cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco SPA122? Incoming calls - phone rings but no (inbound) audio / speech

PNet4um
Grafter
Posts: 27
Registered: 13-02-2010

Cisco SPA122? Incoming calls - phone rings but no (inbound) audio / speech

I apologise for not being able to find the answer to this because I am sure I read a similar problem/solution 3-4 years ago...
The symptom I describe will hopefully make a connection (no pun!) in the mind of someone who understands the protocols, proxies, Stun and all the other SIP/VoIP acronyms...
The Plusnet service, router and Cisco PAPT-"v2" all work perfectly for outbound calls but incoming calls ring but the recipient cannot hear the caller.
I have tried this from 2 * other Plusnet VoIP accounts - using the extension once and PSTN number and then I also tried from a real POTS BT phone and that failed too.
I am pretty sure this worked a month or two ago but can't be 100% certain... Any ideas welcome... I am remote from the router and SPA122 or was it 112 but have remote control of the router - not sure if I can get access to the Cisco device... Must fix that next time on-site!... Thanks in advance... B
5 REPLIES
Community Veteran
Posts: 6,263
Thanks: 433
Fixes: 40
Registered: 30-07-2007

Re: Cisco SPA122? Incoming calls - phone rings but no (inbound) audio / speech

PNet4um
Grafter
Posts: 27
Registered: 13-02-2010

Re: Cisco SPA122? Incoming calls - phone rings but no (inbound) audio / speech

Quote from: MisterW
Does this help http://forums.asterisk.org/viewtopic.php?f=1&t=82387&start=0 ?

Thanks for the link - lots of possibilities therein and even debugging tools...
Maybe my first port (no pun!) of call should be to see if there is a "working" configuration on the Cisco device in a Plusnet (better than assuming Gradwell? equivalent would work?) environment and match that against what I have on the router and Cisco devices. Thanks again.
PNet4um
Grafter
Posts: 27
Registered: 13-02-2010

Re: Cisco SPA122? Incoming calls - phone rings but no (inbound) audio / speech

Quote from: MisterW
Does this help http://forums.asterisk.org/viewtopic.php?f=1&t=82387&start=0 ?
I think that was (the caller) not being able to hear the CALLED number...
Just an update and follow-up question... Today I changed *just one!* of the two lines on the SPA112 and asked someone on-site to test...
The response I got was a little annoying in that *both lines now work!* in both directions...
AFAIK both lines were set-up identically and both had the same problem of the CALLED person NOT HEARING the CALLER a month or two ago...
All I changed was to add the OutBound proxy (nat.plus.net) on port 5082 but what I *didn't do* was get the person on-site to test *before* I made the change...
What effect does a lack of OutBound proxy have? - would it affect both ringing and speaking? or just the latter? Old B...
Community Veteran
Posts: 6,263
Thanks: 433
Fixes: 40
Registered: 30-07-2007

Re: Cisco SPA122? Incoming calls - phone rings but no (inbound) audio / speech

Lack of an OB proxy usually affects incoming audio. Without a proxy, the incoming RTP stream fails to traverse the NAT firewall at your router.
Community Veteran
Posts: 1,817
Thanks: 11
Registered: 30-07-2007

Re: Cisco SPA122? Incoming calls - phone rings but no (inbound) audio / speech

I have the spa122 I have outbound proxy as nat.plus.net:5082
Sorry can't get a decent screen dump while using my tab.