cancel
Showing results for 
Search instead for 
Did you mean: 

Asterisk/FreePBX NAT Nightmares

plusbg
Grafter
Posts: 26
Registered: 24-05-2015

Asterisk/FreePBX NAT Nightmares

Hello peeps :-)
Nice to see others using PBX's on Plusnet and for once not having to resort to the American channels - not having a very friendly time over there :-)
For some totally unknown reason, I cannot get Asterisk/FreePBX to work with the Static IP setting in Asterisk SIP Settings - I cannot get audio at all. As soon as I set it to "Public IP"  - calls work. I have an external static IP (80.*) and an internal static IP (192.*)
I am running Asterisk 11.17.1, FreePBX Distro: 6.12.65-20 and I have the standard Issue Technicolor TG582n router - I read somewhere about turning Sip Alg off through putty  - is that a must or a should? Any other ideas please?
Ports 10000-20000 and 5060 are forwarded to the Server
Thanks  Smiley

1 REPLY
plusbg
Grafter
Posts: 26
Registered: 24-05-2015

Re: Asterisk/FreePBX NAT Nightmares

OK, I think I might have resolved this by turning off SIPALG on the router via Telnet - I've been reading a few articles and i'm unsure of whether SIPALG being turned off will cause problems in itself in terms of keeping the connections active remotely and locally - i.e. ready to receive call - I understand SIPALG was initially supposed to be a helper rather than a hinderer - do I need to set FreePBX differently to compensate for SIP ALG being turned off?
Thanks :-)