cancel
Showing results for 
Search instead for 
Did you mean: 

ATL IP250 Primary Reg err.

eattheword
Grafter
Posts: 57
Thanks: 3
Registered: 07-01-2009

ATL IP250 Primary Reg err.

Hello
I just tried configuring a new ATL IP250 phone to use with my SIP number. To begin, I have put the phone inside the DMZ on my Netgear DG-834GT router in order to avoid any problems with port forwarding. If I get it working then I will bring it out of the DMZ and set up the appropriate port forwards. The phone is plugged via ethernet into one of the ports on the back of the router.
I can't get the phone to work. I first tried putting in the settings that came with the Plusnet "Your new Broadband Phone account" email. However, that just results in the phone displaying a "Primary reg. err." error message and a broken ('beep beep beep') dial tone.
Next I logged onto my broadband phone control panel and noticed it wants me to use sip2.plus.net rather than the sip.plus.net that the email advised. Same result.
Next I blanked the proxy fields on the phone's set up. Same result.
Next I UNTICKED the box on the phone's setup page that says "Send Registration Request with Expire Time". This time the phone appears to be happy and the dial tone is now continuous but if I try calling my Voip line it goes straight to the 'extension xxxxx is unavailable' message and if I try to make a call from the phone the line just goes dead.
Anybody got any hints for what I might try next?
22 REPLIES
Community Veteran
Posts: 6,258
Thanks: 432
Fixes: 39
Registered: 30-07-2007

Re: ATL IP250 Primary Reg err.

Ok, from looking at the manual,  what should work is:-
On the sip server configuration page
sip server - sip.plus.net port 5060
domain - blank ( or possibly newsip )
outbound proxy - nat.plus.net port 5082
send registration request - checked
On the user  details page:-
Phone number - your allocated voip number
caller id - proabably same as phone number
user name - your 7 digit sip id ( extension number )
password - your SIP password ( not necessariry the same as the voip control panel one )
Don't worry about portforwarding, it shouldn't need any and it certainly won't stop it registering!
Hope that helps, post back how that goes.
eattheword
Grafter
Posts: 57
Thanks: 3
Registered: 07-01-2009

Re: ATL IP250 Primary Reg err.

Quote from: MisterW
Ok, from looking at the manual,  what should work is:-
On the sip server configuration page
sip server - sip.plus.net port 5060

Done.
Quote from: MisterW
domain - blank ( or possibly newsip )

Just tried both
Quote from: MisterW
outbound proxy - nat.plus.net port 5082

Done
Quote from: MisterW
send registration request - checked

Done.
Quote from: MisterW
On the user  details page:-
Phone number - your allocated voip number
caller id - proabably same as phone number
user name - your 7 digit sip id ( extension number )
password - your SIP password ( not necessariry the same as the voip control panel one )

Done.
Result: 'Primary Reg. err' message on phone display + broken dial tone.  Cry
Here's the setup screen:

Community Veteran
Posts: 6,258
Thanks: 432
Fixes: 39
Registered: 30-07-2007

Re: ATL IP250 Primary Reg err.

Yep, that sip server page looks fine. My guess is that its an authentication problem.
Is this a new BB phone account ?
Have you tried the account with a softphone to check the account is ok ? ( try X-Lite or 3CX ) - don't use sjphone as suggested on the PlusNet voip site its way out of date!
Are you sure you have the correct sip password ?
Edit: I assume you've set the phones LAN settings to use DHCP and that its getting an IP address from your router ?
eattheword
Grafter
Posts: 57
Thanks: 3
Registered: 07-01-2009

Re: ATL IP250 Primary Reg err.

I installed 3CXPhone on my iPhone which is connected to the same network and it rang when I called it.
The ip250 is registered via DHCP. In fact, I even configured the router to give it a fixed IP address. Checking the phone's internal menus it has picked up the IP address fine, and it is showing the router's IP  as its gateway address.
Community Veteran
Posts: 6,258
Thanks: 432
Fixes: 39
Registered: 30-07-2007

Re: ATL IP250 Primary Reg err.

Ok, so if 3CX works on the Iphone, then your voip account cerentials must be ok. In that case it must be a setup issue on the IP250.
I've just had another trawl through the manual and, I'm clutching at straws here, there are a couple of settings on the Extension page ( page 11 ) that MIGHT be worth trying:-
Encode SIP URI with user parameter - try unchecking
No Authorisation header in re-register - try checking
I'm really not convinced that those are going to do much but its worth trying...
Given that the voip account works, there really shouldn't be much to prevent it at least registering given the sip/proxy servers and authentication
details are set correct;y
eattheword
Grafter
Posts: 57
Thanks: 3
Registered: 07-01-2009

Re: ATL IP250 Primary Reg err.

Thanks for trying to help get this sorted. Alas, those clutched straws yielded the same result...  Cry
I was starting to think it must be something on the router, but as softphones on my computers and on the iPhone work then it seems that it is something specific to the IP250.
Community Veteran
Posts: 6,258
Thanks: 432
Fixes: 39
Registered: 30-07-2007

Re: ATL IP250 Primary Reg err.

No problem, happy to try and help, just sad I've not been able to so far Sad
IP Phones are more difficult to diagnose problems since you can't get any log files from them like you can with softphones.
I'll have another read through the manual and do a bit of googling...
Community Veteran
Posts: 6,258
Thanks: 432
Fixes: 39
Registered: 30-07-2007

Re: ATL IP250 Primary Reg err.

Just reading the 'quick start guide', I notice it says restart the IP250 when the sip settings have been input. The RESET page in the main manual also says reboot to make changes active.
I assume you've rebooted the phone ?
Community Veteran
Posts: 6,258
Thanks: 432
Fixes: 39
Registered: 30-07-2007

Re: ATL IP250 Primary Reg err.

Just thought I'd try the gradwell ( who supply the PlusNet voip ) support site to see if there was anything on there about the IP250.
Found this http://www.gradwell.com/support/kb/article.php?id=92 about the ATL Berkshire 5000.
One interesting thing in there is it sets the domain to sip.gradwell.net. You might try setting the domain on yours to sip.plus.net and see if that makes any difference...
eattheword
Grafter
Posts: 57
Thanks: 3
Registered: 07-01-2009

Re: ATL IP250 Primary Reg err.

Oh yes, I reset the phone after every change of settings.
I had the domain set as sip.plus.net originally.
Community Veteran
Posts: 6,258
Thanks: 432
Fixes: 39
Registered: 30-07-2007

Re: ATL IP250 Primary Reg err.

Back to the drawing board then...
Community Veteran
Posts: 6,258
Thanks: 432
Fixes: 39
Registered: 30-07-2007

Re: ATL IP250 Primary Reg err.

Hi eattheword,
After thinking about it, some more straws to clutch at perhaps...
You say in the first post the IP250 is in the DMZ, have you tried it not in the DMZ ?. With an outbound proxy it shouldn't need any port forwarding and so doesn't need to be in the DMZ.
It might be worth trying explicit IP addresses in the sip server/outbound proxy fields in case its a DNS problem.
On an nslookup, sip.plus.net 79.135.125.154 and nat.plus.net is 79.135.125.160.
Lets see if that makes any difference ?
NB it might also be worth a try with the outbound proxy not set.

eattheword
Grafter
Posts: 57
Thanks: 3
Registered: 07-01-2009

Re: ATL IP250 Primary Reg err.

Hello again. I had intially had it outside the DMZ. I only put it in there to try and remove possible confounding factors. I'll try your suggestions later and see what happens.
Thanks for the help, by the way.  Smiley Smiley
eattheword
Grafter
Posts: 57
Thanks: 3
Registered: 07-01-2009

Re: ATL IP250 Primary Reg err.

Quote from: MisterW
You say in the first post the IP250 is in the DMZ, have you tried it not in the DMZ ?. With an outbound proxy it shouldn't need any port forwarding and so doesn't need to be in the DMZ.

No dice.
Quote from: MisterW
It might be worth trying explicit IP addresses in the sip server/outbound proxy fields in case its a DNS problem.
On an nslookup, sip.plus.net 79.135.125.154 and nat.plus.net is 79.135.125.160.
Lets see if that makes any difference ?

No dice.
Quote from: MisterW
NB it might also be worth a try with the outbound proxy not set.

No dice.
Perhaps it's time to give up on this phone.