cancel
Showing results for 
Search instead for 
Did you mean: 

trying to get no-nat working with 8 ips and a dlink 604t ads

N/A

trying to get no-nat working with 8 ips and a dlink 604t ads

Hi,

Can anyone help me with this problem? I have 8 ips from PN and am trying to get a dlink-604t wireless router to work no-nat
(Im not using the wireless side at all anymore!!!!)

ip range (as example) x.y.z.1 - x.y.z.8
x.y.z.1 - network address
x.y.z.2 - router address
x.y.z.3 - spare
x.y.z.4 - spare
x.y.z.5 - spare
x.y.z.6 - spare
x.y.z.7 - spare
x.y.z.8 - broadcast addy
255.255.255.248 - netmasq

i have curently got the router setup with NAT and a public ip of x.y.z.2 and internal ips in th 10.199.0.q range. this works but i cant use my spare ips for anything Sad

I have had the router set up :-

www ---- > x.y.z.2 (router) x.y.z.3 ------> x.y.z.4 (server)
this worked Smiley
unfortunatly it ment i was down an ip addy (.3) because this had to be assigned to the internal interface of the router.

I contacted dlink tech support, first time they gave me the above config
second time i was told that the only way to do this was to set the router in 'bridged mode' and have the server send it authentication, as the dlink cant authenticate in bridged mode, which would prove VERY hard as im using custom linux kernals with NO ppp style support at all on the server Sad

after looking through the forums i found an article (for another router) that said set the internal AND external interfaces on the router to the same addy, and this didnt apear to work ether Sad

can anyone give me any pointers? or am i just going to have to chuck this router into the bin and get something else?
any sujestions?

Thanks

Matt
6 REPLIES
Community Veteran
Posts: 5,878
Registered: 04-04-2007

trying to get no-nat working with 8 ips and a dlink 604t ads

Hi Matt,

I'm moving this over to the Broadband Help forum, it is in danger of getting lost in the main support forum Smiley

Chris
N/A

Hmm

Does your router support 1-2-1 nats ?


then you

could have


inet>>>>x.x.x.1 Router 10.x.x.1 ----- Server on 10.x.x.2 with a 121 nat of x.x.x.2

still means you get natted out normally but any traffic form the 121 nats perform as if on the internet proper so to speak.


remember to set your rules carefully and open 121 nat your asking for trouble
N/A

cant use nating

the problem i have (and the reason for getting the public ips) is that the software i want to run wont work properly with nat Sad
as far as ive seen theres no option within the router for 121 nat anyway Sad
sorry, thanks for the reply

Matt
Community Veteran
Posts: 1,229
Thanks: 1
Registered: 12-04-2007

trying to get no-nat working with 8 ips and a dlink 604t ads

Have you checked if the software maker you spoke of has a help forum? You may find other peeps with the same issues discussing it there.

Hope so bud. <fingers crossed for ya>
N/A

trying to get no-nat working with 8 ips and a dlink 604t ads

Hi,

I'm a bit confused at the setup or end result that your actually trying to achive. I'm also not sure why you say the router takes up one address when it shouldn't unless you want it to.

Have you tried static routes? to control the follow between internal and external ip addresses
N/A

trying to get no-nat working with 8 ips and a dlink 604t ads

Hi Matt,

I'm not sure about the specifics of your router, but I'm running no-nat on a DSL-500. The critical bit in all of this is getting the router to use "ppp unnumbered". This is a function whereby the ppp interface takes on the IP address of the router's Ethernet interface. Normally just setting the IP address of the ASDL and Ethernet interfaces is not sufficient.

In my case, it involved using the console port of the router (or telnetting to the router if that is supported) and issuing the "ppp 1 unnumbered enable" command. I would suspect this could be the missing piece of the jigsaw for your setup although the function may be turned on in a different way (via the web interface perhaps?). Hope that helps!

Cheers,
Graham