cancel
Showing results for 
Search instead for 
Did you mean: 

newbie adsl user

loony
Grafter
Posts: 174
Thanks: 1
Registered: 24-08-2007

newbie adsl user

i tried your recommendation and it physically looks faster...great!!
but the MTU is still set as 1472!? but i set it as 1478 in the origo wan setup..as you said and the changes took. any ideas?

Receive Window (RWIN): 17256
Window Scaling: off
Path MTU Discovery: ON
RFC1323 Window Scaling: OFF
RFC1323 Time Stamping: OFF
Selective Acks: ON
MSS requested: 1432
TTL: unknown
TTL remaining: 53

2. Test 146000 byte download
Actual data bytes sent: 154592
Actual data packets: 108
Max packet sent (MTU): 1472
Max packet recd (MTU): 1472
Retransmitted data packets: 6
sacks you sent: 22
pushed data pkts: 18
data transmit time: 2.651 secs
our max idletime: 148.5 ms
transfer rate: 44792 bytes/sec
transfer rate: 358 kbits/sec
This is not a speed test!
transfer efficiency: 94%


3. ICMP (ping) check
Target unpingable

and getting 491 kpbs true speed from adsl guide speed test

thanks for the advice any way
jp
16 REPLIES
loony
Grafter
Posts: 174
Thanks: 1
Registered: 24-08-2007

newbie adsl user

hello ,
i've been online(ADSL) two days now and am still learning ,but i have read the sticky post about MTU tweaking and have got Dr TCP and followed the instuctions.
these are the results:
1. Your Tweakable Settings:
Receive Window (RWIN): 17256
Window Scaling: off
Path MTU Discovery: ON
RFC1323 Window Scaling: OFF
RFC1323 Time Stamping: OFF
Selective Acks: ON
MSS requested: 1432
TTL: unknown
TTL remaining: 51

2. Test 146000 byte download
Actual data bytes sent: 154592
Actual data packets: 108
Max packet sent (MTU): 1472
Max packet recd (MTU): 1472
Retransmitted data packets: 6
sacks you sent: 21
pushed data pkts: 17
data transmit time: 3.247 secs
our max idletime: 249.8 ms
transfer rate: 37944 bytes/sec
transfer rate: 303 kbits/sec
This is not a speed test!
transfer efficiency: 94%


3. ICMP (ping) check
Target unpingable


and speed test results from ADSL guide are :actual speed 453 kpbs.
true speed :489 kbps

i have an origo 8400 ethernet modem router
just wondering how to get the best(100%) out of my connection
can anyone advise me what to do next?
thanks
jason
N/A

newbie adsl user

Question - did you set MTU to 1472 with DrTCP
or is that the value your router defaults to?
Also could you check your Exchange status .
Alec
loony
Grafter
Posts: 174
Thanks: 1
Registered: 24-08-2007

exchange status and MTU default

Current Status : (Green)
There are currently no known capacity problems on your exchange. There may still be an exchange problem, however BT are not currently reporting that they are aware of it. Please contact Support if you are having speed problems and we will advise further.

Record Last Updated : 26/01/2004

Note: All data on this page is provided by BT as a rough guide to the current state of each exchange. PlusNet can not guarantee the accuracy of this information.

To learn more about the ADSL network in Britain, please see PlusNet's Network page and information page.

and the modem seems to set default MTU to 1472, i have DrTCP set to 1478
thanks
jp
N/A

newbie adsl user

Your getting the same speeds and 4% packet loss
as I do.
The speed result isn't that bad if you compare it to
Plusnet average last month of 435Kb/s and the average
from the fastest ISP of 448Kb.
You are able to set MTU on some Origo models via the
Routers set up page, go to, Advanced set up - WAN set up,
Set the values of MTU & MRU to 1478, save and re-boot.
( I think you may need to power down for at least 30 secs)
Alternatively set MTU to 1472 with DrTCP on your PC's to
equal that of your router. If using MTU 1472 then set
RWIN to 17184 and try other multiples of 1432.
Other options are to try lower MTU settings eg 1430 or 1458,
some people are still getting good results with the old
1430/13900 MTU/RWIN settings.
You may be able to get rid of the packet loss by using
a very low RWIN of MSS x 4 and may see a jump
of 10Kb on ADSLguide.
However this may reduce speeds on long distance servers,
you can check this by taking the DSLreports speedtest and
various 'surfing' tests at Numion, it really depends on what you
are using your connection for.
Alec
N/A

newbie adsl user

Your MTU is still 1472, if you changed both MTU & MRU
in your router set up to 1478, double check on DrTCP
that you set MTU to 1478 in the drop down box where
your network adapter is listed and also try setting it
in the Box 'Dial up MTURAS'.
Your routers firmware maybe defaulting to 1472
maybe some Origo users can comment.
If that's the case you may aswell set the same value on your
PC's. This will avoid fragmentation between your
router & PC , it gives the router less work to do,
although it isn't a problem for most.
Alec
loony
Grafter
Posts: 174
Thanks: 1
Registered: 24-08-2007

newbie adsl user

getting there, should i change the RWIN back to 17256?

1. Your Tweakable Settings:
Receive Window (RWIN): 17184
Window Scaling: off
Path MTU Discovery: ON
RFC1323 Window Scaling: OFF
RFC1323 Time Stamping: OFF
Selective Acks: ON
MSS requested: 1418
TTL: unknown
TTL remaining: 51

2. Test 146000 byte download
Actual data bytes sent: 150254
Actual data packets: 106
Max packet sent (MTU): 1458
Max packet recd (MTU): 1458
Retransmitted data packets: 3
sacks you sent: 15
pushed data pkts: 15
data transmit time: 2.687 secs
our max idletime: 143.1 ms
transfer rate: 44945 bytes/sec
transfer rate: 359 kbits/sec
This is not a speed test!
transfer efficiency: 97%
N/A

newbie adsl user

Your now using an MTU of 1458 so the recomendation
is to use multiples of MSS, for RWIN, basically deduct 40
from MTU, MSS= 1418 , 1418 x 12 = 17016.
1478/17256 , 1472/17184, 1458/17016 etc.
Also note that the Tweak test will give varying
results you may get 94% efficiency for one test followed by
99% for the next test using the same values, you need to take
a few.
loony
Grafter
Posts: 174
Thanks: 1
Registered: 24-08-2007

newbie adsl user

ok run out of tests for a few hours BBL
thanks v much for your advice alec
jason
loony
Grafter
Posts: 174
Thanks: 1
Registered: 24-08-2007

newbie adsl user

i seem to have confused myself a little after reading this post:
http://adsltech.com/forum/forum_posts.asp?TID=1174&KW=MTU
not sure what to do, as in settings.what do you think?
connection running ok


1. Your Tweakable Settings:
Receive Window (RWIN): 17016
Window Scaling: off
Path MTU Discovery: ON
RFC1323 Window Scaling: OFF
RFC1323 Time Stamping: OFF
Selective Acks: ON
MSS requested: 1418
TTL: unknown
TTL remaining: 51

2. Test 146000 byte download
Actual data bytes sent: 154508
Actual data packets: 109
Max packet sent (MTU): 1458
Max packet recd (MTU): 1458
Retransmitted data packets: 6
sacks you sent: 24
pushed data pkts: 16
data transmit time: 2.897 secs
our max idletime: 142.9 ms
transfer rate: 42124 bytes/sec
transfer rate: 336 kbits/sec
This is not a speed test!
transfer efficiency: 94%

Downstream 455 Kbps (56.9 KB/sec) 491 Kbps (inc. overheads)
Upstream 191 Kbps (23.9 KB/sec) 206 Kbps (inc. overheads

Dr TCP set at
RWIN 17016
mtu 1478
dial up mtu 1478
and router set as in WAN mtu 1478, mru 1478
thanks
jp
N/A

newbie adsl user

But in your first post MTU was 1472 now its
1458 according to DSLreports, where did
you set MTU at 1458 ? or did you make any other
changes, I'm trying to figure out what's changing MTU.
Alec
loony
Grafter
Posts: 174
Thanks: 1
Registered: 24-08-2007

newbie adsl user

i havent changed MTU to 1458
i've just checked the router it's set at mtu and mru 1478 in the WAN
DR Tcp set at MTU 1478
i don't know where dslreports got 1458 from?
and i havent mad any other changes other than whats been said here.
N/A

newbie adsl user

OK this is wierd, the link from the ASR forum
says the default setting of the router is 1492
this gave MTU of 1472 on the tweaktest .
You then set MTU to 1478 on the router
and we ended up with MTU of 1458 on tweak test
20 less than you set router in both cases.
I would suggest you try setting the router to 1498
if its possible and leave DrTCP at 1478.
If that doesn't work then set the router back to it's original
default and then set DrTCP at 1472.
If your happy with 1458 ie if it feels faster then leave router at
1478 and set DrTCP to 1458.
loony
Grafter
Posts: 174
Thanks: 1
Registered: 24-08-2007

newbie adsl user

1. Your Tweakable Settings:
Receive Window (RWIN): 17016
Window Scaling: off
Path MTU Discovery: ON
RFC1323 Window Scaling: OFF
RFC1323 Time Stamping: OFF
Selective Acks: ON
MSS requested: 1432
TTL: unknown
TTL remaining: 53

2. Test 146000 byte download
Actual data bytes sent: 153160
Actual data packets: 107
Max packet sent (MTU): 1472
Max packet recd (MTU): 1472
Retransmitted data packets: 5
sacks you sent: 21
pushed data pkts: 18
data transmit time: 2.980 secs
our max idletime: 155.1 ms
transfer rate: 40588 bytes/sec
transfer rate: 324 kbits/sec
This is not a speed test!
transfer efficiency: 95%

going to change rwin to 17184
N/A

newbie adsl user

I think that's the best your going to get
unless an Origo user can advise different Smiley