cancel
Showing results for 
Search instead for 
Did you mean: 

Zipb on solwise 130 linux dhcp loss of gateway

N/A

Zipb on solwise 130 linux dhcp loss of gateway

I have a strange proble I have configured my solwise 130 to use zipb as to the manual. It works fine with windows XP the IP is transfered tp the PC at the other end.
When I switch the mode over to the Linux box I wish to be my router I get a DHCP message

Determining IP information for eth0... SIOCADDRT: Network is unreachable done1.

/sbin/ifup :Line269:[: :integer expression expected
IP is traansfered when I check wth ifconfig

But when I then use route there is no default route gateway.

So nothing will go out of the box
I know the DHCP is working correctly on the Linux box.
If I then add Gateway
% route add default gw MyPlusnetIPaddress

Then it works

Does anyone know what is going on with the solwise 130 router
4 REPLIES
N/A

Zipb on solwise 130 linux dhcp loss of gateway

Well I have found out a bit more I have basically two problems

1. where is the default gate way this I rectified by the
% route add default gw MYPlusnetIP

Then the the information in the solwise 130 manual appears to be questionable for linux....? Comments welcome.
It would appear if you assign a DHCP pool as sugested then the namserver is given back via the DHCP from Plusnet via the 130 as 192.168.7.1 hence no DNS works (direct IP addresses do of course ).As the DHCP request in Linux over writes the resolv.conf file with the new information gained from the 130.
so you end up with . You can check this out by looking at /var/lib/dhcp/dhclient-eth0.leases

nameserver 192.168.7.1 in the file resolv.conf

You can of course change this back to
nameserver 212.158.13.49
nameserver 212.158.13.50

but each time the eth0 link goes up and down you will have to over write this information along with the default gate way.

I have over come the namserver problem by adding the correct DNS entries in the DHCP pool NOT leaving them Blank.

So I only have the routing default gae way to solve then perhaps I will not have to apply this everytime..

Does any one have a suggestion......for this..?
painswck
Grafter
Posts: 449
Registered: 30-07-2007

Zipb on solwise 130 linux dhcp loss of gateway

Hi,

You may have already tried this but have you asked the same question in the forum on the Slowise site. I have found the users on there very helpful.

Cheers

Roland
benoh
Grafter
Posts: 272
Registered: 24-08-2007

Zipb on solwise 130 linux dhcp loss of gateway

Try this page to stop overwriting your /etc/resolv.conf

http://lists.debian.org/debian-user/2003/debian-user-200301/msg00578.html
N/A

Zipb on solwise 130 linux dhcp loss of gateway

I have over come the resolv.conf problems by adding the DNS server addresses in the DHP pool configuration in the Solwise 130. This works fine, but as mentioned it is not to the instructions from the manual ... which I think are a bit unhelpful for a Linux user ...It only shows a Windows OS system booting in this which does work ..I tried this first. then moved on to the linux box .. .
This does lead you to think whether the modem has been tested in a connection to a Linux Box?

I will have a look on the solwise site..... This is really basic and I am suprised the Modem just doesn't work the manual suggests it should.

I have it working its just a pain having to add the default route ... and having to waste so much time in the dark.

...Thanks for the comments