cancel
Showing results for 
Search instead for 
Did you mean: 

Web pages initially slow to load!

N/A

Web pages initially slow to load!

I've had this problem for a while now and it seems to effect most computers in my house, one more so than the others (and that is the one directly connected to the router via USB whilst the other are via LAN!)
The problem is that when i connect to one of my frequent pages, such as www.play.com, www.bbc.co.uk or www.ebay.co.uk, all big pages that should run fine, i get a rather annoying wait when i first connect to the site.
EG: www.bbc.co.uk just took about 20seconds to load, of which 19 seconds of that was just my browser (firefox) sitting there with a 'looking up bbc.co.uk' status message! Again when i do the same to www.play.com its 15 seconds with the same status message. Now i've connected to the site i can browse freely and new pages load within seconds!
Why does it take so long to do this initially as it's very annoying. Especially as site such as bbc usually have links like news.bc.co.uk which then involves another 20-30 second wait!
My speeds are good, last speed test ranked me at 485 and 482 which is better than that expected for 512k. I've fiddled with the MTU and RWIN for my router and computers but they all seem to be fine (set at MTU 1500 on computer and a slightly lower defualt on my router 1492)
Is there anything to do that will correct this problem?

btw, it may be worth noticing i had this problem with IE and it was painfully slow so i switched to Firefox and Opera and both browsers worked alot better. Now they've slowed a bit too, though not as much. I've also sweeped my com for spyware on a regular basis and have visus and firewall protection configured and updated.

any help much appreciated. Thanks

Matt
6 REPLIES
N/A

Web pages initially slow to load!

First off all the sites you mention are dynamic pages so the speed of the server may be the issue. Is it only on dynamic pages that this happens?

The second thing it could be is a very slow dns responce which is causing the problem. You can try opening a cmd window and ping the site this will give you an ip for the site. Try using the ip to connect and see if it solves it. Play.com is 213.167.82.37 the bbc is 212.58.224.35.

If that solves it enter the ips in your host file which means you wont have to resolve the ip again.

What are you using as a dns if its your router then by default some use a USA dns?
N/A

Web pages initially slow to load!

hey for some reason, i tried the ping, but it kept saying request timed out. Also, said "pinging 213.167.82.37 with 32 bytes of data."

Something i am doing wrong? i havent messed with any setting, but webpages for me also tend to load slow.
N/A

Web pages initially slow to load!

well i've tried pinging and for some reason i cant ping anywhere outside my LAN! A bit wierd! I've adjusted the ping settings, had longger TTL's, bigger packets etc and stil no luck! I'm using the plus.net DNS's and some public ones as backups but there not used unless plus goes down.
N/A

Web pages initially slow to load!

hey could you tell me what PN DNS is? I dont know if ive been using the right IP to ping
holdtight
Grafter
Posts: 1,634
Registered: 15-06-2007

Web pages initially slow to load!

212.159.13.49
212.159.13.50

212.159.6.9
212.159.6.10
N/A

Web pages initially slow to load!

The highest MTU i can get is 1450? Is this normal, as others are getting the 1478's etc. But when i ping, it says packets need to be fragmented but DF set? This is on all the IP's u gave me