cancel
Showing results for 
Search instead for 
Did you mean: 

Upstream speed problem

N/A

Upstream speed problem

I have two Linux machines running different versions of SuSE Linux. I have a 512 kbps broadband account. On both machines the download speeds from ADSLguide.org are sensible at 490-500 kbps, but the upstream speed on one machine (SuSE 9.1) is only 31 kbps, whereas it's a sensible 250-260 kbps on the other machine (SuSE 8.2).

Can anyone suggest what the problem might be with the slow upstream machine?

TIA, Eric
2 REPLIES
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Upstream speed problem

A few suggestions to try and isolate the problem - i.e. a process of elimination

Have you power cycled the router?

Have you power cycled the SuSe boxes (making sure it completly powers off rather than automatically rebooting)

if you unplug both PC's Ethernet cables from your router and swap them over (i.e. before PC1 was in port 1, PC2 was in port 2. after PC1in port 2, PC 2 on port 1), does the problem stay with the port or the SuSe system?

Have you trie plugging the bad system into another port on your router.

Have you tried a different cable on your slow PC? I.e. eliminate a cable problem.

Have you tried the slow system with the other one unplugged from the router.

Try swapping over the cables between PCs and see if the problem stays with the PC or the cable.

Finally, try swapping over the network cards in the PCs and see if the problem stays with the card. If they are different NICs you may not want to do this.
N/A

Upstream speed problem

Quote
A few suggestions to try and isolate the problem - i.e. a process of elimination
... etc.

Many thanks for the suggestions. I've tried all of them, except for swapping the network cards (which is impossible because they're incorporated in the motherboards). Whatever I did, the problem stayed with the same PC.

However this morning I conducted a small experiment. I uploaded a few files of different sizes to my PlusNet webspace, and timed the transfers. The file sizes and timings are as follows:

443,340 bytes: 12 secs = 36 kbytes/sec
2,343,308 bytes: 75 secs = 30.5 kbytes/sec
5,662,759 bytes: 185 secs = 29.9 kbytes/sec

The timings aren't very accurate (I just used the second hand of my watch), and the last one is likely to be the most accurate, but all the results are in the region of the expected speed.

I've concluded that I don't seem to have a problem, and that the adslguide results (which are entirely repeatable) must be caused by some incompatibility between this PC setup and their speed test.

Eric