cancel
Showing results for 
Search instead for 
Did you mean: 

Upgraded to brandband - problems with smoothwall

N/A

Upgraded to brandband - problems with smoothwall

I've just upgraded from a 56k line with freeserve to 512k service with plus net. I used to have my modem plugged into a Smoothwall box to easily allow me to dial up from any of the computers and share my the connection on my LAN at home. I had intended to carry on using Smoothwall when I upgraded, but I've been having a few problems setting it up. It looks like there are a few users out there who are already using Smoothwall with their plus.net account and I wonder if anyone can offer any advice.

For simplicity I decided to go for the 4 port router supplied by plus.net - it's a Binatone 2100. I've not been able to find out much about them on the web, although their support desk was reasonably quick getting back to me. I know the router in it's default state work fine, because currently I have everything plugged straight into it. It's doing DHCP and firewall stuff, but I can't help thinking I'll get some more control with Smoothwall.


For all you smoothies out there, my intention was to implement router<-->red<-->smoothwall<-->green<-->hub<-->LAN machines. For all you non-smoothies out there that basically means setting the router up in bridging mode connected to one nic and connecting the rest of the LAN to another nic. Fine in theory.

As I've said the default settings for the router are pretty much fine (although you have to switch the firewall on), so you pop you account details in and hit the connect button. Cool.

However the problems comes when I need to set the router up ready for smoothwall. The binatone support people said

"As the ADSL 2100 has a built in processor running a version of Linux and also has a built in firewall I would be reluctant to use it in bridging mode, however if you want to do this you need to switch off the DHCP server, uncheck the NAT and enable PPP half bridge mode, but only do this after checking that the router will connect in normal mode. Another thing to take into account is that in this mode you can only use it with one computer connected."

The documentation that is supplied with the router is a bit basic. It's a "Quick Start" guide and doesn't even mention half the settings available via the web front end. I'm fairly confident I've switched off the DHCP and NAT and set enable bridge mode. Going by what the support chappy said, I should be good to go at this point, so I save the settings and router reboots. At this point I plug the router straight into the smoothwall machine. Of course at this point I can no longer see the router's web interface as smoothwall is designed to run in a headless environment. Just for luck I reboot the router. The astute amongst you may have noticed a galring problem. If I can't get to the web interface of the router, how do I force it to connect? I never get the PPP light on the router when it's connected, and I just assumed that the change of settings would force it to automatically connect - maybe a stupid assumption?!?!

When I boot the smoothwall box, i comes back with some errors which seem to relate to not being able to get an IP address for the red interface.

I assumed that everything else would remain the same as far as the LAN connections and smoothwall were concerned - that's certainly what the smoothwall docs imply, but I couldn't get any of the other machines to see each other or the smoothwall box. I think smoothwall gets itself confused when booting? So it's a bit of a mess. As I've said, I've reverted to the bog standard direct connection to the router which works fine, and I'm at work at the mo, so can't do anything about it, but wondered if anyone out there could shed any light before I have another go at the weekend.

Cheers
aw
2 REPLIES
N/A

Upgraded to brandband - problems with smoothwall

I'm using IPCOP with a DG814 modem/router.
The only way I could get the pair to work was to leave DHCP and NAT switched on on the DG814 and limit the DHCP range to one IP address (192.168.0.2).
This is then assigned to the IPCOP box by DHCP. I set up a DMZ on the DG814 pointing to the IP address of the IPCOP box (192.168.0.2) so all traffic is routed to IPCOP.

I had to do this as I couldn't find any bridging mode on the DG814.
The downside is that IPCOP has an internal IP address rather than the ISP assigned address which is picked up by the DG814.

IPCOP then assigns ip addresses to my internal network.

If you are really stuck you could give this a try. From memory I think IPCOP and smoothwall are very similar.
N/A

Upgraded to brandband - problems with smoothwall

first of all give ur router a static ip, then give your smooth wall box 2 static ips (for both nics)

i would sugest your router having 10.10.10.1 as its ip and 255.255.255.0 as its subnet, and ur smoothwall having 10.10.10.2 as its ip and 255.255.255.0 as its subnet once again

now unplug your router, and reboot smoothwal, it SHOULD come up without a problem. now, if that works. turn it off. plug in ur router, and then boot smoothwall again. if you did it right it should see ur router. You should not have to disable nat, but if you are behind the smoothwal then there is no point in having it enabled as smoothwall will do it for you, and all you need to do is send all the packets from router to sw any how.

now, within your lan you should set up ur ips to either be dynamic within the range of 10.10.10.X or just make them static in the same range. this will allow you to run servers and the like.

tbh, you may want to change the way you have got your network set up, get your self a reasonable modem and plug that into ur smoothall, then use a swich (not a hub) for your internal lan.

unless of course you can run VPNs on ur router then u could just use that and remove the hub.