cancel
Showing results for 
Search instead for 
Did you mean: 

Terrible Terrible Terrible Service!

N/A

Terrible Terrible Terrible Service!

I am outraged by the total carelessness of Plusnet in trying to provide me with a working connection. I subscribed more than a month ago and still do not have a sync!

I subscribed on the 13th of June, Plusnet duly took payment of the activation fee, my line was confirmed active by BT and Plusnet too my first monthly subscription payment on June 22. Since then, I have bought the equipment, performed countless tests on my line, borrowed a new modem to test my line (which obviously does-not-work!), had my modem tested on another line, waited
endless hours to speak on the phone with Customer Support (more than 10 times at an average of 40 minutes a time!), written
many many emails, opened 5 different tickets open (Plusnet keep closing them considering the issue solved!) yet I am still unable to connect. Almost forgot, Plusnet have taken payment for my second month the other day!!!
They have still been unable to arrange for a BT engineer to come to my place! (actually , I had to call Customer Support and suggest that they arrange an engineer to check my line, Plusnet did not even propose that to me!)

I am totally dissatisfied and startled by the incompetence of Plusnet.

Hope nobody else has been treated the same way, I certainly will not be recommending Plusnet to anybody. Of course this same posting will go on all adsl forums I can think of.

bests
12 REPLIES
N/A

RE: Terrible Terrible Terrible Service!

http://www.broadband-help.com/home.asp
>
> Hope nobody else has been treated the same way, I certainly will not be recommending Plusnet to anybody. Of course this same posting will go on all adsl forums I can think of.
>
> bests

N/A

RE: Terrible Terrible Terrible Service!

> http://www.broadband-help.com/home.asp
> >
> > Hope nobody else has been treated the same way, I certainly will not be recommending Plusnet to anybody. Of course this same posting will go on all adsl forums I can think of.
> >
> > bests
>
>
I've found them helpfull, posted a message on the portal last week & someone rang me about 10 min later.
Must admit the help line is a wast of time but if you do get through found them OK.

Lenny
N/A

RE: Terrible Terrible Terrible Service!

I am in a similar position (first payment on 25th June) and still have no activation/connection as yet. I am also in correspondance (via email) with Customer Support. As far as I can ascertian my modem is working fine.

I feel they could be doing more to help and have had no confirmation that they have done any checks on my line? Their response time to my postings have been quite fast - although usually very short in content. Although my last posting is now almost 24hours old and still no reply.

Running out of options (and patience) and would appreciate any comments from anyone. I am using an Alcatel PCI card and running WIN98.




///////////////
> I am outraged by the total carelessness of Plusnet in trying to provide me with a working connection. I subscribed more than a month ago and still do not have a sync!
>
> I subscribed on the 13th of June, Plusnet duly took payment of the activation fee, my line was confirmed active by BT and Plusnet too my first monthly subscription payment on June 22. Since then, I have bought the equipment, performed countless tests on my line, borrowed a new modem to test my line (which obviously does-not-work!), had my modem tested on another line, waited
> endless hours to speak on the phone with Customer Support (more than 10 times at an average of 40 minutes a time!), written
> many many emails, opened 5 different tickets open (Plusnet keep closing them considering the issue solved!) yet I am still unable to connect. Almost forgot, Plusnet have taken payment for my second month the other day!!!
> They have still been unable to arrange for a BT engineer to come to my place! (actually , I had to call Customer Support and suggest that they arrange an engineer to check my line, Plusnet did not even propose that to me!)
>
> I am totally dissatisfied and startled by the incompetence of Plusnet.
>
> Hope nobody else has been treated the same way, I certainly will not be recommending Plusnet to anybody. Of course this same posting will go on all adsl forums I can think of.
>
> bests

N/A

RE: Terrible Terrible Terrible Service!

> I am in a similar position (first payment on
> 25th June) and still have no
> activation/connection as yet.

> Running out of options (and patience) and would
> appreciate any comments from anyone.

A very similar thing happened to me when my line was activated. However I found CS to be good. I got a checklist to complete (could I connect to the bt_test domain, could I ping the DNS etc) and once they were sure that the problem lay at BT's door they passed it to them and chased the ticket. I can't fault the service I received from PlusNet, although BT are a completely different matter.
--
Slàinte!
Al

[ADSL Home self-install + Asus 6000EV]
N/A

RE: Terrible Terrible Terrible Service!

Well yes CS do answer, and at first I did appreciate that, but the thing is they do not walk the whole mile, do not chase the problem until it's been solved, leave it to you (me) to chase them to have the problem solved. I understand a good part of the fault lies with BT, but CS have not been up to the job, in my case. And it's getting really late. Maybe the reason is also that I speak/get emailed by different people every time, and they lose track of what my problem is, where I stand in terms of tests, etc.

[MAC OSX and SMC7401]


> > I am in a similar position (first payment on
> > 25th June) and still have no
> > activation/connection as yet.
>
> > Running out of options (and patience) and would
> > appreciate any comments from anyone.
>
> A very similar thing happened to me when my line was activated. However I found CS to be good. I got a checklist to complete (could I connect to the bt_test domain, could I ping the DNS etc) and once they were sure that the problem lay at BT's door they passed it to them and chased the ticket. I can't fault the service I received from PlusNet, although BT are a completely different matter.
>
> --
> Slàinte!
> Al
>
> [ADSL Home self-install + Asus 6000EV]

N/A

RE: Terrible Terrible Terrible Service!

> Well yes CS do answer, and at first I did
> appreciate that, but the thing is they do not
> walk the whole mile, do not chase the problem
> until it's been solved, leave it to you (me) to
> chase them to have the problem solved.

That wasn't my experience, and I'm sorry to hear that yours has been like this.

One tip I received was *always* ensure that the ticket is returned to yourself for closing. That way you retain ownership of the problem and can 'keep the ball rolling' until you're satisfied with the outcome.
--
Slàinte!
Al

[ADSL Home self-install + Asus 6000EV]
N/A

RE: Terrible Terrible Terrible Service!

> question for you did you take up the home install package if so what adsl modem r u useing and what system r u running too and do you havd a spliter in line

email me back ill try to help or we can go onto a chat room on my msn fo you

rich@tech007uk.co.uk
N/A

RE: Terrible Terrible Terrible Service!

> question for you did you take up the home install package if so what adsl modem r u useing and what system r u running too and do you havd a spliter in line

email me back ill try to help or we can go onto a chat room on my msn fo you

rich@tech007uk.co.uk
N/A

RE: Terrible Terrible Terrible Service!

> I am outraged by the total carelessness of Plusnet in trying to provide me with a working connection. I subscribed more than a month ago and still do not have a sync!
>
> I subscribed on the 13th of June, Plusnet duly took payment of the activation fee, my line was confirmed active by BT and Plusnet too my first monthly subscription payment on June 22. Since then, I have bought the equipment, performed countless tests on my line, borrowed a new modem to test my line (which obviously does-not-work!), had my modem tested on another line, waited
> endless hours to speak on the phone with Customer Support (more than 10 times at an average of 40 minutes a time!), written
> many many emails, opened 5 different tickets open (Plusnet keep closing them considering the issue solved!) yet I am still unable to connect. Almost forgot, Plusnet have taken payment for my second month the other day!!!
> They have still been unable to arrange for a BT engineer to come to my place! (actually , I had to call Customer Support and suggest that they arrange an engineer to check my line, Plusnet did not even propose that to me!)
>
> I am totally dissatisfied and startled by the incompetence of Plusnet.
>
> Hope nobody else has been treated the same way, I certainly will not be recommending Plusnet to anybody. Of course this same posting will go on all adsl forums I can think of.
>
> bests

Dear Dante,

First of all, we would like to apologise for the delay in getting your line activated - your ticket is now in the process of being escalated to BT in order for an engineer to investigate the problem at the exchange and your premesis if neccessary.
We will of course let you know the time of any visit needed, and when a retest of the connection is required.
We will also look into getting possible compensation from BT for an early life failure credit.

Kind Regards,

Richard

--
| Richard Allen Unmetered & ADSL solutions
| Customer Support for Home & Business
| PlusNet Technologies Ltd http://www.plus.net
+ ----- My Referrals - It pays to recommend PlusNet -----
N/A

RE: Terrible Terrible Terrible Service!

Richard, you seem to care. However, just to let you (and others if interested) see what is going on with my account, in case you don't know that already, I will tell you about the past week.

On Friday 19th I called CS. After the call, CS posted the following on my ticket:

"2002-07-19
Customer has not been able to use the service since activation and would like some clear and defined answers when the fault is scheduled to be fixed. Also, seeing as the service has been unuseable since activation customer is also pursuing cancelling the account and chosing another ISP for broadband. Assigned"

Another posting the same day:

"Can we arrange for a visit by a BT engineer should bt require one as customer wishes this issue to be resolved asap. Assigned "

two days later Escalations replied:

"2002-07-21
17:19:59 Comment By: CSC - Escalations If the customer wishes to have an engineer sent out without BT reuqesting it they must put here, in contact us via the portal, that they agree to pay the callout charge if this proves to be a local problem.
The callout charge is £140
Please contact the customer and get him to append the necessary comments to this ticket and we will book an engineer Assigned "

I then called again:

"2002-07-22
11:24:56 Comment By: Customer Support Centre Spoke to customer today and explained that if BT engineer calls and no fault is found with the line then he will be charged.He agreed to this.can we arrange for BT to visit this week if poss. Assigned
2002-07-22"

They promised to call me back the same afternoon. They didn't. I called again the following day:

"2002-07-23
17:27:54 Comment By: Customer Support Centre Customer wants BT engineer to come round. He will be available all week. Please phone him with BT engineers appointment time. Assigned "

Once more, they promised to call me back the same afternoon. They didn't. I called again the following day (yesterday) and they said that I needed to post myself my consent to the visit of the BT engineer. So I did that:

"2002-07-24
17:25:04 Comment By: You I wish to have an engineer sent out to my place, and I agree to pay the callout charge if the problem proves to lie with my equipment rather than with the line or the service.Regards Assigned"

Other posting from CS:

"2002-07-24
17:32:00 Comment By: Customer Support Centre Thank you for this information and we apologise that this request has not been actioned up to now.

[...]

We will now contact BT and get them to send an engineer to your house for further investigation.
........

FAO Escalations. Please contact BT and have an engineer to go to the customer's house to investigate the ADSL problem. Assigned"

Now this posting today from escalations (the same that told me they would send a BT engineer if I consented to paying the fee!):

"2002-07-25
07:10:32 Comment By: CSC - Escalations BT faults will be chased - however if they have not requested an engineer attend site then they may not send one. BT ask to goto customers site not the other way round - we will ask them to attend however. Assigned "

I mean it's totally absurd. We're exchanging emails, postings, phone calls and meanwhile nothing is happening and days are going by.

Isn't this "terrible terrible terrible" service?
N/A

RE: Terrible Terrible Terrible Service!

> Richard, you seem to care. However, just to let you (and others if interested) see what is going on with my account, in case you don't know that already, I will tell you about the past week.

Hi Dante,

I have just further expedited this for you.

Kind Regards,

Richard

--
| Richard Allen Unmetered & ADSL solutions
| Customer Support for Home & Business
| PlusNet Technologies Ltd http://www.plus.net
+ ----- My Referrals - It pays to recommend PlusNet -----
N/A

RE: Terrible Terrible Terrible Service!

> I am outraged by the total carelessness of Plusnet in trying to provide me with a working connection. I subscribed more than a month ago and still do not have a sync!
>
Hi Steve,
I had a similar problem (ADSL supposedly activated) but no sync on the modem (see the 'flashing green light' post). I found that any updates entered in issues over the web did not appear to get any response. I quickly found out that I had to followup with a phone call and then the update was actioned.
Anyhow, the problem with my connection turned out to be with the splitter that I was using. For some reason the modem (DSL-200) does not seem to recognise the signal coming from it. What I have found is that by connecting the cable directly from the phone socket to the modem (RJ-11 to BT631A cable) that the modem now recognises the sync and I can connect. How are you connecting? Hove you tried the direct connection?
Regards,
Dave