cancel
Showing results for 
Search instead for 
Did you mean: 

Speedtouch 530 setup

N/A

Speedtouch 530 setup

I'm trying to setup the Speedtouch 530 for the first time.

I've plugged everything in, loaded the USB drivers from CD (verified as latest) and run the configuration setup but didn't reconfigure the router as the it said that this had been done previously. I've checked with dslsource.co.uk earlier today and they said I didn't need to reconfigure this nor specify the ISP username/pwd at this stage.

However I can't understand how this would work.

When I try to point the browser to the router I get my old Dial-Up Connection window saying I need to connect to view the page. The only connections in the list are my old 56k modem connections.

I've successfully pinged the router to make sure the PC can see it.

Also the DSL/WAN indicator on the router is a solid amber indicating the DSL line's sync'd but the end-to-end connection is not active.

So do I need to setup those userid/pwd at config stage or not ? Or am I going wrong somewhere else ?

Thanks for your help.

Silver.
3 REPLIES
N/A

RE: Speedtouch 530 setup


Hi I'm using a speedtouch 510v4 which uses the same configeration software. Below is what I had to do and I'm sure it will be the same for you.

First you need to set your browser up to access the internet via the router. Do this by opening IE then Tools menu -> internet options -> connections -> Radio button 'Never dial a connection'.

Second you should have a new icon on your desktop if you've run the setup correctly. Click on this and you get to the web page based config menus. Under the 'Basic' link click on 'connect'. This is where you enter the username and password as you did not enter these at initial setup.

Your user name is: silveray@plusdsl.net enter your password. You must then press 'connect' link. Everything should then go. Next you must click the link at the top left which says 'save all' so that your password and username get saved. Its worth clicking the advanced tab -> setup just to check what the default service description is.

If you've not already done the MTU and RWIN tweaks for your network cards, its worth checking the values at www.dslreports/tweaks and I suggest you modify them to MTU of 1458 and tcpRecWin of 14180. This gives me rock steady speeds. Don't bother trying to change the MTU of the router it will be set at 1500 by default and as long as its value is greater than the setting on your cards the data packets just pass through.

Come back if you still can't get connected.

Cliff
N/A

RE: Speedtouch 530 setup

Thanks for that. Did all the above and it's working now. I can finally say goodbye to me 56k modem! Smiley

I've just got to do the MTU/RWIN settings.

Cheers.

Silver
N/A

RE: Speedtouch 530 setup

> Thanks for that. Did all the above and it's working now. I can finally say goodbye to me 56k modem! Smiley
>
> I've just got to do the MTU/RWIN settings.
>
> Cheers.
>
> Silver

Glad i could help.

Just one other thing the firewall is enabled by default, but there arn't any rules set up so everything passes through.

If you go to this web site they have some good advice as well as rule sets posted by various people. This is heavy work so have a good read before you start.

http://www.sdharris.com/speedtouch510/

Cliff