cancel
Showing results for 
Search instead for 
Did you mean: 

Setting PlusNet 2MB bband up on my new PC

N/A

Setting PlusNet 2MB bband up on my new PC

I cannot for the life of me remember how to do it. I have installed the modem but it is currently unplugged as I am using it on this PC for support.

I have my PlusNet username and password but what else do I need to set up? Obviously don't need a phone number... or do I?
9 REPLIES
Community Veteran
Posts: 5,877
Thanks: 1
Registered: 05-04-2007

Setting PlusNet 2MB bband up on my new PC

What modem is it?
N/A

Setting PlusNet 2MB bband up on my new PC

Speedtouch USB - I am using it perfectly well right now on this (my old) machine!
N/A

Setting PlusNet 2MB bband up on my new PC

The settings on this page might be useful to you. The "Getting connected" menu on the right hand side offers advice for setting up the connection on a number of different Operating Systems.
N/A

Setting PlusNet 2MB bband up on my new PC

That guide mentions putting a phone number in - I thought you didn't do that with ADSL? I can't remember what the number was - I've got one here but it is an 0845 local rate number - doesn't that mean I will be paying per minute?
N/A

Setting PlusNet 2MB bband up on my new PC

Ah you're right - those link to dialup setup guides. ADSL doesn't require a phone number, just ignore those pages!
N/A

Setting PlusNet 2MB bband up on my new PC

Erm... so which pages should I be referring to?
Community Veteran
Posts: 5,877
Thanks: 1
Registered: 05-04-2007

Setting PlusNet 2MB bband up on my new PC

If you just need the ADSL user and pass I can tell you those.

Edit not the pass only you know that!
holdtight
Grafter
Posts: 1,634
Registered: 15-06-2007

Setting PlusNet 2MB bband up on my new PC

I do remember way back that windows 98/98se required 0,38 in the number bit but i dont think this still applies with later op systems
i know its not needed for xp
N/A

Setting PlusNet 2MB bband up on my new PC

I figured it out - when going thru the new connection wizard, you need to choose "dial-up" instead of "broadband" or ADSL or whatever it is. Works fine now.