cancel
Showing results for 
Search instead for 
Did you mean: 

Results good or bad?

N/A

Results good or bad?

I got Broadband in December and now upgraded to Windows XP. I am not unhappy with my DSL speeds but have been wondering whether the Tweak test results are as good as they should be:
http://monitor.dslreports.com/tweak/block:4f8c583?service=isdn&speed=512&os=winXP&via=pppoA

I am using Rwin 17.256 and MTU 1.478 - strange though, that the MTU field in DrTCP is blank when I start the utility.

Any comments/advice greatly appreciated.

Wolf

http://www.wolfkettler.co.uk/
http://visualxpo.plus.com/
7 REPLIES
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Results good or bad?

Your MTU is probably too high so try some other MTU values: 1478, 1458. You should get 100% transfer effeciency. Ignore any advice for RWIN for now.

Also look at the followitng Thread: MTU Tweak for more suggestions / advice.

Cheers

Peter Cool
N/A

Results good or bad?

Well your MTU is 1492 this is set for PPPOE .
Change it to 1478 in the box' Dial up MTURAS',
save and re-boot and then open up DrTCP and see if
the value has been changed or is blank again.
If its blank, something on your system is changing it back .
Im wondering what modem your using and is it set up for PPPOA ?
N/A

Results good or bad?

I just realised, there are two boxes labelled MTU in DrTCP and I have been using the wrong one ...
The value I input is there now after a re-boot.

Done 2 tests:
MTU=1.478 is here: http://monitor.dslreports.com/tweak/block:cf2efe?service=dsl&speed=512&os=winXP&via=pppoA
and MTU=1.458 is here: http://monitor.dslreports.com/tweak/block:49e6b4?service=dsl&speed=512&os=winXP&via=pppoA

I am not getting 100% transfer efficiency, though.

My modem is a PlusNet-supplied Binatone and yes, it is set to pppoA.

Wolf
N/A

Results good or bad?

Are you running service pack 1 you should do with that modem.
Both those results are pretty good improvements, its not
always possible to achieve 100% it depends on line conditions.
You could try lowering RWIN a bit say down to 10xMSS ,
14180 for MTU 1458 and 14380 for MTU 1478.
This might result in a slight slowdown when accessing long
distance servers, so best to experiment.
I would also take the ADSLguide speedtest
a few times for each of those settings you have just posted,

that will help to give you an overall view of which is the best setting.
Alec
N/A

Results good or bad?

Yes, I have SP1.

ADSLguide speed test results:
MTU=1.458
down actual: max=459; avg=452
down true: max=495; avg=488
up actual: max & avg=246
up true: max & avg=265

MTU=1.478
down actual: max=459; avg=456
down true: max=495; avg=492
up actual: max & avg=248
up true: max & avg=267

Wolf
N/A

Results good or bad?

Hi Wolf,
That's pretty much what was expected,
the MTU setting of 1478 gives slightly more
throughput .
It's about 10kb down on the best results, probably down
to that tiny bit of packet loss your getting .
I would think that's due to BT's routers and not down to anything
your end. Using a very low RWIN value might get rid of the packet loss
but may slow down your connection as a result, defeating the purpose.
Your average result is a lot higher than Plusnets current average
of 437.5 Kb and the current fastest ISP of 450.9 Kb.
Perhaps disabling the firewall or using a lower security level
when testing 'Might' give a better picture.But the result is pretty good
in comparison to others.
Regards
Alec
N/A

Results good or bad?

Thanks very much for your help, Alec. This is really all I wanted to know.

Thanks again,
Wolf