cancel
Showing results for 
Search instead for 
Did you mean: 

Port forwarding/NAT?

N/A

Port forwarding/NAT?

I've just got my +net ADSL connection sorted, got myself a samsung AHT-E300 modem connected to a belkin F5D6230u3 Wireless DSL Gateway/Router - which is then connected to 2 computers via 100baseTX cables, and a laptop with a wireless LAN card. Browsing etc is working great..

My question is this: does anyone know how to set up port forwarding, so that applications like MSN will allow me to send files from the computers on my LAN to other users online? This question also applies to apps like WinMX which requires access to a certain port from outside (6699 as default) and I'm wondering how I might go about setting it up.

The modem and the gateway/switch both ask about public ports/private ports and the hosts ip address. I can't find out what port MSN messenger, for example, needs?

Thanks in advance,
9 REPLIES
N/A

RE: Port forwarding/NAT?

> I've just got my +net ADSL connection sorted, got myself a samsung AHT-E300 modem connected to a belkin F5D6230u3 Wireless DSL Gateway/Router - which is then connected to 2 computers via 100baseTX cables, and a laptop with a wireless LAN card. Browsing etc is working great..
>
> My question is this: does anyone know how to set up port forwarding, so that applications like MSN will allow me to send files from the computers on my LAN to other users online? This question also applies to apps like WinMX which requires access to a certain port from outside (6699 as default) and I'm wondering how I might go about setting it up.
>
> The modem and the gateway/switch both ask about public ports/private ports and the hosts ip address. I can't find out what port MSN messenger, for example, needs?
>
> Thanks in advance,

This might be of help:
http://messenger.msn.com/support/firewall.asp

The NAT IP address of your PC (to which TCP-IP traffic on whatever port is forwarded) is found by running the winipcfg.exe program located in the c:\windows directory.

Sorry I cannot be more specific about your modem/router set-up but try some of the links here:
http://www.google.co.uk/search?hl=en&ie=UTF-8&oe=UTF-8&q=belkin+DSL+router+port+forwarding&meta=
N/A

RE: Port forwarding/NAT?

> This might be of help:
> http://messenger.msn.com/support/firewall.asp
>
> The NAT IP address of your PC (to which TCP-IP traffic on whatever port is forwarded) is found by running the winipcfg.exe program located in the c:\windows directory.
>
> Sorry I cannot be more specific about your modem/router set-up but try some of the links here:
> http://www.google.co.uk/search?hl=en&ie=UTF-8&oe=UTF-8&q=belkin+DSL+router+port+forwarding&meta=

OK, thanks, it's not that I can't use messenger etc - I've got outgoing access no problem, what I'm trying to sort out is inward bound packets. How do I allow the gateway to forward them to the correct computer, rather than just refuse them?

Many thanks,

Brian.
N/A

RE: Port forwarding/NAT?

Your modem/router should have options to do this, some kind of port forwarding utils/page not having your modem I don't know exactly how to do it but I've done it fine on the D-Link 504 and I can't imagine its alot different. Read the manule is as always the first port of call Smiley

Oli
N/A

RE: Port forwarding/NAT?

> Your modem/router should have options to do this, some kind of port forwarding utils/page not having your modem I don't know exactly how to do it but I've done it fine on the D-Link 504 and I can't imagine its alot different. Read the manule is as always the first port of call Smiley
>
> Oli

Hi again

Manual tells me nothing, other than the options are there to be altered...

The modem configuration has got a NAT configuration page, where it asks for a session name, and an IP. The session name configuration asks for a virtual circuit, and allows you to give it a name for the NAT configuration. It also has a virtual server configuration page, where it asks for the public port, a private port, the port type (TCP or UDP), and an IP - it lets you add as many as you like to a list..

The gateway/router configuration has got a virtual server configuration page, where it asks for a private IP, private port, port type (TCP or UDP) and a public port. It lets you add a few in a list.. It also has a special application ports configuration page where it asks the Trigger port, trigger type (UDP or TCP), the public port and the public port type..

I dunno how to set those up, thats the thing, which ones do I set up, and how? Could anyone give me some tips?

Many thanks,

Brian (Clare's bf)
N/A

RE: Port forwarding/NAT?

<SNIP>
> The modem configuration has got a NAT configuration page, where it asks for a session name, and an IP. The session name configuration asks for a virtual circuit, and allows you to give it a name for the NAT configuration. It also has a virtual server configuration page, where it asks for the public port, a private port, the port type (TCP or UDP), and an IP - it lets you add as many as you like to a list..
>
> The gateway/router configuration has got a virtual server configuration page, where it asks for a private IP, private port, port type (TCP or UDP) and a public port. It lets you add a few in a list.. It also has a special application ports configuration page where it asks the Trigger port, trigger type (UDP or TCP), the public port and the public port type..
>
> I dunno how to set those up, thats the thing, which ones do I set up, and how? Could anyone give me some tips?
>
> Many thanks,
>
> Brian (Clare's bf)
</SNIP>

Sorry, no guarantied step-by-step solution but here is what I would try:
1. Start with a simpler harware configuration, i.e. remove the gateway/router and connect a PC directly to the Samsung modem. Check that the PC connects to the Internet.
2. Run the winipcfg.exe program in the c:\windows directory and note down the IP address and subnet mask values.

Note: The following steps, 3 and 4, are not essential but would save you having to possibly re-configure NAT (NAT is sometimes called virtual server) port forwarding each time you reboot the PC.

3. Open the Windows TCP-IP properties box (start>settings>control panel>network>TCP/IP>properties). Click the IP Address tab. If the 'obtain an IP address automatically' is selected then select 'specify an IP address' and enter the IP address and subnet mask values from step 2.
4. Turn-off the DHCP function of the modem and re-boot the PC.

Note: If you cannot turn-off DHCP or you will never switch-off any of your PCs then ignore steps 3 and 4. The reason for steps 3 and 4 is to change from a dynamically assigned to a fixed IP address set-up. NAT port forwarding needs to know the IP address of your PC. Due to dynamic assignment, the address may change each time the PC is re-booted, especially if you will have several PCs on the network. If the IP address changes then you have to re-configure the NAT port forwarding with the new IP address. Tedious.

5. In the modem set-up add two sets of values:
set 1:
private port: 1863
public port: 1863
port type: UDP
IP: (see step 2)

set 2:
private port: 1863
public port: 1863
port type: TCP
IP: (see step 2)

6. save/activate the new modem configuration and see if things work. If not then try replacing all the 1863 entries with 0 (zero) or *. Beware - using 0 or * might open all the ports into your PC allowing any external application to connect to any network program running on the PC.

7. If it works then try adding the gateway/router. If you add additional PCs then they you need to specify an IP address and subnet mask for each of then as in step 3. Get these values by running step 2 on each PC, with all PCs turned-on, before you mess around with your current set-up.

Hope some of this helps. If not I recommend trying step 1 then contacting Samsung.

N/A

RE: Port forwarding/NAT?

> Sorry, no guarantied step-by-step solution but here is what I would try:
> 1. Start with a simpler harware configuration, i.e. remove the gateway/router and connect a PC directly to the Samsung modem. Check that the PC connects to the Internet.
> 2. Run the winipcfg.exe program in the c:\windows directory and note down the IP address and subnet mask values.
>
> Note: The following steps, 3 and 4, are not essential but would save you having to possibly re-configure NAT (NAT is sometimes called virtual server) port forwarding each time you reboot the PC.
>
> 3. Open the Windows TCP-IP properties box (start>settings>control panel>network>TCP/IP>properties). Click the IP Address tab. If the 'obtain an IP address automatically' is selected then select 'specify an IP address' and enter the IP address and subnet mask values from step 2.
> 4. Turn-off the DHCP function of the modem and re-boot the PC.
>
> Note: If you cannot turn-off DHCP or you will never switch-off any of your PCs then ignore steps 3 and 4. The reason for steps 3 and 4 is to change from a dynamically assigned to a fixed IP address set-up. NAT port forwarding needs to know the IP address of your PC. Due to dynamic assignment, the address may change each time the PC is re-booted, especially if you will have several PCs on the network. If the IP address changes then you have to re-configure the NAT port forwarding with the new IP address. Tedious.
>
> 5. In the modem set-up add two sets of values:
> set 1:
> private port: 1863
> public port: 1863
> port type: UDP
> IP: (see step 2)
>
> set 2:
> private port: 1863
> public port: 1863
> port type: TCP
> IP: (see step 2)
>
> 6. save/activate the new modem configuration and see if things work. If not then try replacing all the 1863 entries with 0 (zero) or *. Beware - using 0 or * might open all the ports into your PC allowing any external application to connect to any network program running on the PC.
>
> 7. If it works then try adding the gateway/router. If you add additional PCs then they you need to specify an IP address and subnet mask for each of then as in step 3. Get these values by running step 2 on each PC, with all PCs turned-on, before you mess around with your current set-up.
>
> Hope some of this helps. If not I recommend trying step 1 then contacting Samsung.
>
>

OK, I understand that, but as I've got more than one PC connected to the gateway, how do I set up that - In step 5 it says to use the IP from step 2. How would that apply for multiple IP's? Would you create an entry for each IP on the network?

Thanks in advance,

Brian.
N/A

RE: Port forwarding/NAT?

<SNIP>
> OK, I understand that, but as I've got more than one PC connected to the gateway, how do I set up that - In step 5 it says to use the IP from step 2. How would that apply for multiple IP's? Would you create an entry for each IP on the network?
>
> Thanks in advance,
>
> Brian.
</SNIP>
The short answer to the above question is yes.

Here's a longer answer:
Setting up port forwarding for this set-up:
[modem] --> [PC]
just simplifies the problem, making it easier to work-out how to get port forwarding working for the modem.

But obviously you need to connect several PCs, which requires the gateway/router back in the set-up:
[modem] --> [gateway/router] ==>> [PCs]
So now the only remaining problems are:
- 1. working-out how to set-up the gateway/router to also do port forwarding, and
- 2. which box (modem, gateway or both?) needs the list of IP addresses (with port data given at step 5) of the various PCs.

At this point I'd probably try things in this order:
- 1. add the IP address list with port numbers to the modem configuration. If this does not work then:
- 2. add the IP address list with port numbers to the gateway/router configuration. If this does not work then:
- 3. add the IP address of the gateway/router to the port forwarding configuration of the modem.

I hope some of the above helps but it's difficult to come-up with more than suggestions without actually playing with the hardware.

You might find some other suggestions here:
http://www.homenethelp.com/web/explain/about-NAT.asp

Cheers,

Fredrik
N/A

RE: Port forwarding/NAT?

> The short answer to the above question is yes.
>
> Here's a longer answer:
> Setting up port forwarding for this set-up:
> [modem] --> [PC]
> just simplifies the problem, making it easier to work-out how to get port forwarding working for the modem.
>
> But obviously you need to connect several PCs, which requires the gateway/router back in the set-up:
> [modem] --> [gateway/router] ==>> [PCs]
> So now the only remaining problems are:
> - 1. working-out how to set-up the gateway/router to also do port forwarding, and
> - 2. which box (modem, gateway or both?) needs the list of IP addresses (with port data given at step 5) of the various PCs.
>
> At this point I'd probably try things in this order:
> - 1. add the IP address list with port numbers to the modem configuration. If this does not work then:
> - 2. add the IP address list with port numbers to the gateway/router configuration. If this does not work then:
> - 3. add the IP address of the gateway/router to the port forwarding configuration of the modem.
>
> I hope some of the above helps but it's difficult to come-up with more than suggestions without actually playing with the hardware.
>
> You might find some other suggestions here:
> http://www.homenethelp.com/web/explain/about-NAT.asp
>
> Cheers,
>
> Fredrik
>

Thanks for the help, I've been trying that, and can't get it to work lol...

In time I guess I will, lol

Brian.
N/A

RE: Port forwarding/NAT?

To Clare McCarthy
(clare1980)
Hi
Please can you help me? My problem as follow

have a problem to have a voice conversation using MSN messenger, NetMeeting and Yahoo messenger. Our LAN consists of 4 machines running OS Win98/2000/XP. We have DLINK 504 and ADSL connection to the internet.

The problem is that when trying to connect voice / video conversation, using these applications to connect to people outside the LAN, it will NOT connect.

Please advise me of the setting for D-Link 504 to resolve this problem.

many thanks


> I've just got my +net ADSL connection sorted, got myself a samsung AHT-E300 modem connected to a belkin F5D6230u3 Wireless DSL Gateway/Router - which is then connected to 2 computers via 100baseTX cables, and a laptop with a wireless LAN card. Browsing etc is working great..
>
> My question is this: does anyone know how to set up port forwarding, so that applications like MSN will allow me to send files from the computers on my LAN to other users online? This question also applies to apps like WinMX which requires access to a certain port from outside (6699 as default) and I'm wondering how I might go about setting it up.
>
> The modem and the gateway/switch both ask about public ports/private ports and the hosts ip address. I can't find out what port MSN messenger, for example, needs?
>
> Thanks in advance,


--