cancel
Showing results for 
Search instead for 
Did you mean: 

Poor speed test results

N/A

Poor speed test results

I have just upgraded to using a Belkin 54mbps router/modem/4 port hub but since using this I notice much slower speed test results using the Plusnet bandwidth speed checker.
I am lucky to get above 451.00 and as low as 439.10
I have upgraded the firmware in the router but no difference was noticed.
Any idea's my old Fujitsu FDX310 was fine with speed checks of 475 to 478 all the time.
Anyone got any further info please.
7 REPLIES
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Poor speed test results

What MTU value is set in the router. This should be set to the same value your PC is set to. Don't know the router so can't say where you can set that info but that may be the cause.

Try doing a dslreports.com tweak test and check what MTU is has detected. If it is different to what your PC uses then the likely culprit is the MTU values in the router.
Highlighted
N/A

Poor speed test results

Thanks Peter,

I have reset the router back to factory default and noted router MTU is 1454, Using DRTCP I have set the same MTU setting for the PC.
But this has not improved the speed bandwidth check it is still around 455.00.
It has generally speeded up web page access though.
Are the other settings in DRTCP crucial and how do I acheive the correct ones.

Also would more than one PC operating on the network router reduce this speed figure

Thanks

Derek
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Poor speed test results

MTU and corresponding RWIN values can sometimes make a big difference and sometimes not. 1454 is not one of the common ones that tends to be used however.

Although you have not said yet I assume you are on 512K ADSL otherwise 455 would be really bad for a 1Meg line :shock:

There is an MTU tweak thread which contains lots of examples of values used by others so I suggest you read through it and try some of the suggestions.

I use MTU 1478 and RWIN 17256 for my 512K connection using a DG814 modem/router and get around 480->490Kbits/s so give that a try. Note: the RWIN value is only for Windows, the ADSL kit just needs the MTU set.

[edit - corrected the MTU value I use Shockedops: ]
N/A

Poor speed test results

Thanks again Peter,

Yes sorry it is a 512k ADSL connection.
A local friend and also a Plusnet user gets 485.00 using the same router.
I will try the different settings but I am starting to feel guilty using the speed checker so much.
But what worries me most is it is telling me my speed is too low for my connection and it has never been like this before.

Thanks for all your help.

Derek
N/A

Poor speed test results

Derek,

An obvious question, but is anything else going on traffic-wise when you are running the speed test? I'm assuming that you are using the router as you have more than one PC conencting to the Interent?
N/A

Poor speed test results

Quote
Although you have not said yet I assume you are on 512K ADSL otherwise 455 would be really bad for a 1Meg line


well, I have a 1Mb ADSL connection and I am getting an average of 400K... how bad is that?
N/A

Poor speed test results

Quote
But what worries me most is it is telling me my speed is too low for my connection and it has never been like this before.


Your speed, although currently lower than with your old USB modem, is within specification for 512 DSL.

The speed difference you are seeing is most probably down to the MTU in the router. Use 1478 in the router as already mentioned. Also use 1478 in DrTCP for your NIC. The other settings in DrTCP for your NIC card can be left at default for an ethernet connection as they are not really relevant.