cancel
Showing results for 
Search instead for 
Did you mean: 

PlusNet supplied router, NAT, and audio in MSN Messenger

N/A

PlusNet supplied router, NAT, and audio in MSN Messenger

Hi all

This (rather long) post describes my experiences trying to use MSN Messenger (version 6) to chat to my friends with audio and video. I hope it might be helpful to those of you experiencing similiar issues, and perhaps even myself, if anyone has any solutions.

Please note that throughout this thread I am only concerned with NAT related issues, not firewall ones. If you are trying and failing to use audio and video through MSN, the first thing you should do is disable the firewalls at both ends to make sure they are not blocking something important. All the problems described here occur both with and without ZoneAlarm loaded on either machine.

Finally for this little introduction, let me just say in advance that all of this is entirely my opinions, through experience and research on the web. Whilst I have tried to ensure everything I state is accurate and true, I cannot guarantee it. Please do not flame me if I claim something that turns out to be false - correct me instead.

You may wish to first read this article on Microsoft TechNet about the use of Windows Messenger in combination with firewalls and NAT. Windows Messenger and MSN Messenger are essentially the same thing, you can find out the differences between the two here.

For the benefit of those of you who do not wish to read that whole thing, it basicly states that certain features will not work through NAT unless the NAT device is UPnP capable.

Next, an introduction to my router. I signed up to PlusNet in late August 2002, and received a plain white router labelled simply "ADSL Router" on the box, the device itself, and in documentation. No brand name is present. PlusNet refer to it as an Alcatel router, and indeed it uses an Alcatel chipset. On the bottom of the router a label presents the model number "AR11". Through research, I have identified this router as an Aceex AR11/2. The same router is sold under other brand names, but Aceex seem to be the original manufacturer. Their home page for the router is here. My router does not seem absolutely identical to this one - it is white all over, and does not have a reset button on the back, but I am still pretty certain this is the one. These are probably just changes in the design since mine was produced.

Anyway, this router does not support UPnP. Now, on to my experiences trying to get audio and video working; To avoid any issues with the use of port forwarding or firewalls, I set the DMZ feature on the router to point to my PC, and disabled my firewall. I verified this had worked by having a friend connect to an FTP server running on my machine.

I then enabled the incoming and outgoing log tables on the router to enable me to view what was happening. For some reason, on my router, the incoming log table never displays anything, even with someone connected to my FTP server, but the outgoing log table was helpful.

I enabled video, my friend accepted, and a video link was established with my friend able to see me. The outgoing log table showed a TCP connection to his IP, with the amount of data rising rapidly. I then enabled audio, and my friend accepted again. This time the outgoing log showed a UDP connection going to his machine, but MSN was unable to establish the connection, and audio did not work. Please note that this friend is not using NAT, and had disabled his firewall. He is on Cable broadband from NTL, and has successfully held video and audio conversations over MSN with other NTL cable users.

So, given that the use of NAT seemed to be preventing me holding an audio conversation in MSN, I resolved to stop using it. I raised a contact ticket with PlusNet, explaining the situation, and asking if I could be granted a block of 4 IPs for a no-NAT setup. This they did, for which I am very grateful - it's not every ISP that will grant you 4 IPs at no additional charge.

Then the fun started.

I read the manual for the router carefully, and sought support on the web. Firstly I tried simply setting the LAN address of the router to the new global one with the correct netmask. I will detail here what my IP settings were, but please note that I have replaced my IPs for the purposes of this post with the ones provided in the PlusNet example here. I did not actually try to use these IPs, I used my own, I just don't want to reveal my real IPs here and have every opportunistic script kiddie reading this trying to hack me.

Router LAN interface:
212.159.98.65 IP,
255.255.255.252 netmask.

PC Configuration:
212.159.98.66 IP,
255.255.255.252 netmask,
212.159.98.65 gateway.

This appeared to be working at first, and indeed does let me browse the web as normal. However, visiting What is my IP? gave 212.159.98.65 still, the IP of the router. The router is still performing NAT. This is not surprising, when you look at the setup mode it is in. I don't seem to be able to log in to my FTP to upload a screenshot at the moment, but if you read the PlusNet setup guide for this router here, you will see the mode listed as "PPPoA+NAT".

So, I tried some of the other modes in that list, namely "Router" and "Bridge". A word of warning to anyone with the same router who is considering trying this - have your serial cable ready. In Bridge mode, I could not reach the web configuration interface and had to use HyperTerminal. Anyway, neither of these modes worked. The router started up, and claimed to be "Connected", but could not ping any external hosts.

I will admit, I am not that knowledgeable on what exactly is required to establish an ADSL connection, but I would think that PPPoA (RFC2364) is the only way in the UK.

Lastly, I tried using the NAT IP address mapping feature of the router (sorry, can't provide a screengrab right now) to translate the "local" 212.159.98.66 to a "global" 212.159.98.66. (Remember these are replaced IPs for the purposes of this post only - I actually used my real IPs).

This did yield some results - What is my IP? now reported 212.159.98.66. Also, in this setup without this IP address mapping, my friend was not able to log in to my FTP, but was able with it present. Audio in MSN still does not work though.

Looking around on Google groups, I found a suggestion to do this to get a no-NAT setup with this router. You can read it here.

I contacted PlusNet again, asking if this router did support a no-NAT configuration, and if so how. Their response was:

"Yes our routers all can perform no-nat configurations. However technical spport are not trained to be able to pass on this information. You should seek help locally if you can not configure the device, or review the manual."

I can appreciate that they don't have time to provide this level of techical support - that's fair enough. I've worked for a major company such as this one before, and know that they have constraints on the level of service they can provide.

However, I would dispute the claim "Yes our routers all can perform no-nat configurations." I don't think this router can.

My thoughts on this matter seem to be backed up by this page, PlusNet's guide to setting up a different router, the Solwise SAR110, in "No-NAT" mode.

Notice the little note at the bottom -
"Whilst this No-NAT configuration should work for most purposes, some people may experience problems with applications that embed the local IP in the data packets (some games for example). No guarantee can be made for this setup guide to cover all situations."

It would seem the same is true of this router. I wish to stress this point - this is NOT a no-NAT configuration - the router IS still performing NAT. This could best be described as a simulation of a no-NAT setup, and the difference is crucial when it comes to audio chat in MSN.

Well, that's all I have to say really. Please remember that all this is only correct as far as I know, I cannot guarantee this information.

If anyone knows how to get this router to perform an actual no-NAT setup, or indeed knows any other way to get audio in MSN working through this router, please enlighten me. If not it seems I will be buying one..
10 REPLIES
Lorian
Grafter
Posts: 699
Registered: 31-07-2007

Re: PlusNet supplied router, NAT, and audio in MSN Messenger

I don't think it will work - you need an ALG that the router does not have. But I'm no expert on this as I don't use messenger.

Also be aware anyone can find out your ip addresses by typing just two lines, so best keep the firewall up.

Jc.
N/A

PlusNet supplied router, NAT, and audio in MSN Messenger

Why not just dump messenger and move on to one that works with no problems, like all the rest of the IM services.

Be cheaper and less hassle in the long run.
N/A

PlusNet supplied router, NAT, and audio in MSN Messenger

I have two things to add to this post.

1: I would suggest using Yahoo! IM.

One of the best features is its connection failure backup abilties.

Connections come in two classes with Yahoo! They are run through the yahoo server, in which case both parties make out-going connections, thus, avoiding NAT. Or they use direct connections. This is where NAT will break it normaly, however, most of the yahoo services will fallback onto method 1.

2: Has anybody noticed that a reply to this thread went missing?

Currently, the first reply talks about ALG. Having read the thread before, there was a reply talking of MSN being ALG (Application layer gateway).

However, after the second reply, this vanished, and has cause the now reply number 1, to look totaly out of whack to the thread.
Lorian
Grafter
Posts: 699
Registered: 31-07-2007

PlusNet supplied router, NAT, and audio in MSN Messenger

Quote

2: Has anybody noticed that a reply to this thread went missing?


T'was me - I deleted my first post (was not correct) and replaced it a little while later with the second one. Sorry for the inconvenience. It does make sense if you didn't read the first post.

I'd missed the fact it was an aceex router when I orginally posted (no ALG), and thought he was talking about the SAR110, on which I think it should work with the latest firmware supplying the extra ALG.

Jc.
N/A

Re: PlusNet supplied router, NAT, and audio in MSN Messenger

Quote
Hi all

My thoughts on this matter seem to be backed up by this page, PlusNet's guide to setting up a different router, the Solwise SAR110, in "No-NAT" mode.

Notice the little note at the bottom -
"Whilst this No-NAT configuration should work for most purposes, some people may experience problems with applications that embed the local IP in the data packets (some games for example). No guarantee can be made for this setup guide to cover all situations."



Actually, I don't think this is true (of the SAR 110) any longer - *my* version of the services tab->NAT page has a radio button to disable NAT...

I hope to be trying this very soon, and will let you know how I get on
N/A

PlusNet supplied router, NAT, and audio in MSN Messenger

Well, this post has now dropped well off the first page, and I notice it hasn't exactly had huge numbers of readers.

Does anyone have suggestions as to where I could post this to get it a little more exposure, in the hope that someone reading might have some answers?

Thanks in advance for any replies
N/A

Re: PlusNet supplied router, NAT, and audio in MSN Messenger

Quote
Actually, I don't think this is true (of the SAR 110) any longer - *my* version of the services tab->NAT page has a radio button to disable NAT...

I hope to be trying this very soon, and will let you know how I get on


"feline": You're right, and there's a "tutorial" article now on the Solwise SAR110 and No-NAT.
N/A

PlusNet supplied router, NAT, and audio in MSN Messenger

Well, the audio in MSN still doesn't work, but it seems I now have a bigger problem -

Using the setup described above, that is an Aceex AR11/2 router (described by PlusNet as an Alcatel Router), with a block of 4 IPs, and a "No-NAT" setup by translating my PC's IP address to the same one globally, I cannot make any outgoing FTP connections.

Anyone else have this setup and this problem?
Community Veteran
Posts: 3,789
Registered: 08-06-2007

PlusNet supplied router, NAT, and audio in MSN Messenger

Try enabling Passive (PASV) mode in your ftp client and see if this cures your problem.

B.
N/A

PlusNet supplied router, NAT, and audio in MSN Messenger

Thanks for the suggestion zubel, but I already tried enabling passive mode, to no avail. I've tried several different FTP sites both with and without passive mode, including my PlusNet webspace.

I've also tried CoffeeCup FTP, Internet Explorer and Mozilla Firebird as FTP clients, nothing with any of them. Strange, because it used to work fine on my old NAT setup. People can connect to the FTP server I run on my PC just fine, so incoming works, but not outgoing Sad