cancel
Showing results for 
Search instead for 
Did you mean: 

OS X, Netgear Router and Apache Webserver

N/A

OS X, Netgear Router and Apache Webserver

I have Apache Server running on my OS X eMac on a network connected to PlusNET ADSL via a Netgear DG819 gateway. At the moment, everyone on the LAN can connect to my Apache server, but how can I make this server available to people outside my LAN?

Thanks very much,
Sam
(mail@samstarling.com)
7 REPLIES
N/A

OS X, Netgear Router and Apache Webserver

I assume you meant the DG814 router?

You need to go to the port forwarding menu of the router and add an entry for the HTTP service. You can use the selection box to select HTTP, enter the IP Address of the PC running Apache in the "Server IP Address" boxes, and press the "Add Server" button.

If you have any firewall software on the Apache machine, you will need to configure it to allow through connection requests on port 80. Since you can access the web server from other PCs internally, it's likely this is already OK.

You will need someone from outside your network to test it out -- tests from inside your network will not seem to work (this is usual and not something to worry about). They should be able to bring up the web pages by using http://starling.plus.com.
N/A

OS X, Netgear Router and Apache Webserver

Thanks for your reply.

I need to know how I can use my DG814 to cope with my IP address that occasionally changes (it will end in anything from .1 to .5) as my computer is not always on the network.

Also, how can I get http://starling.plus.com to forward to the webserver? At the moment it just shows a directory listing of what I have put up there

Thanks,
Sam
N/A

OS X, Netgear Router and Apache Webserver

Hi,

I am presuming that this is because your machines address is assigned dynamically through DHCP?

In which case, you could always manually configure a static address on this machine.

Strictly speaking I would recommend you pick one outside of the range that the router may dole out, but DHCP will usually cope if you don't do this.

Regards,
D'Essen
N/A

OS X, Netgear Router and Apache Webserver

You would be correct on the DCHP issue... How can I set myself a fixed IP on the network? (I'm using Mac OS X, but I presume the settings you need to change are the same on Windows and Mac OS).

Then I'd just like to know how I can get people to access it from the outside, preferably by visiting server.samstarling.com and getting a directory listing or something.

Thanks,
Sam
N/A

OS X, Netgear Router and Apache Webserver

NB: I can set up to connect to my network by "DHCP with manual IP", it then asks me to enter an IP address... but I don't know what to enter. Any ideas?

Thanks,
Sam
N/A

OS X, Netgear Router and Apache Webserver

I don’t know the specifics of Mac OS, but otherwise the values you will need would be the same regardless of platform.

If memory serves then NetGear usually uses the 192.168.0.0/24 network by default. Which in English means that your machine needs to have a an IP address of 192.168.0.x, where x cannot be 0 or 255, and must be unique on your network.

The subnet-mask would be 255.255.255.0 (or 24 bits), and the default gateway is the IP address of your router (normally 192.168.0.1).

Now your address is fixed, the instructions left earlier by TaskForce9 should work for you. Point the port forwarding service towards the address you have just assigned your machine.

On a different note, if your seeing a directory listing when you browse to your website, then I would guess that this is being served by Apache. In which case:
* If this is the correct directory, place an ‘index.html’ file in there.
* If this is not the correct directory, modify the DocumentRoot setting in your httpd.conf file.

Regards,
D'Essen
N/A

OS X, Netgear Router and Apache Webserver

Thanks to both of you for your help! I'm well on my way to getting it all sorted out. I'm getting my webhosts to add a DNS record which will point server.samstarling.com to my machine - this is the last link in the "chain"!

Thanks once again,
Sam