cancel
Showing results for 
Search instead for 
Did you mean: 

No NAT with 4 IP setup!

N/A

No NAT with 4 IP setup!

Hi...........help,

I am having difficulty. I got the 2meg connection with the No NAT option for the purpose of commissioning my computer network with a webserver hanging off it.

I have a working linux box with 2 network cards, one plugged into the SAR-110 router (eth-0) and the other plugged into a 5 port hub (eth-1). The 5 port hub has all the computers connected and are assigned internal IP addresses from the DHCP server on the linux box. All worked well with my previous cable connection but I am stuck since moving to Plusnet.

I have set the router up as specified on the setup instructions then added the NoNAT config specified on the plusnet router support page.

My 4 ip block is:

xxx.xxx.xxx.64
xxx.xxx.xxx.65
xxx.xxx.xxx.66
xxx.xxx.xxx.67

Here is my problem:

With eth-0 of the linux box set to an internal address (192.168.7.2) and gateway (192.168.7.1), all networked computers can surf the net, download email and share files/printers etc etc. However, despite the NoNAT rule being defined as specified, the server is not accessible on any of the domains pointed to xxx.xxx.xxx.66, apache is configured to listen on xxx.xxx.xxx.66.

So....I configure eth-0 on the linux box for xxx.xxx.xxx.66 and I can access the server only. The computers on the network cannot browse the net!

Can someone enlighten me.......my guess is an IP routing issue, however I have followed the instructions on the site to the letter, so I don't understand why it doesn't work.

Can someone expalin in an informative response which also provides some clarity on where the 4 IPs should be used.

Cheers

Pete
11 REPLIES
N/A

No NAT with 4 IP setup!

If all the pc are going through the linux box the linux box is doing the nat. As all the traffic is going via linux everything just sees the traffic from one ip.

All pc that you want visable should be connect to the router via a hub and have a live ip. Other than that use port forwarding
N/A

No NAT with 4 IP setup!

Thanks for your reply!

OK I dont want the windows workstations visible, they just need to be able to access the net. As it is the Linux box is setup as a firewall using IP masquerading / port forwarding. No problem at all and this works!

All I want now is for my linux box to serve on a public IP address. I have apache listening on xxx.xxx.xxx.66 but when I setup eth-0 in the linux box to listen on xxx.xxx.xxx.66 my network loses net access.

So how do I setup eth-0 on the linux box in terms of IP address and Gateway IP address to get all traffic on all ports on xxx.xxx.xxx.66 in and out. If I can get this right then I am sure the rest will work. Also, I suspect the plusnet tutorial on the plusnet site falls short of apache virtual hosting, are there any other rules that need to be set on the router?

Cheers

Pete
N/A

No NAT with 4 IP setup!

Update!

I have re-plugged the network so as to make life a little easier!

I now have the uplink port of the hub plugged into eth-0 of the adsl router with internal IP addresses setup for each. Now eth-0 of the linux box is simply plugged into the router.

All network PCs work fine, but I can't get the linux box visible on xxx.xxx.xxx.66 any ideas - rules - broadcast address etc etc?Huh
N/A

No NAT with 4 IP setup!

Put simply if you plug anything into the router(directly or via a hub) with a public ip and if there is nonat they will be visable on the net.

if any other pc connect via a pc with 2 cards the pc will do a nat and htey wont be visable on the net unless there is port forwarding. to route any ip it has to be in a diffrent range or there is nothing to route. So if you have a unix box with one card on 192.11.131.66 and the other card on 192.11.131.69 then it cant route as the are in the same range. If the second card i on 10.0.0.2 then routing will take place ok.

In this example anthing on the 10.0.0.2 side of the unix box would see anything the other side as it goes via the default gateway so it knows how to get it. Anything on the 192 side isnt normaly routed as there isnt a gateway on that side as any pc on that side would have the router as it default gateway not the unix box
N/A

No NAT with 4 IP setup!

OK..........All my machines have internal IP addresses ranging from 192.168.7.2 through 192.168.7.9 when I had the server doing nat, I used the range of 192.168.1.1 - 200, however, this is now defunct!

I now have all machines connected to the hub each with their own internal IP as above. However, an internal IP on a webserver hosting virtual sites doesn't work. So I want my server to listen on say 81.175.222.66 and traffic on all ports to get through ie. http ftp ssh mysql etc etc. Right now when I key 81.175.222.66 into my browser, or shell client or ftp client I get nothing. I want to assign this public IP to the server. Also, I need to be able to access the sites on the server from a machine on the internal network, either internally or by using a public IP or domain name etc etc.

Any ideas?
N/A

No NAT with 4 IP setup!

Hmm, I looked at the 4-IP option at first thinking this was the best one for me as I too am running a small home webserver under Linux. The way I see it, I'm no better off with the 4-IP as with the single static. I went for an ethernet modem as opposed to a router or USB modem which means my Linux box picks up my single static IP and is hence public with no faffing around.

My Linux has two NIC's, eth0 is the LAN connection on a 192.168.3.* IP and eth1 is plugged into the ethernet modem and gets it's IP from PlusNet. Linux does the NAT/firewall/caching for the two XP machines I have on the LAN.

The way I understood the 4 IP block was as follows:

1 IP for the public face of the router
1 IP for the LAN face of the router
1 IP for the server
1 IP as the broadcast IP

So I'd guess you should have as follows:

router public port on static IP 1
router LAN port on static IP 2
linux to router eth on static IP 3 (this is the IP PlusNet should tell you is the one to give ur server)

the 4th static IP is the broadcast one and I don't think this can be allocated to any machine?

the LAN eth interface on Linux will have to have a private IP in the same range as your LAN machines, and Linux will NAT the internet connection.

I'm hoping you're either looking into firewalling your connection with Linux or are already doing so. Either way, you can use the firewall (iptables) to port-forward requests on port 80 to your internal server IP so your web server will then be able to serve it's pages.

Either that or run your webserver from Linux since it already has a static IP!

I'm currently writing up what I've done to get my Linux machine on the web with PlusNet and if you're interested message me and I'll tell you when it's on my site.

Not sure if this helps any!

nry
N/A

No NAT with 4 IP setup!

port forwarding is the best way to go. Very often you cant get to your own webserver as the router doesnt route it internally.
N/A

No NAT with 4 IP setup!

Well.....everything is of help!

I had all this working on blueyonder with a dynamic IP which never changed, simply a case of understanding how to talk to the DHCP........however, no probs at all. I had my linux box eth0 connected to the ouside world and my hub connected to eth1 serving IPs to my network from dhcpd. All I want is the same with plusnet with a static IP. I will plug the network back through the linux box once it is available on a public IP and working OK.

For now I have the hub on the router just so as when I get the linux config wrong I don't lose net access.

If you can help with some specifics on config:

Linux box eth0 IPaddress - xxx.xxx.xxx.66 I think?
Linux box eth0 Gateway IP ?
Anything else mission critical for linux?

Any rules to be setup on the router?

I can't see how the linux box can have an internal IP, I have quite a few virtual sites, MYSQL, pro-ftp, SSH all who need to listen on a public IP. I understood the NoNAT option to mean that the public IP would be available on linux eth0.

Also I am very interested in what you are doing so please keep me informed!
N/A

No NAT with 4 IP setup!

Quote
port forwarding is the best way to go. Very often you cant get to your own webserver as the router doesnt route it internally.


If this is the case I see we will need a major hack as posted on the solwise site and in page 40 of the reference manual. I really wanted to avoid this but looks like I have no choice!

I don't believe that neither of the 4 IP addresses will give me a straight forward path to my linux box.

Thanks anyway!
N/A

No NAT with 4 IP setup!

I'm guessing you've read the following? Seems to describe it all fairly well:

http://portal.plus.net/supportpages.html?a=215

As for what IP to allocate to what interface, based on the above it seems that something must need to be set on the router itself to turn off any NAT and maybe set it to use the same IP on both the LAN and WAN ports: I think PlusNet will allocate at least the WAN IP automatically by DHCP. You 'may' need to set the LAN interface IP yourself but this will depend on the router.

Your Linux box with the 2 NIC's can have both a public IP and a private IP: in your current layout I think eth0 would get the public IP and eth1 would get the internal/private IP. This way the world can see it via eth0 and the LAN can see it via eth1.

I presume the gateway address of eth0 would be the router IP. If I understand the setup correctly, you shouldn't need any port-forwarding as this is the whole point of using the 4-IP block. Can you ping the server public IP from a non-LAN machine eg at a friends house? If so, can you http://LinuxIP from outside? If you can do this then the fault may lie with the DNS config as this caused me a few problems till a kind Tech Support person corrected the mistake I'd made when I set the DNS records va the portal. If PlusNet have provided your router and the 4-IP block then it must be possible to turn NAT off on the router otherwise they've made a big mistake in providing a setup that can't work with the supplied hardware...

nry
N/A

No NAT with 4 IP setup!

Agreed, found the solution last night. It takes the config away from anything remotely associated with the standard plusnet config but I have found a way.

I will let you know when done - wondered if I would ever use the console port!!