cancel
Showing results for 
Search instead for 
Did you mean: 

NIC failure

N/A

NIC failure

Hello

Has anyone had a problem with windows not loading drivers correctly for there NIC?

This started out of the blue last night, am getting code 31 messages on 2 devices :

This is on windows xp service pack 2 professional edition

Binatone Adsl 500 modem
SIS 900 Ethernet Adapter

The following steps have been taken :

a) uninstalled the above devices and rebooted , hoping plug and play will work, this failed, just bringing up unknown device and showing the 2 above will yellow ! and the same error

b) uninstalled again and installed the binatone drivers, restarted same problem as above

c) installed a brand new nic, restarted and exactlly the same error on all 3 devices now

Ok thought it could be a registry problem, so used a registry fixing program, restarted and exactly the same problem happened

At this point all logic I had went out the window, so tried a system restore I created when first installed dsl, this went wrong big style and getting blue screens of death each time I restart the computer

So now it is the old format and re-install windows Sad

Just wondering if anyone has come across this before and did they manage to fix it?

Thanks

darrenf
7 REPLIES
the_norris
Grafter
Posts: 463
Registered: 02-08-2007

NIC failure

Hi

Are these devices PCI card? I would try updating the chipset drivers.

Also I would remove the failed device via safe mode. - This way windows deleted the driver not just removing the device from the device manager.

Phil
N/A

okly dokly

Hello

Thanks for that, I did upgrade the SIS 900 ethernet drivers to the latest (it is an internal motherboard nic type thing) and this failed as well

The dsl modem is USB

Still working out why the USB modem needs a NIC anyway

oh well nuke and pave and a re-install of windows tonight

fun fun fun Smiley
N/A

NIC failure

A usb modem doesnt require a NIC, In fact it doesnt work with one.
All it requires is a usb port and the driver.
This is certainly true of the binatone adsl 500, I had one myself.
N/A

um strange

Hello

Whenever my binatone connects up it creates a LAN connection and needs a NIC to do this.

Not sure if this is right, but it has always done this since I have had it and has worked perfectly

Re-install of windows fixed the problem

Thanks

darrenf
N/A

NIC failure

Your Binatone modem creates a Network Connection not a NIC.

You may be confusing the two.

1 is your physical connection (LAN) the other a peice of hardware.
N/A

ok

But the network connecton needs the nic?

I have tested this myself, by uninstalling the nic and just trying to use the USB connection

It fails everytime until I re-install the nic

It confuses me as well Smiley

Unless it is windows throwing a wobbly Smiley

oh well it is all working now anyway Smiley
Community Veteran
Posts: 14,469
Registered: 30-07-2007

NIC failure

That modem works perfectly happily on a system without a Network Interface Card or port so there must be something funny with your windows setup as a NIC is not needed.