cancel
Showing results for 
Search instead for 
Did you mean: 

IP's, Broadband and Apache

craigbrass
Grafter
Posts: 1,009
Registered: 30-07-2007

IP's, Broadband and Apache

Yes, I can access the apache from other PC's on my network, but am still unable to access apache in any way from the internet.
craigbrass
Grafter
Posts: 1,009
Registered: 30-07-2007

IP's, Broadband and Apache

Bumping this post...Still need help...Read above.
N/A

IP's, Broadband and Apache

What are the answers to the earlier questions?

What status does "ShieldsUp!!" report for port 80? Which IP Address does it detect?

Are you using the WAP as a DHCP server? Which IP address is assigned to the laptop? Did you configure the router's "Virtual Server" to forward port 80 to this IP address?
craigbrass
Grafter
Posts: 1,009
Registered: 30-07-2007

IP's, Broadband and Apache

It is detecting my IP as 212.159.98.49 and it is saying port 80 is Stealth. I can access it from every PC on my network just not from the net.
N/A

IP's, Broadband and Apache

It sounds like either firewall rules or NAT is still affecting it then.
N/A

IP's, Broadband and Apache

Quote
It sounds like either firewall rules or NAT is still affecting it then.


My impression from the manual was that the AR11 router does not have a firewall of its own -- there's certainly no configuration screen relating to firewall settings -- so the most likely other place for a firewall is the laptop. But if apache can be accessed from the other PCs, port 80 is either completely open or there's a rule allowing it only for local hosts.

Assuming the firewall possibility can be ruled out, that leaves the NAT / Virtual Server settings on the router.

On this subject, the AR11 router's configuration screens are remarkably similar to those of the Conexant AMX-CA61E. The ADSLguide review of the AMX-CA61E pointed readers to http://www.farina1.com/amx for screenshots showing how to configure this router for the UK. One thing I note is that the "NAT" screen shown on that site shows "NAT" set to "NAPT" rather than the default "Dynamic NAPT". I think you should try setting it to "NAPT", press Submit, save the settings and reboot, and then see if "ShieldsUp!!" shows a different status for port 80.

The "Virtual Server" settings on that other website seemed to confirm the recommendations made earlier.
N/A

IP's, Broadband and Apache

I'm haveing a similar problem.

I am trying to get my web server (on WinXP) visible to the outside world.

I have a Alcatel router connected to a Win XP box which has got IIS running.
Connected to this box by another network card and windows ICS is another WinXP box. This box can see the web server on the first one ( 192.168.8.3) but i cant get it from the outside IP. address (212.159.114.236).
I have set up port forwarding for port 80 and 443 as described earlier.
I ran Shields up and all ports were "Stealth", i turnred off the firewall on the box with the Web Server and ran shields up again and this time port 80 and 443 were open, but the connection was refused from 212.159.114.236.

Thats as far as i can get, any ideas would be very helpful
N/A

IP's, Broadband and Apache

Quote
i turnred off the firewall on the box with the Web Server and ran shields up again and this time port 80 and 443 were open, but the connection was refused from 212.159.114.236.


How did you determine that the connection was refused from212.159.114.236? Did you try browsing to that IP address (or "lowcatton.plus.com") from within your local network, or did you ask someone from outside to test it?

I reckon if you get someone else to try it, it might work (with the firewall switched off, or allowing through ports 80 and 443, that is).


Mods: would you split off these last couple of posts onto a new thread, please.
N/A

IP's, Broadband and Apache

I can't test it from outside tonight but if someone could help me out, I have left the firewall off and the ports forwarded.

Could someone try http://212.159.114.236/ and reply with what they find

Thanks
N/A

IP's, Broadband and Apache

A page saying "Low Catton1" which I assume means the server, etc. is working.
N/A

IP's, Broadband and Apache

Thanks alot for your help
craigbrass
Grafter
Posts: 1,009
Registered: 30-07-2007

IP's, Broadband and Apache

Looking at your reply before Task and clicking on that router link, that is not the setup window I get. This is the one I get : http://www.flashasp.plus.com/ss1.JPG

I have tryed using port forwarding : http://www.flashasp.plus.com/ss2.JPG

I have tryed using NAT virtual server mapping : http://www.flashasp.plus.com/ss3.JPG

And I have tryed using DMZ : http://www.flashasp.plus.com/ss4.JPG

All with no joy. I have disabled all encryption on the wireless access point but on my laptop, it won't let me connect to the wireless access point without the firewall that comes with windows XP enabled. Any more ideas?
N/A

IP's, Broadband and Apache

Yes, I can see your setup screens are very different from those I thought applied to your router! Although it does seem to use some of the same terminology, like "Virtual Server".

One thing I did spot was on the very first screen shot: two bullet points:
  • Packet filter parameters (LAN to WAN)
  • Packet filter parameters (LAN to WAN)
In other words, unlike the router I was considering, yours does have some sort of firewall functionality (over and above what is inherent in NAT).

It would be interesting to see a screen shot showing what has been set up for packet filtering.

I don't think the wireless encryption is the source of the problem, so I suggest you have it enabled. As far as the Windows XP firewall goes (I assume this is Internet Connection Firewall, ICF?) as long as it is set to allow outsiders to connect on port 80, that's fine.

For now, I think the packet filtering on the router is the best lead.
craigbrass
Grafter
Posts: 1,009
Registered: 30-07-2007

IP's, Broadband and Apache

On the lan to wan packet filter it looks like this : http://www.flashasp.plus.com/ss5.JPG which in turn leads to these three options :

IP Range : http://www.flashasp.plus.com/ss6.JPG
Mac Address : http://www.flashasp.plus.com/ss7.JPG
Web Site or Key Word : http://www.flashasp.plus.com/ss8.JPG

On the wan to lan there is this : http://www.flashasp.plus.com/ss9.JPG


Any ideas now?
N/A

IP's, Broadband and Apache

No!

The (LAN to WAN) is a kind of "parental control" facility to prevent certain computers on your internal network from accessing things out in the Internet. So that's not relevant.

The (WAN to LAN) blocks certain computers in the Internet from accessing your internal network, and nothing is configured anyway. So that's not relevant, either!

So, pretty much running out of ideas -- we've covered all the things which should matter.

I think both the "Virtual Server" setting, shown in ss2.jpg and the DMZ setting shown in ss4.jpg should have worked. As a matter of interest, how did you test these -- from inside your network (ie browsing to http://212.159.98.49), or did someone outside try accessing it? (See the problem lowcatton reported in this thread, attempting to access his webserver from within his network by using his public IP address! -- is yours an instance of the same thing?) You need to test from outside, which isn't easy if you're sitting inside your network (dial-up from another PC -- not the laptop running the webserver -- is one way to test it).

Perhaps you'd show us a screen dump of your "NAT" screen (not the Virtual Server screen, which you've already shown us). Is there a separate "NAT" screen (as there was on the configuraion pages for the router I thought you were using) with options like "Dynamic NAPT", "NAPT", "NAT", etc?