cancel
Showing results for 
Search instead for 
Did you mean: 

IP's, Broadband and Apache

craigbrass
Grafter
Posts: 1,009
Registered: 30-07-2007

IP's, Broadband and Apache

I have two useable public IP's, 212.159.98.49 and 212.159.98.50. The routers current IP is 212.159.98.49 at port 80, but you can change the routers port to any port number. The routers local IP is 192.168.8.1. The router is the Alcatel one plusnet supplyed in the startup packs between august and november of last year. The router is connected to a wireless acess point (3Com 3RWE41196) which in turn connects one PC and one Laptop. The Laptop has Apache 2 with php version 4 and mysql version 4 installed. I want my laptop's IP to be 212.159.98.50 then people can access the apache http server from outside my network. Plusnet told me somthing about port forwarding or somthing. I don't actually understand so if anyone can help me and set it up for me I would apricheate it. I am looking mainly at Accar or John Essex but anyone who can help me would be much thanked. I need somone with an messenger account so if you can help post back with your messenger handle name.

Thanks,
Craig Bras
34 REPLIES
N/A

IP's, Broadband and Apache

Hmm, from what you say I'm guessing you have a set of 4 IP addresses from plus.net? If no there is a how-to on setting it all up on the plus.net website which may help:

http://portal.plus.net/supportpages.html?a=264

I'm not quite sure if this is what you're after though. Basically, port forwarding does something like this:

1) Request made to look at your website from the Internet (outside)
2) You have your domain name DNS record setup to point to your public facing static IP (in this case your router)
3) Your router recieves the request to look at your web page on port 80
4) You set your router to forward port 80 requests to an internal IP address (in this case your laptop)

Your laptop can have a private IP such as 192.168.8.10

I'm also not quite sure what you mean when you say you can change the routers port. A port is something which handles a specific type of connection to an IP address. Requests for web pages usually go to port 80, ftp uses 21 and e-mail servers usually use 25 and 110 (I think!). All of these ports can be used from a single IP address, ie a single computer on the Internet can be a web server, ftp server and a-mail server all from the same IP.

Simply, you need to tell your router to forward requests on port 80 to the IP of your laptop (which you should probably leave on an internal IP to save confusion). I'd guess your router manual/CD/website should have some instructions in it about doing this. The main issue with putting your laptop directly on a public IP is security. Without any decent firewall in place your laptop would be completely open to the WWW.

Regards,

nry
N/A

Re: IP's, Broadband and Apache

I agree with NotRichYet

Quote
I have two useable public IPs, 212.159.98.49 and 212.159.98.50. The router's current IP is 212.159.98.49 [...] The router's local IP is 192.168.8.1.


I think you're confusing two different Internet connection strategies, which are described on the Networking with ADSL page.

If you refer to that page, the Four IP (No-NAT) Setup Example illustrates the product you have -- a set of 4 IP addresses, of which the middle two may be assigned to devices. Here is the diagram:

http://www.plus.net/images/adsl_networking_a_general_guide_files/image002.jpg

Your Router and your Wireless Access Point (WAP) are represented by the two yellow boxes. But you'll note from the diagram that both of these are assigned public IP addresses -- the Router gets the same IP address on both of its interfaces (212.159.98.49 in your case) and the WAP would be given the second address (212.159.98.50 in your case) on its Ethernet interface. This is not the scheme you've followed in your configuration. The only way your laptop could use the 212.159.98.50 address is by playing the same role as indicated by the second yellow box in the diagram.

Now look at the earlier diagram, representing the Single IP (NAT) example:

http://www.plus.net/images/adsl_networking_a_general_guide_files/image001.jpg

Remember, this is for a single IP setup, which is not what you have. But if you look at the IP adddreses used by the Router in this setup, you'll see your own router follows the same principle, with a public IP address on its WAN interface, and a private IP address on the LAN interface.

Therefore, you've mixed-and-matched concepts from each of the two different connection strategies. You cannot do this -- you have to use either one or the other.

For your purposes, the Single IP address (NAT) arrangement would be suitable, as NotRichYet points out. Look at the orange box on that diagram -- "Server receiving IP traffic via Port Forwarding" -- this could be your laptop web server.


Quote
I want my laptop's IP to be 212.159.98.50 then people can access the apache http server from outside my network.


The laptop does not have to have a public IP address, because the router (the device with the public IP address) can be told to forward traffic to the private IP address assigned to the laptop. This is "Port Forwarding", in which traffic arriving on port 80 (the usual port for HTTP) at the router's 212.159.98.49 address can be forwarded to port 80 at whatever private address the laptop has been given. This is a standard feature of ADSL routers.

Quote
Plusnet told me something about port forwarding or something. I don't actually understand so if anyone can help me and set it up for me I would apreciate it.


We've just discussed this; it applies to the Single IP (NAT) connection method.

So, to summarise: the product you have from PlusNet is the "No-NAT" (multiple public IP address) product, but the way you've configured your equipment is for the "NAT" product (single public IP address). You can certainly do this, but it means you will make no use of the other IP address. I think you should ask PlusNet to switch to a NAT product (which means they can take back the block of IPaddresses for someone else, and assign a single address to you).

If your router has a public IP address of 212.159.98.something and a local address of 192.168.8.1, your laptop could have an address "192.168.8.something" (1 < "something" < 255) and the router told to forward port 80 to whatever address that is. (Similarly for port 443 if you use https). Look in your router documentation for terms like "Port Forwarding", "Port Redirection", "NAT" or "NAPT" which will probably explain how to do this.

Something tells me the Mods won't like those diagrams...

[Moderators note (by Thomas): I'm afraid I don't, so I've just turned them into URLs instead. Smiley ]
Community Veteran
Posts: 6,983
Thanks: 8
Registered: 10-04-2007

IP's, Broadband and Apache

Quote
Something tells me the Mods won't like those diagrams...


Very true, they are a bit screen hogging but as they are very relevant to this issue I'll leave them in place Cool
craigbrass
Grafter
Posts: 1,009
Registered: 30-07-2007

IP's, Broadband and Apache

Is there anyone that would mind setting it up for me?
N/A

IP's, Broadband and Apache

I don't think you're too far off the mark as it is.

Your router is obviously set for NAT, and I'd be inclined to leave it that way. With 192.168.8.1 as the router's local address, you could set 192.168.8.2 as the laptop's address. For the "Port Routing" function on the router, you need a known IP address to which to route, so the laptop has to be guaranteed to always be assigned that known address, which means either setting it manually in its network configuration, or if you have a DHCP server which can issue fixed addresses to known hosts, you could use DHCP (which is, after all, the ideal for a laptop). Your router just might be able to do this.

As for which router you have, I think there's been some confusion over the router being issued by the PlusNet companies. Back in October over on the Force9 forum there was a person who also made an enquiry concerning the "Alcatel ADSL Router" supplied by Force9 (one of the other PlusNet brands) -- model "3881 version 2.6k". [Use the guest login details to view the thread.] It turned out this router is actually an AR11 ADSL router (http://www.aceex.com.tw/test1/product/ar112.htm) and I suspect yours probably is too, as it was issued at much the same time. This router was being touted as using the "Alcatel chipset", which is probably the cause of the confusion. Force9 customer "deepsea" has a useful article about this router at http://www.deepsea.force9.co.uk/router.html. In it, he refers to a Force9 setup guide which conforms to the information you've supplied about your own setup -- http://portal.f9.net.uk/supportpages.html?a=222.

I downloaded the manual from the ACEEX support page referred to earlier, and it now refers to the Conexant chipset, so the router may have changed somewhat, but I hope the configuration is similar. If it is, then it would appear that this router is not capable of providing a fixed IP address to known DHCP clients, so you'd have to configure your laptop's network settings manually.

For the port forwarding, the configuration screen to go to is called "Virtual Server". If you go to this page, you'll see it's quite easy to configure. If your laptop has been given the address 192.168.8.2 and it's http (port 80) you wish to be forwarded, the settings are:
    Public port: 80
    Private port: 80
    Port Type: TCP
    Host IP address: 192.168.8.2

Then press the "Add this Setting" button. You may also wish to forward port 443 (for the https protocol). It points out the settings need to be saved, which is done using the "Save Settings" link over on the left frame. When you confirm that, the router will reboot and the settings will be in effect.

That should be it!

If you do this, you will only be using one of the IP addresses which have been reserved for you. As IP addresses are in demand, you should relinquish surplus ones, so someone else can use them instead. So, use Contact Us to ask PlusNet to change you from the No-NAT to NAT product. This may mean you end up with a different public IP address, but if you have set your router to obtain it dynamically, it should only need a restart of the router when PlusNet has done its work.
craigbrass
Grafter
Posts: 1,009
Registered: 30-07-2007

IP's, Broadband and Apache

I can't seam to find the option on this router to turn off nat. Is there a way or not on this router?
N/A

IP's, Broadband and Apache

Yes, in the manual I'm looking at, the options on the "NAT" configuration screen seem to be "Dynamic NAPT" (the default) "NAPT" and "NAT". The descriptions of each of these seem rather garbled to me, so it's not at all clear what they are supposed to do.
craigbrass
Grafter
Posts: 1,009
Registered: 30-07-2007

IP's, Broadband and Apache

I have setup the router so people can access it globally. Is there anyone willing to go into the settings and set it up for me?
N/A

IP's, Broadband and Apache

Trust me, if you do it yourself you'll feel a lot better! I'd guess that since you've managed to get Linux running on your laptop you're more than capable of playing with this to get it working.

Aside from the HUGE security risk of letting someone you don't know configure your router! They could do anything to your system while they're 'setting it up' and you wouldn't know about it!

Regards,

nry
N/A

IP's, Broadband and Apache

I've been reading the manual for your Wireless Access Point (WAP), the 3Com 3CRWE41196. In view of what I've read, here's my advice on configuring your system.


The Router (Part 1)

Leave the router in NAT mode (Dynamic NAT as it calls it on its "NAT" Configuration screen). It will pick up 212.159.98.49 as its WAN (public) address, unchanged from before.

On the "LAN" configuration screen leave its IP address as 192.168.8.1 with 255.255.255.0 as the subnet mask. Uncheck the "DHCP Server", which means the settings of most of the rest of that screen do not matter. On the "Ethernet Mode" selector, choose "Autosense" and press "Submit".

For now, do nothing about "Virtual Server" configuration -- we'll come back to this later.

On the "DNS" configuration screen, choose the "Use Auto Discovered DNS Servers Only" option for "DNS Proxy Selection" and press Submit.

Save these settings (probably not much different, if at all, form what you already had).


The Wireless Access Point (WAP)

The good news is the WAP also has a built-in DHCP Server, and (according to the manual) it will issue the same IP Address to a given host whenever that host requests network parameters. So, we can be reasonably certain, if your laptop is configured as a DHCP client, it will be given the same IP address every time it connects; therefore, we can use this address in the "Virtual Servers" Configuration screen on the Router. So it seems a good idea to use the DHCP server facility of the WAP to configure the laptop and possibly any other wireless systems which you want to connect.

I'm now suggesting that the IP address of the WAP should be 192.168.8.2 (the next address on from the one used by the Router), again with a subnet mask set to 255.255.255.0. These settings can all be configured on the "LAN Settings" configuration screen:

Static IP address (to be configured manually)
IP Address: 192.168.8.2
Subnet mask: 255.255.255.0

DHCP Server: Enable - checked

The DHCP Settings now need to be configured:
IP Pool Start Address: 192.168.8.3
IP Pool End Address: 192.168.8.254
Default Gateway: 192.168.8.1
Primary DNS Address: 192.168.8.1
Secondary DNS Address: 192.168.8.2

Press the "Apply" button.


The laptop

I'm not sure which operating system you're running on the laptop, but whichever it is, you should set up its networking so it acts as a DHCP client -- ie it "obtains its IP address" dynamically, and the same for default gateway and DNS servers.

If you now reboot the laptop, it should acquire network parameters from the WAP, and the WAP should reflect this fact in its "DHCP Clients List Screen" which should now show an entry for your laptop computer. On this entry it shows the IP address which was assigned to the laptop -- probably 192.168.8.3. Whatever address you see here will be shown as <laptop address> in the rest of this post. Armed with this information, we can now go back to the Router, and finish off its configuration with the "Virtual Server" settings.


The Router (Part 2)

On the "Virtual Server" configuration screen, make these entries:
Public Port: 80
Private Port: 80
Port Type: TCP selected
Host IP address: <laptop address>
Press "Add this setting"

If your laptop's Web server also uses the HTTPS protocol (secure HTTP), repeat this specifying port 443 instead of port 80, giving you two entries.

Once again, save the settings on the router, and let it reboot.


That should do the trick!
craigbrass
Grafter
Posts: 1,009
Registered: 30-07-2007

IP's, Broadband and Apache

It still does not work. I have noticed that there are many variatios of the router. I have the jetway version. Any more ideas like DMZ?
N/A

IP's, Broadband and Apache

Out of interest, how are you trying to see if it has worked? I'm guessing from your first post that the public facing IP of the router is 212.159.98.49 and I can't http://212.159.98.50 and get a website displayed so I'm guessing you haven't got it working as of this post.

Can you access the laptops webpages from internal PC's?

Regards,

nry
craigbrass
Grafter
Posts: 1,009
Registered: 30-07-2007

IP's, Broadband and Apache

Nope, I haven't got it working. I am wanting to access my local copy of apache from the internet. If that is accessing it via 212.159.98.50 or 212.159.98.49:95 it does not matter but I want people to see my test work rather than having to upload it to the net. Any ideas.
N/A

IP's, Broadband and Apache

Are you running any sort of firewall software on your laptop? Could it be blocking incoming HTTP requests on port 80?

Browse to the ShieldsUp!! website. Which IP address is detected? Now scroll down to the "ShieldsUp!! Services" box, enter 80 in the text input area, and press the "User Specified Custom Port Probe" bar. Does it report that port 80 is open?

Coming back to your own system, did you try setting up as I suggested? Which IP address was the laptop assigned? Were you able to access the Internet from the laptop with this configuration? Do you have another computer locally, form which you can attempt to access the laptop by browsing to its local IP address? -- does that work?

Do the apache logs on the laptop report anything of significance?