cancel
Showing results for 
Search instead for 
Did you mean: 

IP Address Question & Port 80 Sanity Check

N/A

IP Address Question & Port 80 Sanity Check

Hi,

I have a question plus the need for a sanity check on something I'm attempting - the question first. . . .

1/ I've a static IP address of lets say 81.174.133.54 . If I check my security with 'Shields-Up' ( https://grc.com/x/ne.dll?bh0bkyd2 ) then it reckons my address is 81.174.138.54 . Probing 81.174.138.54 I discover that it is in fact my address rather than the static addres I set in my router. Why the discrepancy between my static IP address setting (as per my router - Netgear DG814) and what's seen on the net?

2/ Sanity Check.
I'm developing a web server application and need colleagues to be able to access it for testing so I thought I'd give them access via my ADSL line

The application sits on my local LAN which consists of PCs and the Web Server (Linux) with the ADSL router acting as the hub and internet gateway.

All the PC's can successfully access the local web server which is on 192.168.2.130.

All devices including the Linux box successfully access the internet via the adsl router.

On the adsl router I've set port forwarding for port 80 to 192.168.2.130.

Should this work? As you might have guessed, it doesn't. But before I spend two much time puzzling over it I wanted to check the sanity of what I was doing. Incidentally, I've switched the linux firewall off to remove that variable and 'Shields Up' indicates that port 80 is open.

Thanks
6 REPLIES
Community Veteran
Posts: 14,469
Registered: 30-07-2007

IP Address Question & Port 80 Sanity Check

1) I assume you have not been allocated a block of 4 or 8 IP addresses by PlusNet? If you have not then that could be a config error by PlusNet. Is the Netgear setup to get it's Internet IP (i.e. PlusNet allocated IP) address automatically (set to get dynamically from ISP) or have you manually entered the IP address and netmask? If it is set manually, change it to dynamic and reboot and see if it now corresponds with what the DNS lookup gives you. Note: tyou should also have the DNS set to get automatically from ISP.

If you go to connection seettings -> Static IP, which of the two IPs you have mentioned does that page correspond to?

2) Yes, the port forwarding should be all you need for external IPs to access your internal web server. Just make sure remote management on the router is disabled, otherwise it will be responding to connection requests and not your web server. It normally defaults to listening on port 8080 but I mention this just in case you have changed it..

What firmware version are you running on the router. The latest is v4.10 so if it's not that version try upgrading the firmware (and do a factory reset afterwards) then reconfigure it and see if that works.
N/A

IP Address Question & Port 80 Sanity Check

1./ No block allocation of IP address to my knowledge.

Have checked the router settings and status.
The router is set to a static id equivalent to the 81.174.133.54 example I gave above.
However it actually records the WAN address as equivalent to 81.174.138.54 -ie the addess seen by 'Shields Up' and the addresss which responds to pings.

I attempted to change to dynamic allocation as you suggested and the router crashed (the NetGear panel showed html formating text), So I rebooted and upgraded to v4.10 . The upgrade went fine. I reloaded my previous settings - went to change from static to dynamic allocation and the router crashed again just as before. In fact even upgrading the firmware and entering the configuration from scratch the router crashes when I hit 'Apply'.

So the outshot of this is that although I'm allocating a (possibly incorrect) static address to the router it appears to be adopting an alternative one and I appear to be unable to change the settings. :roll:

I'm concerned that this incompatability might impact the port forwarding - but I'm in the dark on that one.

2./ Router Remote management is off.
I've set up port forwarding for telnet and ftp to see if I can get either of those working but no success there either. One useful observation though. With port 80 forwarded, if the server is turned on the 'Shields Up' identifies port 80 as open. If the server is down the 'Shields Up' see port 80 as stealthed - which to me indicates that something must be getting through to the server. If that is the case I wonder if it indicates the problem lies with the server rather than the router?? If the latter it would indicate it is treating 'local' traffic differently from router/internet based traffic - though given the firewall is off that leaves me a bit puzzled.
Community Veteran
Posts: 14,469
Registered: 30-07-2007

IP Address Question & Port 80 Sanity Check

Did you reset the router back to factory defaults after upgrading the firmware as this is necessary in some cases. This is done by pressing the hidden reset button located at the back of the router between the telephone cable and the first network cable (you need a paperclip to do it, just poke it in the small hole you see to reach the button).

When you said you reloaded your previous settings, was this from a saved config file or did you manually enter the details again. It is likely to fail if you used a config file as new features and parameters were added in each of the releases which the config file would not have. A factory reset and manual entry of your settings is required.

Also If you go to connection seettings -> Static IP, which of the two IPs you have mentioned does that page correspond to as that is the IP address that has been allocated to your ADSL line.

Note: I have the same router and always reset to factory defaults whenever I do a firmware upgrade then manually eneter the settings again. I also use dynamic for internet IP and DNS settings and I am using v4.10 firmware so I know it does work.
N/A

IP Address Question & Port 80 Sanity Check

Just to be certain - I've gone through the upgrade again - namely

- Upload Firmware
- press rest-factory settings button on back of router
- reboot router
- log in with factory default user and password
- attempt to manually enter the configuration

Unfortunately when I hit the apply button I still get the crash I mentioned earlier. The only way I'm able to re-config the router is to upload my previously saved config - which given what you've said may cause problems in itself. It makes me wonder if there's a software corruption in the router somewhere.

In answer to your IP address questions - I'll use some real addresses - probably makes life easier . . .

a/ I've checked my Static IP address as per +Net and it is set as
81.174.159.44

b/ If you refer to the router's Basic Settings page (which is the one I appear unable to change) it is set to a static address of

81.174.154.44 - so that's wrong then :roll:

c/ If you refer to the Gateway Status page it shows a WAN Port IP address of

81.174.159.44

The latter address is what appears to be active on the net and can be pinged.

So from a router perspective I now know what address should be set - but the router software falls over when I attempt a submit.
N/A

IP Address Question & Port 80 Sanity Check

As an addendum to the above. . .

I exported by configuration and had a look at it. The netgear .cfg file is in plain text - so I amended the static address in that and reloaded the config.

It worked like a charm. Now my IP addresses agree. Smiley

No joy yet on accessing the webserver though.

One entry in the .cfg file did interest me however - namely. .

[PACKET FILTER]
url=disable
website=block

Had a hunt in the netgear menus to see if I could track them down but was unable. Have you come across them at all?
N/A

IP Address Question & Port 80 Sanity Check

All Fixed!

The change I made to the .cfg file did the trick. Unfortunately I continued to test the server access via my adsl link - :| - just tested it via a dial up internet link and it works fine.


Many thanks for your help!