cancel
Showing results for 
Search instead for 
Did you mean: 

IF YOU GOT BAD PING TRY THIS!!!

N/A

IF YOU GOT BAD PING TRY THIS!!!

USE DR TCP

INPUT THESE SETTINGS AND VOILA!

Rwin 64240 / Windows Scaling Yes / Timestamp Off / Selective ACKs Default / MTU discovery On / Black hole detection On / TTL 128 / MTU 1492

my ping went ***** 2 weeks ago..

and now its back down to 20-50 .....hooray
4 REPLIES
N/A

RE: IF YOU GOT BAD PING TRY THIS!!!

> USE DR TCP
>
> INPUT THESE SETTINGS AND VOILA!
>
> Rwin 64240 / Windows Scaling Yes / Timestamp Off / Selective ACKs Default / MTU discovery On / Black hole detection On / TTL 128 / MTU 1492
>
> my ping went ***** 2 weeks ago..
>
> and now its back down to 20-50 .....hooray
>

I've got to admit I just can't see how this is going to help although I've not tried it.

If I use ping to check for packet Fragmentation anything over MTU=1430 fragments (i.e MTU=145Cool so with an MTU of 1492 you must be getting split packets (unless BT have already modified the Broadband Access Servers you link through).

Also having such a high TCP receive window should only cause a greater problems if packet loss is occuring. My guess is that this only seems to improve things when the plusnet servers are not loaded but makes thing worse when they have heavy traffic.

I would have thought an MTU=1458 with a smaller RWIN would have been a better solution or have I misunderstood the concepts here. I'd be interested in other views.
espresso_mick
Grafter
Posts: 225
Registered: 30-07-2007

RE: IF YOU GOT BAD PING TRY THIS!!!

I agree. If your RWIN is too high, this can cause packet loss.

I've been using the following settings for quite some time with no problems at all.

1458 MTU & 12868 RWIN

Delves
Grafter
Posts: 188
Registered: 26-08-2007

RE: IF YOU GOT BAD PING TRY THIS!!!

To be quite honest I think too much is being put on these settings as a solution to the slow problems. Granted they do improve your speed to some degree but the problems with speed I'm having isn't going to be sorted by tweaking these settings anymore.

I've checked mine at the DSL reports site and it says they are good.

I think it suites +net for eveyone to jump on settings while they potter away trying to resolve the real issues.


> I agree. If your RWIN is too high, this can cause packet loss.
>
> I've been using the following settings for quite some time with no problems at all.
>
> 1458 MTU & 12868 RWIN
>
>

N/A

RE: IF YOU GOT BAD PING TRY THIS!!!

Yeh I agree, but the original poster has put this forward as a solution to the high pings.

I can't see how this will help other than cause your connection to slow by causing fragmentation (back to the november slow speeds).

Personally my speeds have been 470/240 even during these high ping times, but I'm pretty sure if I made the changes suggested they would fall.

Has anyone made these changes and got low ping times and still maintained good speeds?