cancel
Showing results for 
Search instead for 
Did you mean: 

Horrible Lag when connecting to game servers

N/A

Horrible Lag when connecting to game servers

I have a 2mb package which is now running at full speed, (I did have the disconnection problem, but that is now resolved).

I do find that when I join a game server my ping will climb to the 6/700's
It will settle down to around 40 after a few minutes and remains stable until the next map change when ping climbs to a similar figure for a similar amount of time.

Although not a major issue, it IS annoying.
Has anybody else experienced this, or does anyone have any ideas what is happeneing and how to fix it?

Many thanks
5 REPLIES
Community Veteran
Posts: 3,181
Thanks: 19
Fixes: 2
Registered: 31-07-2007

Horrible Lag when connecting to game servers

What game? and does it use punkbuster. Some games use cheat protection that checks your files during the first 2 mins of gaming, punkbuster for Quake3 engine games & CS & 1942 / Anti TCC for Unrealtournament 2004. So add to you ping and lag.

Have you just closed a p2p session just before joining? If so then your conection won't be suitable for gaming for 10-20 mins after.

Do you have msn / icq / aim etc open at the time, if so close them.
Unvalued customer since 2001 funding cheap internet for others / DSL/Fibre house move 24 month regrade from 8th May 2017
N/A

Horrible Lag when connecting to game servers

The games in question are Tribes2 and Tribes:Vengeance

Neither use punkbuster or similar and its the same on all servers regardless of country of origin.
It will occur no matter what I was doing previously, chatting, downloading or even from a fresh boot up.

If I quit the game during the lag and run an adsl benchmark I get the usual high scores. On previous ISPs the glitch didnt appear at all so I'm fairly confident its not my software.
Community Veteran
Posts: 3,181
Thanks: 19
Fixes: 2
Registered: 31-07-2007

Horrible Lag when connecting to game servers

Tribes has some of the same issues as UT99 and UT04 as they use the UT engine. Check your ping via the command Stat Net or its bound F key, which is more accurate than using the inbuilt Server Browser.

Also best to add servers in your favorites so to by pass the Master Server, which helps to show a True ping to a server as your game pings it directly which gives a simmilar reading to Stat Net. This is because the Master Server can give you false Low pings whikch you only find out when joining the server.

Plus the fact that it could just be the Server you are playing on. If its a listen or under powered server then yeah the pings will jump about a lot as new people join/leave. Only rented servers on a good connection with a decent server pc will give a steady ping.
Unvalued customer since 2001 funding cheap internet for others / DSL/Fibre house move 24 month regrade from 8th May 2017
N/A

Horrible Lag when connecting to game servers

Thanks, I'll look into this.

However, as far as I know Tribes2 doesnt use the same net code as Vengeance, UT etc, and I get the same lag when joining a dedicated Tribes2 server.

Thanks for the help. I'll see what I can do.
N/A

Horrible Lag when connecting to game servers

I've had time now to try multiple servers. No change, dedicted, hosted, Tribes2 or Tribes Vengeance, I still get about 3 minutes of really high ping before it settles. A friend, on a 512k connection on the same servers experiences none of the lag.
This didnt happen, at least with Tribes2, until I aquired my Plus.Net package.
I guess I'm still open to suggestions :/