cancel
Showing results for 
Search instead for 
Did you mean: 

First Hop Latency - Issue or Normal

Lorian
Grafter
Posts: 699
Registered: 31-07-2007

First Hop Latency - Issue or Normal

Had ADSL now for two weeks.

SAR110, 288/576 no rate adaption. Downloads are great, 480K on the speed test.

However I'm a bit disappointed by the latency. The first hop from my router to the plusnet network is 38ms:

Tracing route to www.linx.net [195.66.232.42]
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms 192.168.7.10
2 38 ms 37 ms 38 ms pth-ag2.plus.net [195.166.128.6]
3 37 ms 39 ms 40 ms gi1-2.vlan3.pth-gw4.plus.net [212.159.1.3]
4 39 ms 38 ms 38 ms gi5-0.pth-gw1.telehouse.core.plus.net [195.166.1
29.21]
5 38 ms 38 ms 41 ms collector.linx.net [195.66.225.254]
6 38 ms 42 ms 42 ms piper.linx.net [195.66.232.42]

Trace complete.

Is this normal - what are others are getting? Can anything be done to reduce that first hop latency?

Maybe I'm just being too demanding :?:

Jc
13 REPLIES
N/A

First Hop Latency - Issue or Normal

Tracing route to www.linx.net [195.66.232.42]

over a maximum of 30 hops:

1 <1 ms 1 ms <1 ms 192.168.0.1
2 19 ms 20 ms 19 ms pth-ag2.plus.net [195.166.128.6]
3 35 ms 31 ms 30 ms gi1-2.vlan3.pth-gw3.plus.net [212.159.1.2]
4 19 ms 20 ms 19 ms gi5-0.pth-gw2.telehouse.core.plus.net [195.166.1
29.22]
5 19 ms 20 ms 20 ms pr2.tcm.linx.net [195.66.227.254]
6 20 ms 20 ms 23 ms g0-0.tr3.tcm.linx.net [195.66.248.126]
7 19 ms 20 ms 19 ms e2-2.collector.thn.linx.net [195.66.248.241]
8 23 ms 23 ms 23 ms piper.linx.net [195.66.232.42]

Trace complete.


This seems pretty normal to me..
Lorian
Grafter
Posts: 699
Registered: 31-07-2007

First Hop Latency - Issue or Normal

Quote


This seems pretty normal to me..


Hmm thats what I was expecting soemone to say. 20ms. I have a friend with another ISP who has 18ms first hop.
N/A

First Hop Latency - Issue or Normal

Have you always had the 30ms latency, or only recently?
Lorian
Grafter
Posts: 699
Registered: 31-07-2007

First Hop Latency - Issue or Normal

Quote
Have you always had the 30ms latency, or only recently?


It's always 37-38ms latency on the several times I've checked it tonight.

Tonight is the first time I looked at, when someone else online said their first hop was 17ms, and I checked mine out Sad

My online pings are around the same I used to get with ISDN with my previous ISP.

I've only had ADSL for just over a week.

Jc.
Plusnet Staff
Plusnet Staff
Posts: 12,169
Thanks: 18
Fixes: 1
Registered: 04-04-2007

First Hop Latency - Issue or Normal

Hi,

Have you run the Network Optimiser from

https://portal.plus.net/supportpages.html?bvIkeqvfDEk%3D

this may make a difference?

Also, try running the ping/tracert test at different times of the day to see if that makes a difference. There may just be a little contention at your exchange.

We're you downloading anything at the time? This could have an impact on the ping times.
Lorian
Grafter
Posts: 699
Registered: 31-07-2007

First Hop Latency - Issue or Normal

Quote
Hi,

Have you run the Network Optimiser from

https://portal.plus.net/supportpages.html?bvIkeqvfDEk%3D

this may make a difference?

Also, try running the ping/tracert test at different times of the day to see if that makes a difference. There may just be a little contention at your exchange.

We're you downloading anything at the time? This could have an impact on the ping times.


Hi,

No the Network Optimiser didn't make any difference, it just changed my MTU to 1458 when it was that already :-)

I wasn't downloading anything at the time!

I'll certainly try some pings in the morning, but based on my in-game pings the last few days of nver better than 60-70ms on UK servers I think the problem is persistant rather than transient.

Further info: The router is running NAT in routing mode. I've tried turning all filtering off. I have also checked the 110 is using G.DMT modulation.

Jc.
Plusnet Staff
Plusnet Staff
Posts: 12,169
Thanks: 18
Fixes: 1
Registered: 04-04-2007

First Hop Latency - Issue or Normal

Hi,

Well the optimiser was worth a try.

Do you have any firewall software installed? If you are using Windows XP this has a built in firewall. Also are the firewall settings enabled on the router?

If this makes no difference try it again later tonight if you can and in the morning.
Lorian
Grafter
Posts: 699
Registered: 31-07-2007

First Hop Latency - Issue or Normal

Quote
Hi,

Well the optimiser was worth a try.

Do you have any firewall software installed? If you are using Windows XP this has a built in firewall. Also are the firewall settings enabled on the router?

If this makes no difference try it again later tonight if you can and in the morning.


All the firewall, protection and filtering are turned off in the router.

WinXP firewall is not configured on my LAN interface and I am not using any other firewall software .

I just tried it again now, it's a little worse, average around 40ms first hop.
I'll try it again in the morning.

Anything else to try? If I could get that reduction of 20ms it would be great.

Thanks for the help,

Jc.
Lorian
Grafter
Posts: 699
Registered: 31-07-2007

First Hop Latency - Issue or Normal

Quote
Hi,

If this makes no difference try it again later tonight if you can and in the morning.


It's just as bad (38ms) at 7am on Sunday morning:

Tracing route to www.linx.net [195.66.232.42]
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms 192.168.7.1
2 37 ms 38 ms 38 ms pth-ag2.plus.net [195.166.128.6]
3 38 ms 37 ms 39 ms gi1-2.vlan3.pth-gw4.plus.net [212.159.1.3]
4 39 ms 37 ms 38 ms gi5-0.pth-gw1.telehouse.core.plus.net [195.166.1
29.21]
5 40 ms 37 ms 38 ms collector.linx.net [195.66.225.254]
6 38 ms 40 ms 41 ms piper.linx.net [195.66.232.42]

Trace complete.

Jc.
N/A

First Hop Latency - Issue or Normal

12:36pm : I'm still getting 19ms to the +net servers [and only 22ms to the linx.net servers].

I may be coompletely wrong, but does connection speed have anything to do with wiring? I.E. distance from exchange, or amount of wiring from router > you, etc.[/code]
Lorian
Grafter
Posts: 699
Registered: 31-07-2007

First Hop Latency - Issue or Normal

Quote
Hi,

Well the optimiser was worth a try.

Do you have any firewall software installed? If you are using Windows XP this has a built in firewall. Also are the firewall settings enabled on the router?

If this makes no difference try it again later tonight if you can and in the morning.


Well I don't think it's caused at my end. I just tried another PC connected via a Intel Anypoint 3240 modem (no router) and also got 37-38ms first hop.

I'll raise a ticket now I know it's not my hardware.

Jc.
Ianwild
Grafter
Posts: 3,835
Registered: 05-04-2007

First Hop Latency - Issue or Normal

Hi Guys,

Connection speed and ping times are dependent on so many things. The latency here is occuring before the connection hits our servers, so it is something that exists within the local exchange or BTs network which is probably causing the delay.

Line noise and a high DB reading will result in more latency and potentially a slower connection. I suspect Peter that this could be normal for you with being on the extended reach trial. With that sort of Latency BT are not going to see it as a problem (I have seen people with 70ms to the first hop being told this is acceptable by BT faults) and given that the delay is being caused in their part of the network I'm afraid I'm struggling for suggestions as to how we work with this.

I think it might be worth waiting until the end of the week when BT will have finished their platform upgrades to see whether this has any effect...

Regards,
Lorian
Grafter
Posts: 699
Registered: 31-07-2007

First Hop Latency - Issue or Normal

Quote
Hi Guys,

Connection speed and ping times are dependent on so many things. The latency here is occuring before the connection hits our servers, so it is something that exists within the local exchange or BTs network which is probably causing the delay.

Line noise and a high DB reading will result in more latency and potentially a slower connection. I suspect Peter that this could be normal for you with being on the extended reach trial. With that sort of Latency BT are not going to see it as a problem (I have seen people with 70ms to the first hop being told this is acceptable by BT faults) and given that the delay is being caused in their part of the network I'm afraid I'm struggling for suggestions as to how we work with this.

I think it might be worth waiting until the end of the week when BT will have finished their platform upgrades to see whether this has any effect...

Regards,


Ian,

Thanks for the response. I know I'm lucky to have ADSL at all, so I don't want to push my luck.

If I use bt_test@startup_domain my ping time is worse than others report too, confirm what you say I guess. Given I live near gods own country I should be thankfull with 38ms!

Jc.