Showing results for 
Search instead for 
Did you mean: 

Domain config for another email server


Domain config for another email server


I want to ask a question in regard to my domain settings, on the PlusNet portal as PlusNet were not allowed to answer me.
i have installed my own email server as a project and everything is working fine, as in loggin into the system, creating accounts, sending out-going emails etc...

My trouble is i can't receive any e-mails sent to the domain name i have on 'My Domains' on the PlusNet portal 'my domain settings' i have set the email for: wish to specify DNS records for mail to this domain, then i set 'MX' and pri =1 and set to my own IP address 212.159.XXX.XXX - on the right side field box, and have left the left-side box field empty.

Is this the correct method to send my email to my own mail server?. As when i send an e-mail to 'My Domain' instead of being received on my own email server, i get it sent back to me as: Mail delivery failed: returning message to sender
This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

all relevant MX records point to non-existent hosts
Can anyone tell me what the setting is on the portal under 'My Domains' to direct my PlusNet hosted domain email to my own mail server?.
I'm not sure ive set it correctly on the PlusNet portal.
Should it be 'send email via smtp to my static IP' ?

Any help apricated.

Domain config for another email server

This is almost correct. You need to specify one more step.

1: Set the domain to other, for email delivery

2: Add a MX record with the left field blank, the pri set to 5 (best advised) and teh right set to "mail" or some other name

3: Add a A record with the nameused in thr right feild above, this time placing it in the left field, then place your IP address in the right field, leavin pri empty.

This is an important step.

Domain config for another email server

Thanks for your help Philip,
I'll go and set that up on the 'domain settings'
and wait on it updating.

I've been getting lots of different messages,
I put the machine in the DMZ as a last check
incase I had left any ports blocked, just for 5 mins
mind as I wouldn't leave it unprotected any-longer!.

When I did I got this failure message, different from the last,
"<>: host[] said: 550 relaying
blocked, read new mail, add to forwarding or enable smtp
authentication in yo (in reply to RCPT TO command)"

That's when I tried to email my server from
It's a "SurgeMail Version: Windows 1.9b-1 May 5 2004"
up-to-date version, quite nice server but alot of settings,
anyway I shall go now and update my domain settings.

Thanks again. I'll post back if I get any luck! Smiley

Domain config for another email server

PS> That's me done exactly as you explained Phil.

It made alot of sense!

Left field Type Pri Right field

mail a
mx 5 mail

So I will have to wait a while on the nameserver updating now,
I'm not sure if PlusNet only update over night or not?.
I'll just keep checking to see when the mail A name is pointing to my IP.
is there any special ports I should allow the router to port forward?.

I only plan on using the 'WebMail' which comes with this server,
to login send and receive mail etc...

On the log file I found this:

imap host='' smtp host=''

Do I open port 143 for imap? and also port 25 for smtp?.
thing is there is loads of ports all saying they are listening via my ZoneAlarm,
but I'm also behind a NAT (router) etc.... so I still have to port forward I think.

Here is the ports I see listening for this server:
25, 106, 110, 143, 465, 993, 995, 7025, 7026, 7080, 7110, 7443, 7995.

That's all the ports listening on the ZoneAlarm for surgemail.exe
of course I would think id still need to open port forward for them?
if so do I just do the port 25 for smtp and the imap port 143,
as I only have 10 port forwards on my router, and most are taken up already!
only have a few spare.


Domain config for another email server

It's working now!

Thanks Phill

I also had to open up port 25 to receive mail on the server (smtp)
and port 110 (pop) to send, works opposite way round because it's the server and not an email client.
I have no idea about the IMAP port, is that for the web mail?
or do we not use that port 143?

Anyone know.

Ah well it passed the time Cheesy

Domain config for another email server

IMAP is a more feature packed method of e-mail storage and collection, like POP3.

It stores all mail server side, noting when you have read mail or not. It also has folder, so you can sort your mail.

It is handy for people on the move, as they can login from different machines, using webmail or client software, and have access to the same e-mail content regardless of which system you are on.

Webmail is normaly provided over port 80, using a web server. All webmail is, is a server side gateway that deals with the collection and display of e-mails, and formats them for a browser.

Webmail interfaces can often use both POP3 and IMAP systems. Again, IMAP is better, as it means all content can remain on the e-mail server until needed.

Domain config for another email server

Sounds good IMAP,
i never really read up on it before now, yes the email server i installed,
though i can collect on my email client, i use the web mail thats built into it, it runs on ports 8070 http and port 7447 i think on https secure.
I can change it to port 80 but i have an Apache server on that.

I will set it for port 143 then, as thats the IMAP setting.
i looked IMAP up after reading your message, is a good read.

Have a look at the Surge Mail server, its really professional,
and easy (once you know how) to set-up.

Get it 30 day trial from here:
it costs $500 for a license, but its easy to get the 3 required reg files
and skip that part, if you look about, its a pro ISP mail server.
Not that i plan to run an ISP, i just like the software for personal use.
I doubt i will set it up on a public webpage, id have spammers using it, and id get the blame :twisted:

Thanks for all your help Philip.