cancel
Showing results for 
Search instead for 
Did you mean: 

DG814 no nat config or switch from gateway to bridge?

N/A

DG814 no nat config or switch from gateway to bridge?

I'm trying to configure my DG814 to simply run as an adsl modem. I have 2 static IP addresses from PlusNet and am trying to set my connections up so that 1 of the public addresses is on the DG814 and the other is assigned to the WAN side of the linux firewall box that sits behind the DG814. At present both the router and linux firewall are set up for NAT , therefore causing problems with regard to VPN trying to pass through double NAT .

I've found out that NAT can be turned off on the DG814, but I'm not sure how to then configure everything correctly i.e is that all you do, turn NAT off and then assign the public addresses in the relevant places?. I've also recently discovered that the DG814 can be turned into a simple ADSL modem/bridge by going into http://192.168.0.1\devicetype.htm and switching it from gateway to bridge. Does this then mean that all I need is a static address on the WAN NIC off the firewall?

Is this all I need to do? I've spent so long trying to get it working tonight, I've gone around in circles endlessly and am convinced I'm trying to make it more complicated than it really is :!:

Any help would be much appreciated.

Cheers
Sad
4 REPLIES
Community Veteran
Posts: 14,469
Registered: 30-07-2007

DG814 no nat config or switch from gateway to bridge?

As far as I know just disable NAT, disable DHCP, set the IP address of the DG814 to one of your PlusNet assigned IP addresses and the NIC on the Linux box to the other and your done.

You may need to set the DNS IP addresses on Linux.

I assume the rest of your local network connects to a 2nd NIC in your linux box.
mssystems
Rising Star
Posts: 269
Thanks: 33
Fixes: 1
Registered: 10-08-2007

DG814 no nat config or switch from gateway to bridge?

In full bridge mode the router will pass all traffic including PPP to the internal network, hence you will not be able to authenticate unless you put a PPP/OA client on the Linux box.

Some routers claim to do half-bridging, hence authenticateing the PPP before establishing the bridge, but I have yet to get ine to work.

Two IPs is not enough to set up simple forwarding. You in fact need 3. One for the outside of the router, one for the inside of the router and one for the linux box.

Some routers support Zero IP bridge (ZIPB). You set the outside address the same as the inside and the router assumes all traffic hitting the inside interface needs forwarding although the subnets are the same.

Some routers (few) support un-numbered links, where the subnet between the routers is either 0.0.0.0 or both ends use the same address.

Generally for ADSL modems ZipB is the most successful but a few routers demand that the inside subnet is different to the outside so that they know to route between them.

Regards
Matt
N/A

DG814 no nat config or switch from gateway to bridge?

Hi Guys

Thanks for your replies, it appears then that bridge mode is not what I need. I have a block of 4 addresses from PlusNet, 1 for the gateway, 1 for the address of the router, 1 spare and 1 that's the broadcast address.

I tried turning NAT off before and setting the LAN address of the router as the IP address given for the address of the router and the spare IP address as the WAN side NIC of the linux box, should this work? If so, I'll try again, further, wasn't sure what the default gateway should have been set to on the WAN side of the linux box, the gateway address given by PlusNet or the router address?

Thanks
N/A

DG814 no nat config or switch from gateway to bridge?

Just to let folk know

I managed to get everything working by following advice given, thanks again.

I switched the router to no-NAT, configured LAN address using the assigned address for the router, ensured DHCP was off and that addresses were set to 0.0.0.0 (just to be safe) and then configure the WAN side of the linux box with the spare address assigned by PlusNet. and the gateway to be the address of the router. All worked perfectly, cheers