cancel
Showing results for 
Search instead for 
Did you mean: 

D-link DSL504

N/A

D-link DSL504

Just to let people know that I have just had a problem with this router that is probably worth knowing about.

I was having problems whereby the router said it had a connection and the PC stated that it had all the correct IP information but when I tried to browse I would get intermittent failures when accessing certain sites.

Basically the problem pointed to routing issues with timeouts on pings, and traceroutes not working.

After loads of head scratching and conversations with Support I eventually got fed up and did a factory reset on the router and bingo, it all came back working fine.

So just be aware that if you get similar problems instead of assuming it is a Plusnet problem then try a factory reset on the router, it's also worth loading the latest firmware.

thanks,
Rich.
2 REPLIES
N/A

RE: D-link DSL504

Rich,

Have you tried using the latest firmware for the router. Try this link.. I am using this router and it seems ok to me.

ftp://ftp.dlink.co.uk/pub/broadband/dsl-504/dsl504upgr202b2t4uk.exe

H


> Just to let people know that I have just had a problem with this router that is probably worth knowing about.
>
> I was having problems whereby the router said it had a connection and the PC stated that it had all the correct IP information but when I tried to browse I would get intermittent failures when accessing certain sites.
>
> Basically the problem pointed to routing issues with timeouts on pings, and traceroutes not working.
>
> After loads of head scratching and conversations with Support I eventually got fed up and did a factory reset on the router and bingo, it all came back working fine.
>
> So just be aware that if you get similar problems instead of assuming it is a Plusnet problem then try a factory reset on the router, it's also worth loading the latest firmware.
>
> thanks,
> Rich.

N/A

RE: D-link DSL504

H,

I loaded the latest version, it's actually dsl504upgr202b2t8uk.exe now

R.


> Rich,
>
> Have you tried using the latest firmware for the router. Try this link.. I am using this router and it seems ok to me.
>
> ftp://ftp.dlink.co.uk/pub/broadband/dsl-504/dsl504upgr202b2t4uk.exe
>
> H
>
>
> > Just to let people know that I have just had a problem with this router that is probably worth knowing about.
> >
> > I was having problems whereby the router said it had a connection and the PC stated that it had all the correct IP information but when I tried to browse I would get intermittent failures when accessing certain sites.
> >
> > Basically the problem pointed to routing issues with timeouts on pings, and traceroutes not working.
> >
> > After loads of head scratching and conversations with Support I eventually got fed up and did a factory reset on the router and bingo, it all came back working fine.
> >
> > So just be aware that if you get similar problems instead of assuming it is a Plusnet problem then try a factory reset on the router, it's also worth loading the latest firmware.
> >
> > thanks,
> > Rich.
>
>