cancel
Showing results for 
Search instead for 
Did you mean: 

Connecting to Plusnet

N/A

Connecting to Plusnet

I've been with Plusnet for about a year now and I've recently re-formatted my PC and re-installed windows due to a new hard drive.

Now I can't get connected to the internet, it dials up and sends the username and password but then after a minute or so wait the connection errors.

I'm using an Alcatel Speed Touch USB modem

I've set up the connection exactly the same as I did previously but something obviously ain't right. I've set up my username to sirgaz@plusdsl.net and my password accordingly. The phone number field I've left blank. Basically exactly the way that the instructions show in the customer support section.

Anyone any ideas on what I can do now? At the moment I'm limited to internet access at work only. Sad
2 REPLIES
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Connecting to Plusnet

Are you sure your entering the password correctly (the same one as you used to login to the portal) and all lower case?

Are you sure it's username@plusdsl.net, have you tried username@plus.net which is one of the old logins? The correct ADSL login should be shown via connection settings -> connection details page.

Is you modem syncing with the exchange? If this is the 'green frog' modem then both USB and ADSL lights should be solid green. If the ADSL is amber or flashing it is not syncing.

Have you also tried with the latest V3.01 firmware. The upgrade and manuals can be found here and the full package can be downloaded from here (note: this download applies to the speedtouch USB, speedtouch 510 and speedtouch 330 which are all USB modems).
N/A

Connecting to Plusnet

Password is correct, and typed in several times just to be sure.

I haven't tried with the older username@plust.net, but then my previous windows installation was set up with username@plusdsl.net and it worked fine.

I've already got the latest drivers for the "green frog" modem but I also have some older drivers which were next on list of things to try. Both lights are solid green so it is syncing fine.

Any other ideas?Huh