cancel
Showing results for 
Search instead for 
Did you mean: 

Conexant router and linksys Befw11s4

N/A

Conexant router and linksys Befw11s4

Hi guys. I have a problem. I recently got a conexant modem/1 port router which I am planning to use with my linksys Befw11s4 AP/4-port switch/router. I tried using ALL sorts of ethernet cables between the conexant modem and the linksys router but I still havent managed to get them working together. The problem is that the wan led of the router and the lan led of the modem appear to be off (and therefore not working). Any ideas or reccomendation? Thanks in advance.

P.S. I am sure it doesnt have anything to do but I still dont have adsl in my flat. I am waiting for it but I want everything to work ok. thanks
6 REPLIES
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Conexant router and linksys Befw11s4

I believe your problem is the conexiant is not a cable modem (which is what the linksys is expecting to connect to it's wan port) so you cannot connect it to the wan port of the linksys.

Your only option is to connect the conexiant to one of the 4 switch ports on the linksys. However if you intend to use the wireless part of the linksys things will get very complex to setup as you will have 2 routers probably trying to do DHCP etc.

This may not be helpful but you would have been better investing in a combined modem/router/switch/wireless device and selling your linksys.
N/A

Conexant router and linksys Befw11s4

Can you get the Conexant router to work if you connect it directly to your PC (ie with the Linksys removed from your network)? What is the LAN address of the router when set up this way? (Call this address A)

If you now disconnect the Conexant and connect the Linksys to the PC, what is the LAN address of the Linksys? (Call this address B).

Address A needs to be an address in a different IP network from that used by address B. EG if address A is 192.168.0.something address B must not also be a 192.168.0 address. (If you don't understand all that, post details of the addresses.

If that condition is met, move on to consider the WAN address of the Linksys (Call it address C). Address C must be an address in the same IP network as address A, but with a different host component. EG if A is 192.168.0.something, then C must be 192.168.0.something-else. The subnet masks must also match, and the default route for the Linksys should be address A. You might be able to use DHCP on the Linksys to set its details (assuming the Conexant is set as a DHCP server). You probably need a length of straight-through cable to attach the WAN port of the Linksys to the LAN port of the Conexant.

There's a very old topic, Wireless Router which might help you further.
N/A

Conexant router and linksys Befw11s4

Ok. I got it working yesterday. Although, the setup is a bit weird. I have it like this:

Connexant : 192.168.1.10
Linksys : 192.168.1.1
PCs : 192.168.1.2-4

1) Although, you reminded me that the connexant has to be something like 192.168.0.1 or something. I am not really sure I follow the part about the address C. Inside the linksys config there is the option to get the ip address for the WAN automaticaly or give it a static ip (amongst other options). Since I know the ip of the connexant modem I presume I can set the static ip of the wan port of the linksys router to 192.168.0.1 (ip of conexant). Is this right?

2) You also said that the subnet masks should also match. The default subnet mask for the conexant modem/router is 255.0.0.0 and for the linksys is 255.255.255.0 (if i remember correctly). Should I change these then?

Btw, I needed a crossover cable to connect the linksys with the conexant. Since both are routers a crossover cable is needed. Too bad I realised after I layed down a 20m ethernet cable going from the living room to my room.
N/A

Conexant router and linksys Befw11s4

Are you connecting the WAN port of the Linksys to a/the LAN port on the Conexant? I would expect you'd need a straight-through cable for that, but a crossover cable (if it mattered at all -- they may auto detect) if connecting a LAN port on the Linksys to the LAN port on the Conexant.

The IP address information you've supplied suggests to me you're connecting Linksys LAN to Conexant LAN (either that, or the Linksys is acting as some kind of brige rather than a router). If you're happy with that, leave it as it is, but you should bring the subnet masks into conformity. With the 192.168.1.something addresses you're using, you should specify 255.255.255.0.

If you're connecting Linksys WAN to Conexant LAN, then, again, if it's working (although at the moment I'm not clear as to how that might be so), I'd say leave it as it is. If both are to work as routers and if the Conexant's LAN address is 192.168.0.1 subnet mask 255.255.255.0, then you could set the Linksys WAN address to 192.168.0.2 subnet mask 255.255.255.0 and default gateway 192.168.0.1. The Linksys LAN address could then be something like 192.168.1.1 subnet 255.255.255.0 and the PCs 192.168.1.2-4 subnet 255.255.255.0, default gateway 192.168.1.1 DNS 212.159.13.49 and 212.159.13.50 (and possibly 192.168.1.1 for good measure).
N/A

Conexant router and linksys Befw11s4

As I said in the beginning, my current config doesnt work. I connected the wan port of the linksys to the lan port of the conexant and assigned the ips and subnets I mentioned above. This didnt work so I am gonna assign the ip 192.168.0.1 to the conexant, 192.168.1.1 to the linksys, 255.255.255.0 the subnet for both of them and 192.168.1.X for the pcs with subnet 255.255.255.0.
I also have to declare the wan configuration of the linksys as a static ip and not as "obtain ip automatically" since dhcp server is disabled (anmd it will stay like that) in the conexant. Is this correct?

I ll try it when I get home tonight. Thanks for your help.
N/A

Conexant router and linksys Befw11s4

If the DHCP server on the Conexant is disabled, assign address 192.168.0.2 to the WAN port on the linksys, with subnet mask 255.255.255.0 and default route 192.168.0.1. If it requires DNS settings, give 212.159.13.49 and 212.159.13.50. And if it allows NAT to be on or off, have it enabled.