cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot access Plusnet from G4 Mac

N/A

Cannot access Plusnet from G4 Mac

Hi
I cannot get a Mac to see my router or connect to Plusnet. All five PC's on my network can.
Generally, this should be easy on the Mac, but it's driving me batshit.

I have tried the following in the TCP/IP control panel:
Connect Via: Ethernet
Configure: Using DHCP Server
But that doesn't work as the router has DHCP *DISABLED*. :-(

I have also tried the following manual settings:
Connect via: Ethernet
Configure: Manually
IP address: 192.168.1.x (where x is the IP number of the router)
Subnet mask: 255.255.255.0
Router address: (same as IP address)
Name server address: 212.xxx.xx.xx (where x the DNS proxy used by the router).
I have to say I'm not sure about this one. But in any event it does not seem to be the problem and shouldn't be needed.

After all that the Mac gives me the following error message:
"Another device on your TCP/IP network with the physical MAC address of xx-bb-xx-yy-xx-zz is
currently using the same IP address (192.168.0.x).
Your TCP/IP network installation has been shut down"

The router is a D-Link and known good. Ther Mac is a G4 running OS 9.2.1 and can communicated with the all the PC's on the network perfectly well. It just won't see the router!

My guess is that the Mac is *already* seeing the Router since I can type it's IP into IE and get
straight into the router's web server front end. But when I set up a new TCP/IP connection on the
Mac it thinks there is now a duplicate - hence the error message.

This is the same error I've been getting ever since I got on this merry-go-round! :-(

Anyone have any ideas?
Needless to add Plusnet were useless and offered no advice at all. Apparently they think Macs are some sort of rain coat. :-P

TIA
3 REPLIES
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Re: Cannot access Plusnet from G4 Mac

Quote

I have also tried the following manual settings:
Connect via: Ethernet
Configure: Manually
IP address: 192.168.1.x (where x is the IP number of the router)
Subnet mask: 255.255.255.0
Router address: (same as IP address)


The IP address for the G4 must not be the same as the router, it must be different and unique and must not match any of the other PCs. This is what identifies this PC from the others. It must also be in the same range so try something like 192.168.x.10 - did you really mean 1 for x as the error says it's 0 for x. Whatever the router is set to use that value for x.


Why is DHCP disabled in the router, it makes configuring PCs & Macs much easier unless you are running a web server or SMTP server on your side of the router.
Community Veteran
Posts: 3,181
Thanks: 19
Fixes: 2
Registered: 31-07-2007

Cannot access Plusnet from G4 Mac

@ peter DCHP on Win XP machines can be flakey so probably why

ed: ok didnt want to hijack: if and when the DCHP IP times out the XP machine can fail to get a new IP from the router, requiring the router rebooted to issue new one's. found this out after a number of XP users using different makes of routers on the Origo support forum found this happening. It shouldnt happen but it does.
Unvalued customer since 2001 funding cheap internet for others / DSL/Fibre house move 24 month regrade from 8th May 2017
Community Veteran
Posts: 14,469
Registered: 30-07-2007

Cannot access Plusnet from G4 Mac

It works fine for my network of XP PCs and I suspect most XP systems will be using it. Why do you say it is flakey on XP?