cancel
Showing results for 
Search instead for 
Did you mean: 

Buffalo G54 Airstation and DLink 300G+

N/A

Buffalo G54 Airstation and DLink 300G+

I am pulling my hair out! Got ADSL today and it works a dream with the Dlink 300G+ Ethernet modem connected straight to my PC. Trouble is I want to connect it to my wireless network, but when I plug it into my Buffalo G54, the buffalo can’t seem to talk to it. No errors, just no web! Is anyone running this combo? I have even tried input all the DNS, and IP address by hand but it still doesn’t work! Looks to me as if the G54 should get a IP from the Dlink300G which in turn gets it from PlusNet. The PC can get it from the Dlink so why can’t the G54?

Any ideas much appreciated,

Will
3 REPLIES
N/A

Buffalo G54 Airstation and DLink 300G+

The Buffalo is usually bundled with the X-Modem,
so I don't know if there's a compatabilty issue with the D-link.
If you first try to update the firmware on the modem
via D Link UK website this might help.Try the same with router.
If it does'nt , instead of ticking 'obtain an IP address automatically'
in the Buffalo's WAN (ISP) set up input manually an address in
the range of the D Link eg 192.168.0.2 and enter the default gateway
as the address of the D Link 192.168.0.1 (assumed)
Try the default gateway 192.168.0.254 aswell as this is the gateway
used by modem , when you connect 1 pc.
You could also try Plusnets DNS Servers manually aswell if that don't work.
Check subnet mask's same on both units.
Alec
N/A

Buffalo G54 Airstation and DLink 300G+

Just got connected today and am using the same combination of modem (DLink 300G) and router (Buffalo WBR-G54). While researching ADSL over the last few weeks I came across a posting (can't remember what forum) that explained how to connect these together.

The key seemed to be to setup the modem with a PC directly connected to the modem, check that you are connected to the internet. Then from a DOS/commnd window on the PC (running XP) run the command 'ipconfig /all' make a note of the MAC address (Physical Address) for the connection. Now switch off the modem and connect it to the WAN port on the G54 router and connect the PC to the router (either via wireless or a wired connection). In the 'Advanced/WAN settings/WAN port menu set 'Manual setting' for MAC address of WAN and enter the MAC address from the modem (using ':' instead of '-' between each group of 2 hex numbers). Then go back to the main menu for the router and configure 'DSL' choosing 'Automatic IP Assignment by ISP'. (be patient at a couple of points in this process the router needs to commit values and restart, this can take a couple of minutes, you may also need to check settings for NAT and DHCP and also give time for values to propogate to your PC when you get the WAN connection configured).

This worked for me Shocked (not sure that I understand why this was necessary! hope it also helps you.

It's obviously early for me to tell if this is a stable combination but so far so good (currently testing with a couple of wireless connected laptops)!

Good luck.

Ian
N/A

Buffalo G54 Airstation and DLink 300G+

Thank you very very much. I am now connected through the Buffalo! I had already tried up-grading the firmware but the problem persisted. However when I typed in a manual MAC address it sprung into life! This as far as I understood things shouldn’t work but who cares!

I’d bought the Buffalo about a year ago and was/still-am very happy with it; both linking 4-wired ports in my house and the wireless connection to my laptop. I was beginning to think I was going to have to eBay them both and get a combined unit.
Anyway, both are now going back in my loft where they can stay (hopefully) connected for at least a few years!

I am impressed by PlusNet as a whole, much like Demon was back in the 90’s!

Thanks,

Will :-)