cancel
Showing results for 
Search instead for 
Did you mean: 

Slow upstream speed

FIXED
Highlighted
clivep
Hooked
Posts: 8
Thanks: 1
Registered: ‎17-07-2019

Slow upstream speed

Since joining Plusnet my downstream speed has been as good as with previous suppliers but the upstream speed is lower.

I believe this is caused by the high noise margin figures that the router shows are currently 11.0/5.0.

With previous suppliers these have been 6.0/3.0.

The BT performance test is giving test results of 3.52 Mbps Download and 0.26 Mbps Upload. The further diagnostics give an IP profile for the Downstream of 3.64 Mbps and for Upstream 0.83 Mbps.

The download speed may be improved slightly if the noise margin were reduced but my main concern is the low upload speed.

I called Plusnet and had Question #191724942 raised on 2nd July. This question was closed by Plusnet before I had a chance to see if any improvements were made and post a reply.

In monitoring the router settings since 2nd July I have seen no significant change to the upload speed or noise margin.

 

 

 

16 REPLIES 16
Plusnet Help Team
Plusnet Help Team
Posts: 14,480
Thanks: 348
Fixes: 95
Registered: ‎27-04-2007

Re: Slow upstream speed

Hi there, 

 

I've just tested the line and I can't see any obvious issues at all but we can try resetting the SNR if you like? 

 

The change should be reversible if it were to have any negative impact on your connection. 

 

 

If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
clivep
Hooked
Posts: 8
Thanks: 1
Registered: ‎17-07-2019

Re: Slow upstream speed

Thanks for the very quick response.

Following re-connection the SNR is now showing 11.0/6.3 giving 3.44/0.26 Mbps on the BT Wholesale perormance test. The upstream has not changed but the downstream is slightly worse.

Plusnet Help Team
Plusnet Help Team
Posts: 14,480
Thanks: 348
Fixes: 95
Registered: ‎27-04-2007

Re: Slow upstream speed

OK, no worries. Let us know if you want us to try resetting it. 

 

 

 

 

If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
clivep
Hooked
Posts: 8
Thanks: 1
Registered: ‎17-07-2019

Re: Slow upstream speed

I had assumed the disconnection about an hour ago was due to something you had done at your end. The router currently reports an uptime of 59 minutes.

 

If this wasn't you resetting the SNR then try doing it now but I doubt it will make a difference.

Plusnet Help Team
Plusnet Help Team
Posts: 6,950
Thanks: 709
Fixes: 263
Registered: ‎01-01-2012

Re: Slow upstream speed

Thanks for getting back to us @clivep

From what I can see the drop was due to us testing the line. Our testing in most cases is intrusive which is why this happened.

I've just tested your line as well which will have caused a drop. Your current profile is "BT WBC 8M/Uncapped/6dB/Interleaved (ADSL)" which means your line has a 6db target for both upload and download. Unfortunately, we can't set the target SNR for upstream any lower than 6db but from what we can see your current upload sync speed is 576 with an SNR of 10.6.

Can you try connecting to the test socket if possible as explained here and then see if that gives you a slight increase?

If this post resolved your issue please click the 'This fixed my problem' button
 Matthew Wheeler
 Plusnet Help Team
clivep
Hooked
Posts: 8
Thanks: 1
Registered: ‎17-07-2019

Re: Slow upstream speed

The normal layout is that I have the ADSL microfilter with router and cordless phone base station attached being plugged into the master socket. There is then a cable to another landline phone connected at the back of the removable faceplate of the master socket.

The results of much more testing...

Connecting the microfilter to the test socket gives a small improvement to the upstream performance as expected. The SNR briefly went down to 10.0 before returning to 11.0 but after the latest re-connection it seems to have settled at 10.0. The router reports an upstream data rate of 640 kbps compared with 576 beforehand which is echoed in the BT benchmark speed increase from 0.26 to 0.33 Mbps.

During testing and returning to my original configuration this speed only dropped to a benchmark of 0.29 (router data rate 603 kbps) rather than back to it's original values for some reason.

The downstream SNR actually increased once I started using the test socket and is currently 6.3 but the BT benchmark speed has remained at 3.52 Mbps throughout my tests.

There is no noticeable difference to performance whether or not the cordless phone base station is plugged into the microfilter.

I do not believe there are any problems with the line to the house or within the house. The IP profile from the BT wholesale site is consistent with the limitations of my EO line and it's distance to the exchange.

As you say, my profile is "BT WBC 8M/Uncapped/6dB/Interleaved (ADSL)". I don't expect so have an upstream SNR less than 6.0 but the problem appears to be that this target far from being reached. My previous suppliers (TalkTalk, Sky, EE) all had a 6.0 upstream SNR so is this a problem with your DLM?

I'll keep using the test socket for the time being.

 

Plusnet Help Team
Plusnet Help Team
Posts: 6,950
Thanks: 709
Fixes: 263
Registered: ‎01-01-2012

Re: Slow upstream speed

Thanks for getting back to me @clivep

Your SNR target for your upstream is currently 6db which means that in ideal conditions your upstream SNR should be around 6db.

If it's not currently at that then there may be some underlying noise on the line that may be causing this.

Is it possible for you to connect to the test socket with a different microfilter first and then with your phone unplugged?

I'd also recommend doing a quiet line test by dialing 17070 from your landline to see if there's any noise on your line

If this post resolved your issue please click the 'This fixed my problem' button
 Matthew Wheeler
 Plusnet Help Team
clivep
Hooked
Posts: 8
Thanks: 1
Registered: ‎17-07-2019

Re: Slow upstream speed

17070 does not indicate any noise.

 

Before changes (Plusnet microfilter with Plusnet router & cordless phone base station in test socket) -

Router: Data rate 640/4064

             Maximum 776/4036

             Noise Margin 10.0/6.1

             Attenuation 31.5/60.5

BTW Performance test: Download Speed (Mbps): 3.52
                                         Upload Speed (Mbps) :      0.32

With D-link microfilter -

Router: Data rate 640/4064

             Maximum 816/4128

             Noise Margin 10.0/6.2

             Attenuation 31.5/60.5

Despite the better maximum rates, the BTW performance test actually gave worse results for a while but then settled down to -

BTW Performance test: Download Speed (Mbps): 3.60
                                         Upload Speed (Mbps) :      0.32

 

With D-link microfilter. Cordless phone base station unplugged -

Router: Data rate 640/4064

             Maximum 816/4128

             Noise Margin 10.0/6.3

             Attenuation 31.5/60.5

Despite the same maximum rates, the BTW performance test actually gave a reduced download speed of 3.44 Mbps for a while but then settled down to -

BTW Performance test: Download Speed (Mbps): 3.52
                                         Upload Speed (Mbps) :      0.32

i.e. exactly the same performance as with the old microfilter and phone base station connected.

I'll leave it in the current state for now with the D-link microfilter and no phone.

 

 

Community Veteran
Posts: 5,374
Thanks: 579
Fixes: 25
Registered: ‎10-06-2010

Re: Slow upstream speed

It looks like your line has been set to use ADSL1 although ADSL2+ is available. Plusnet could try changing it to ADSL2+ to find out if that's any better, they could just change it back if it's worse.

Plusnet Help Team
Plusnet Help Team
Posts: 5,053
Thanks: 1,238
Fixes: 240
Registered: ‎25-03-2015

Re: Slow upstream speed

Fix

It looks like @MatthewWheeler has placed that order, hopefully we'll see some improvement on the upload speeds tomorrow.

If this post resolved your issue please click the 'This fixed my problem' button
 Harry Beesley
 Plusnet Infrastructure Operations Professional
clivep
Hooked
Posts: 8
Thanks: 1
Registered: ‎17-07-2019

Re: Slow upstream speed

I think the problem has been correctly identified. I believe I was on ADSL2+ with all the previous suppliers I mentioned.

I had not noticed that the router setting for Mode was ADSL.

It's still showing ADSL but hopefully this will change some time today.

 

Will I need to switch off the router for a few seconds in order to effect the change?

Plusnet Help Team
Plusnet Help Team
Posts: 222
Thanks: 51
Fixes: 16
Registered: ‎25-02-2019

Re: Slow upstream speed

Hi @clivep,

 

You would not to reboot the router as it should re-sync automatically.

If this post resolved your issue please click the 'This fixed my problem' button
 Faris N
 Plusnet Help Team
clivep
Hooked
Posts: 8
Thanks: 1
Registered: ‎17-07-2019

Re: Slow upstream speed

So something seems to have happened overnight as the router uptime is about 4 hours. It's still showing ADSL as the mode so I'm not sure if the router is supposed to show ADSL 2+ or whether the change has not been applied yet.

There certainly have been a few changes...

Router: Data rate 747/3887

             Maximum 748/4188

             Noise Margin 5.9/5.6

             Attenuation 37.8/60.0

BTW Performance test: Download Speed (Mbps): 3.36
                                         Upload Speed (Mbps) :      0.39

The further diagnostics give an IP profile for the Downstream of 3.43 Mbps and for Upstream 0.83 Mbps.

 

Upstream the SNR has dropped, attenuation increased and upload speed increased. These now all seem consistent with figures on ADSL 2+ from previous suppliers.

 

Downstream the speed has dropped slightly as it's now below maximum. It is similar to previous suppliers when on a SNR of 6 during the training period before stabilising a bit better on a SNR of 3.

 

This leads me to conclude that I am probably now on ADSL 2+ and there's a training period to go through. Hopefully this will get me the extra 0.3 Mbps dowload speed back and all will be sorted.

 

Plusnet Help Team
Plusnet Help Team
Posts: 13,385
Thanks: 4,123
Fixes: 665
Registered: ‎21-04-2017

Re: Slow upstream speed

Thanks for getting back to us @clivep 

Yup you're on ADSL2+ now, previously you were on ADSL1 over 21CN services. The current profile is "WBC 160K - 24M Medium delay (INP 1) 6dB Downstream, UC Medium delay (INP 2) 6dB Upstream (ADSL2+)"

It's good to see your upload speed has gone up, hopefully you'll get your download speed back over the next 10 days.

Here's a copy of our testing if you're interested:

xDSL Status Check
Circuit ID: [redacted] Service ID: [redacted]
Telephone NO.: NA Test Executed On: 19-07-2019 11:54:17
xDSL Status Test Summary
Sync Status: Circuit In Sync
General Information
NTE Status:   NTE Power Status: PowerOn Bypass Status:  
 
  Upstream DSL Link Information Downstream DSL Link Information
Loop Loss: 37.8 60.0
SNR Margin: 6.0 6.0
Errored Seconds: 0 1
HEC Errors: 0  
Cell Count: 1928988 15207237
Speed: 747 3887
 
Maximum Stable Rate (KBPS): 3424 Fault Threshold Rate (KBPS): 2739
Mean Time Between Retrains (Seconds): 86400 Mean Time Between Errors Upstream (Seconds): 2400
Indicative Line Quality: G Mean Time Between Errors Downstream (Seconds): 273
If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team