Showing results for 
Search instead for 
Did you mean: 

ST516 v6 help.

Posts: 10
Registered: ‎25-08-2012

ST516 v6 help.

Hi all, I'm having a lot of problems with my 1-port ST516 router.
I wanted to log in to see if there was any settings I could change or new firmware to use to help with a game I'm having trouble with,
but I never got that far.
Every single time since I've had it this router has given me a hard time with username & password, but it has always given in with
a change in case or a reset. Except this time. This time it brings up
Congratulations on purchasing this SpeedTouch residential gateway.
You are currently not connected to the Internet, click on the task below to continue.
Set up my SpeedTouch"
so I click on Set up my Speedtouch and that brings up a plain Username + Pass request box.
This time no combination of resets, reboots, and the user/pass I KNOW is right (my name & serial number),
plus a large number of default ones for this model router without the plusnet firmware, will get it to stop demanding credentials.
I'm completely out of ideas apart from flashing it, and going by my record with this thing it'll just brick.
Tried different browsers to no avail. I never actually changed it from default settings either :p
So has anyone got any bright ideas what is up with it?
I had a search, but nothing quite like what I'm getting is in the results.
Many thanks.
Posts: 9,926
Thanks: 1,267
Fixes: 71
Registered: ‎06-04-2007

Re: ST516 v6 help.

Are you trying to login to the router admin interface or trying to set up the router to connect to the Internet. What you are describing seems like a combination of the two with broadband username and router administration password on older routers.
Have you tried following the instructions in the set-up guide For an Easy Start router the username and password you need are the ones you use to login to the Member Centre