cancel
Showing results for 
Search instead for 
Did you mean: 

SMTP server doesn't advertise STARTTLS in the EHLO - can't send secure

disfroot
Grafter
Posts: 224
Thanks: 6
Registered: ‎28-04-2008

SMTP server doesn't advertise STARTTLS in the EHLO - can't send secure


Hi,
I finally decided to switch to SSL-secured SMTP mail sending after reading about this in the Ironport blog
(http://community.plus.net/blog/2008/11/04/ironport_technical/) but couldn't get it to work. After a little poking
around I discovered the reason
---
>telnet relay.plus.net 25
220 relay.plus.net ESMTP Exim Tue, 07 Apr 2009 17:21:58 +0100
>EHLO
250-ptb-relay02.plus.net Hello [xx.xx.xx.xx]
250-SIZE 104857600
250-PIPELINING
250-AUTH PLAIN LOGIN
250 HELP
>HELP
214-Commands supported:
214 AUTH STARTTLS HELO EHLO MAIL RCPT DATA NOOP QUIT RSET HELP VRFY
>QUIT
221 ptb-relay02.plus.net closing connection
---
If the server supports STARTTLS, why isn't it advertising it in the EHLO response like a
normal Exim SMTP server does ?
(http://www.exim-users.org/forums/showpost.php?p=121370&postcount=2)
I can only assume that this is deliberate ?
Can someone at PlusNet fix this or explain, please ?
3 REPLIES 3
Community Gaffer
Community Gaffer
Posts: 13,942
Thanks: 1,469
Fixes: 119
Registered: ‎04-04-2007

Re: SMTP server doesn't advertise STARTTLS in the EHLO - can't send secure

You're not connecting to the IronPort boxes, you're connecting to our old relays that are currently configured to smart host via the IronPorts. AFAIK when we point relay straight at the IronPorts then we can look at allowing SSL but that's not likely to be for a month or two I'm afraid.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

disfroot
Grafter
Posts: 224
Thanks: 6
Registered: ‎28-04-2008

Re: SMTP server doesn't advertise STARTTLS in the EHLO - can't send secure

er, OK, thanks for taking the trouble to reply.
So there is no way to use SSL with PlusNet e-mail at the moment, then ?
I'm still a bit confused...why do the 'old relays' advertise STARTTLS via the HELP query if they don't support it, then ?
adie:quote
Community Gaffer
Community Gaffer
Posts: 13,942
Thanks: 1,469
Fixes: 119
Registered: ‎04-04-2007

Re: SMTP server doesn't advertise STARTTLS in the EHLO - can't send secure

Quote from: disfroot
So there is no way to use SSL with PlusNet e-mail at the moment, then ?

Nope.
Quote
I'm still a bit confused...why do the 'old relays' advertise STARTTLS via the HELP query if they don't support it, then ?

Not sure tbh, they never have done and as we're getting rid of them I doubt it's something we'd consider doing either.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵