cancel
Showing results for 
Search instead for 
Did you mean: 

HORRENDOUS download speeds even to PN sites

Highlighted
Rising Star
Posts: 158
Thanks: 23
Registered: ‎01-08-2007

HORRENDOUS download speeds even to PN sites

Hi,
I have an (unprecedented) 730kbps download connection... according to my router. For me this is "ludicrous speed". However...
It has taken my browser the better part of half an hour from opening Firefox to getting this page to load and I am also trying to download Firefox 4 which Firefox is telling me is progressing at the fantastic rate of 535 BYTES per second. Internet Explorer is giving me similar pathetic results.
DNS is resolving near-instantly so it's not that... I set up two (throttled) torrents to test pure IP connectivity and that's working fine as well. I've variously tried turning NAT on and off, the broadband firewall on and off, completely turned off my software firewall / antivirus... safe to say it's nothing at that end.
So what's going on?
Quote
Tracing route to community.plus.net [212.159.8.110]
over a maximum of 30 hops:
  1    <1 ms    <1 ms    <1 ms  192.168.1.254
  2  1418 ms  1505 ms  1211 ms  lo0-central2.pcl-ag02.plus.net [195.166.128.236]
  3  1072 ms  1091 ms  583 ms  gi1-24-221.pcl-gw01.plus.net [84.92.6.40]
  4  557 ms  843 ms  738 ms  po5.ptn-gw01.plus.net [212.159.1.131]
  5  1455 ms  841 ms  365 ms  gi3-0.pih-cr1.plus.net [212.159.1.177]
  6  438 ms  491 ms  299 ms  if25.pih-lb03.plus.net [212.159.0.17]
  7  315 ms  281 ms    41 ms  community.plus.net [212.159.8.110]
Trace complete.
C:\Documents and Settings\Tim>tracert community.plus.net
Tracing route to community.plus.net [212.159.8.110]
over a maximum of 30 hops:
  1    <1 ms    <1 ms    <1 ms  192.168.1.254
  2  837 ms  1079 ms  1643 ms  lo0-central2.pcl-ag02.plus.net [195.166.128.236]
  3  1217 ms  1451 ms    *    gi1-24-221.pcl-gw01.plus.net [84.92.6.40]
  4    *        *        *    Request timed out.
  5  865 ms  1362 ms    *    gi3-0.pih-cr1.plus.net [212.159.1.177]
  6    *        *    1740 ms  if25.pih-lb03.plus.net [212.159.0.17]
  7  1211 ms  825 ms  1035 ms  community.plus.net [212.159.8.110]

This is literally unusable.
Oddly, some sites seem reasonably usable - the Google home page for Firefox (for example) loads up in a blisteringly fast twelve seconds.
If you don't get a reply from me over the weekend, please assume I've lost the will to live after accidentally hitting F5.
19 REPLIES 19
Highlighted
Community Veteran
Posts: 38,460
Thanks: 1,032
Fixes: 62
Registered: ‎15-06-2007

Re: HORRENDOUS download speeds even to PN sites

Are you connecting to the router by wireless
Also what does this say for current line speed https://portal.plus.net/my.html?action=data_transfer_speed
Also please post the current router stats - speeds, noise margin and attewnuation.
Normally I would suggest the BT speedtest but with those problems it would take for ever.
Highlighted
Rising Star
Posts: 158
Thanks: 23
Registered: ‎01-08-2007

Re: HORRENDOUS download speeds even to PN sites

Hi,
For interest, I posted the last message at 12:50 so it took the better part of an hour to post the message!
I hit the "reply" button to your message (after turning "download images" off in the browser) at 2pm and it's just loaded the page... at 14:07.
It's a wired connection to a Bipac router.
Quote
ADSL Firmware Version : FwVer:3.10.5.0_TC3085 HwVer:T14.F7_1.0
Line State : Showtime  
Modulation : G.DMT
Annex Mode : ANNEX_A

SNR Margin : 7.0db down,  9.0 db up
Line Attenuation : 63.5db down,  31.5db up
Data Rate : 736kbps down, 448kbps up

Given up trying to load the speed test, because after 10 minutes it's still not finished loading the page.
A tracert to www.plus.net achieved this:
Quote
 1    <1 ms    <1 ms    <1 ms  192.168.1.254
 2  1277 ms  1041 ms   903 ms  lo0-central2.pcl-ag02.plus.net [195.166.128.236]
 3     *        *        *     Request timed out.
 4     *     1117 ms  1287 ms  po5.ptn-gw01.plus.net [212.159.1.131]
 5  1631 ms  1541 ms  1257 ms  gi3-0.pih-cr1.plus.net [212.159.1.177]
 6  1333 ms  1404 ms  1572 ms  if25.pih-lb03.plus.net [212.159.0.17]
 7  1117 ms  1387 ms  1897 ms  portal.plus.net [212.159.8.2]

I tried a traceroute to cnn.com and it's just timing out after exiting the internal PN network.
Quote
Tracing route to www.cnn.com [157.166.255.18]
over a maximum of 30 hops:
 1    <1 ms    <1 ms    <1 ms  192.168.1.254
 2     *     1164 ms  1349 ms  lo0-central2.pcl-ag02.plus.net [195.166.128.236
 3  1149 ms  1545 ms  1407 ms  gi1-24-221.pcl-gw01.plus.net [84.92.6.40]
 4  1499 ms  1773 ms  1285 ms  po4.pcl-gw02.plus.net [212.159.1.129]
 5  1275 ms   973 ms  1909 ms  195.50.122.129
 6  1415 ms     *     1027 ms  ae-34-52.ebr2.London1.Level3.net [4.69.139.97]
 7     *     1211 ms  1513 ms  ae-41-41.ebr1.NewYork1.Level3.net [4.69.137.66]
 8     *        *        *     Request timed out.
 9     *        *        *     Request timed out.
10  1378 ms  1139 ms  1521 ms  ae-6-6.ebr1.Atlanta2.Level3.net [4.69.148.105]
11     *        *        *     Request timed out.
12     *        *        *     Request timed out.
13     *        *        *     Request timed out.
14     *        *        *     Request timed out.
15     *        *        *     Request timed out.
16     *        *        *     Request timed out.
17     *        *        *     Request timed out.
18     *        *        *     Request timed out.
19     *        *        *     Request timed out.
20     *        *        *     Request timed out.
21     *        *        *     Request timed out.

Normally I would expect this tracert to go out to level3.net hosts in London and New York but it's timing out at that point.
So something outside my LAN is the issue, but whether or not it's something PN should be addressing or not, I can't say. Obviously, the way the internet is designed, it should be able to cope with this... and if it's an issue States-side, then why is it affecting my ability to use the PN site and community forums?
The clock on my PC has just bounced over to 14:19 so look at the date/time stamp of the message. It should be 14:19 or thereabouts.
Highlighted
Community Veteran
Posts: 38,460
Thanks: 1,032
Fixes: 62
Registered: ‎15-06-2007

Re: HORRENDOUS download speeds even to PN sites

You didn't post the current line speed - this doesn't require a speed test https://portal.plus.net/my.html?action=data_transfer_speed
Highlighted
Rising Star
Posts: 158
Thanks: 23
Registered: ‎01-08-2007

Re: HORRENDOUS download speeds even to PN sites

With bitmaps turned off, it seems that posting messages is a lot faster! I hit the send button at 14:25 and at 14:29 it finally got round to telling me that you'd posted a message in the interim and asked me to edit the post!
This is completely screwed up.
By the way, I'm still waiting for the "https://portal.plus.net/m...ction=data_transfer_speed" page to finish loading. It's so far got to the point where Firefox has identified the page title as "Member Centre" and the certificate for the SSL connection, and is waiting for a reply from portal.plus.net.
In that browser tab the page has been blank for 20 minutes but it hasn't timed out so it has a connection, albeit one that's slower than 9600 baud dialup on a go-slow.
According to the network diags, the WAN interface is downloading about 50 bytes every 2 seconds.
Router diags say:
Quote
>> Testing Ethernet LAN connection ... PASS 
      >> Testing ADSL Synchronization . PASS 
      >> Testing ATM OAM segment ping ... PASS 
      >> Testing ATM OAM end to end ping ... PASS 
      >> Ping Primary Domain Name Server . PASS 
      >> Ping www.yahoo.com ... PASS

Posting this message at... 14:42 by my clock.
Superuser
Superuser
Posts: 10,060
Thanks: 1,368
Fixes: 75
Registered: ‎06-04-2007

Re: HORRENDOUS download speeds even to PN sites

In case the problem is with the pcl-ag02 gateway you could try disconnecting from Plusnet using the router's web interface (no need to re-sync), wait a minute then connect again. Hopefully that will give you a different gateway.
David
Highlighted
Rising Star
Posts: 158
Thanks: 23
Registered: ‎01-08-2007

Re: HORRENDOUS download speeds even to PN sites

Connected to the 01 gateway now and it is no better.
Happily, the login page for portal.plus.net has FINALLY finished loading!
Highlighted
Community Veteran
Posts: 1,412
Thanks: 4
Registered: ‎29-01-2009

Re: HORRENDOUS download speeds even to PN sites

Those are *really* bad response times as soon as they get off your LAN. Here's my current comparison figures:
Quote
[tt]traceroute to www.plus.net (212.159.9.2), 30 hops max, 60 byte packets
1  router.xxx.org.uk (192.168.0.1)  0.556 ms  1.163 ms  1.450 ms
2  lo0-homesurf.pcl-ag01.plus.net (195.166.128.28)  18.781 ms  20.599 ms  23.499 ms
3  gi1-2-805.pcl-gw01.plus.net (84.92.5.64)  140.078 ms  140.181 ms  140.431 ms
4  gi5-8.ptp-cr01.plus.net (84.93.224.48)  30.581 ms  32.860 ms  35.294 ms
5  vlan2658.ptp-elb02.plus.net (84.93.224.45)  36.762 ms  39.641 ms  42.526 ms
6  vlan2658.ptp-elb02.plus.net (84.93.224.45)  43.449 ms  44.304 ms  45.456 ms
[/tt]

Those suggest that there's a really bad delay between you and PN's edge router. The three areas of concern would be:
- Your ADSL link
- BT's exchange, backhaul, and core IP network
- Plusnet's "central" connection pipe.
There is little you can do about the second item.
The third one you can check - with this URL: http://usertools.plus.net/@gateway/.
You seem to be on "lo0-central2.pcl-ag02.plus.net", so I'm guessing pcl-ag02.
Packet loss can then be seen here: http://www.plus.net/support/service/network_performance/broadband_packets_drop.shtml
If there is a problem, you can try disconnecting, and getting re-allocated to a different pipe.
The first item seems more likely to me... but rather than disconnections, perhaps you are seeing a lot of errors on the line, which are causing delays in sending your packets.
Someone on here had a problem like this in the last few days, where they were getting 200,000 errors per hour - around 95% of their line capacity. They had great problems in getting web pages to finish loading too.
What error figures (CRC, FEC, ES, SES) is your modem reporting? And how are they changing over (say) a 5 minute period?
Plusnet Customer
Using FTTC since 2011. Currently on 80/20 Unlimited Fibre Extra.
Highlighted
Rising Star
Posts: 158
Thanks: 23
Registered: ‎01-08-2007

Re: HORRENDOUS download speeds even to PN sites

I have to wonder if someone from PN has been surreptitiously monitoring this thread because it's suddenly started working properly. By the way, from the client end I wasn't seeing any errors of any kind, anywhere - it was just appallingly slow.
Highlighted
Rising Star
Posts: 158
Thanks: 23
Registered: ‎01-08-2007

Re: HORRENDOUS download speeds even to PN sites

Problem's come back again today. According to the router there are no CRC errors, no collisions or anything like that but it periodically fails a ping test to www.yahoo.com. Name resolution always works.
Quote
>> Testing Ethernet LAN connection ... PASS 
      >> Testing ADSL Synchronization . PASS 
      >> Testing ATM OAM segment ping ... PASS 
      >> Testing ATM OAM end to end ping ... PASS 
      >> Ping Primary Domain Name Server . PASS 
      >> Ping www.yahoo.com ... FAIL
Connection Type : PPPoA
  IP Address : 87.112.154.204
  Subnet Mask : 255.255.255.255
  Default Gateway : 195.166.128.242
  DNS Server : 208.67.222.222
ADSL Firmware Version : FwVer:3.10.5.0_TC3085 HwVer:T14.F7_1.0
  Line State : Showtime 
  Modulation : G.DMT
  Annex Mode : ANNEX_A

  SNR Margin : 7.5db Downstream, 8.0db Upstream
  Line Attenuation : 63.5db Downstream,  31.5db Upstream
  Data Rate : 736kbps Downstream,  448  kbps Upstream

I cannot even get usertools.plus.net to load so cannot check ANY of those settings, the speed test won't load. It's taking 10 minutes for the google home page to load (and that's the one with just the search box and search options, NOT the portal page).
I'm literally having to turn images off just to get pages like this to load and even then it is taking in the order of 30 minutes to actually get to a point where it displays the content and I can respond.
The only error I am seeing on the router is "WANIPConnection->GetGenericPortMappingEntry failed" which is to do with port forwarding (which I don't have configured).
I still have no idea why, if I hit Submit on this page, the response is posted up in a matter of a minute or so but it takes 20 minutes for my browser to get round to showing the target page.
Anyone from PN around who's reading this thread.... HELP! I can raise a call from the office tomorrow, but there's no way I can do it from here. Heck, even Windows Live Messenger is unable to track my status because it's so sllllllllllllooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooww
Highlighted
Community Veteran
Posts: 1,631
Thanks: 25
Registered: ‎29-06-2010

Re: HORRENDOUS download speeds even to PN sites

Might be worth switching from Open DNS (208.67.222.222). Either set it to dynamically assigned, which should get you the PlusNet DNS servers, or if you have some reason for not using those, try Google's - 8.8.8.8 and 8.8.4.4 instead.
Highlighted
Rising Star
Posts: 158
Thanks: 23
Registered: ‎01-08-2007

Re: HORRENDOUS download speeds even to PN sites

Still same issue after changing DNS several times and even putting the PN servers into my local HOSTS file. I set the DOS prompt to show the local time and attempted a traceroute to portal.plus.net with DNS cached to the HOSTS file. Name resolution was near-instant.
Quote
7:43:54.07 >tracert portal.plus.net
Tracing route to portal.plus.net [212.159.8.2]
over a maximum of 30 hops:
  1    <1 ms    <1 ms    <1 ms  192.168.1.254
  2    *        *        *    Request timed out.
  3    *      866 ms  713 ms  gi7-5-531.pcl-gw01.plus.net [84.93.254.65]
  4  1288 ms    *        *    po5.ptn-gw01.plus.net [212.159.1.131]
  5  1095 ms  1447 ms  727 ms  gi3-0.pih-cr1.plus.net [212.159.1.177]
  6  1084 ms  1401 ms  1231 ms  if25.pih-lb03.plus.net [212.159.0.17]
  7  991 ms    *      795 ms  portal.plus.net [212.159.8.2]
Trace complete.
7:44:46.84 >

52 seconds to trace the route from a broadband connection to the PN portal is ludicrous but I haven't seen better than this (from home) for over a week!
Now I have disconnected and reconnected the router well over ten times in the past 48 hours and been connecting to different gateways and the latency does appear to be on the PN network.
My router is still saying there's no collisions, no packet loss, no TCP timeouts and no name resolution issues, but does still occasionally fail the PING test to non-PN hosts.
BitTorrent, perversely, is the only thing running on my machine right now that doesn't seem affected in the slightest (although it's still very slow, ~14kB/s download at best with two high-seeded torrents on the go) and that's despite the fact I've set the antivirus/firewall up to treat BT traffic on a set port, to be checked - ports 80 and 443 are currently open and not subjected to the same level of inspection.
I very rarely use BT myself but every now and again it comes in handy for troubleshooting.
Highlighted
Community Gaffer
Community Gaffer
Posts: 14,184
Thanks: 1,777
Fixes: 136
Registered: ‎04-04-2007

Re: HORRENDOUS download speeds even to PN sites

I'd take a look at things from this side for you but I'm struggling to locate your account from your Community Site username. Have you raised it with our help desk? If you have, perhaps you can provide a ticket reference?

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

Highlighted
Rising Star
Posts: 158
Thanks: 23
Registered: ‎01-08-2007

Re: HORRENDOUS download speeds even to PN sites

User name staddon, ticket number 41358371
Perversely, I just had to log into Yahoo Mail (pinging at 1300ms, wow!) and dig that out from the email because that was more responsive than going to the portal. The PN My Questions page is still loading, while I've been able to read and delete through 4 days' worth of spam.
When I power the router off and on, for about 30 seconds after the DSL connection comes up, everything works okay. Then it just goes rubbish.
Quote
Tracing route to portal.plus.net [212.159.8.2]
over a maximum of 30 hops:
  1    <1 ms    <1 ms    <1 ms  192.168.1.254
  2  1233 ms  871 ms  960 ms  lo0-central2.thn-ag2.plus.net [195.166.128.230]
  3  685 ms  1071 ms  1333 ms  gi1-14-221.thn-gw1.plus.net [84.92.6.200]
  4  1716 ms  1425 ms  1273 ms  po6.ptn-gw01.plus.net [212.159.1.137]
  5    *        *        *    Request timed out.
  6    *    1028 ms  1263 ms  if25.pih-lb03.plus.net [212.159.0.17]
  7  670 ms  593 ms  933 ms  portal.plus.net [212.159.8.2]



Highlighted
Grafter
Posts: 9,786
Registered: ‎16-06-2010

Re: HORRENDOUS download speeds even to PN sites

Hi tstaddon,
I've just done some investigating and your current IP profile is 135k, this has been caused by the number of disconnections as you can see from the graph below. I would firstly have a look at our support pages for dropping connection and if that doesn't help then either raise a fault or call our support center on 08451 400 200

Jojo Smiley