Tuesday 21st October 2014Login | Register
Pages: [1] 2 3 ... 5

Using the Technicolor TG582n in Bridge Mode

« on 27/06/2012, 09:38 »
Hey, I've just set up our Plusnet business broadband service and want to use the included modem/router purely as a modem. I believe this requires it to be in bridge mode and the username password is entered into our main office firewall/router which is a Zyxel Zywall USG100.

The included router is the Technicolor TG582n but nowhere can I find a setting to enable bridge mode, or turn off DCHP, wireless etc. Does anyone know how to achieve this? Is it even possible with this router?

Any help appreciated.
Logged
« Reply #1 on 27/06/2012, 11:39 »
this can be done, but to my knowledge only via CLI commands so it's not a job for the faint-hearted Smiley  Here's some information I've found from Thomson if that helps: http://wiki.aa.org.uk/ima...CLI_Guide_v1.0_public.pdf

Adam Walker
Plusnet Customer Relations Team
Service Status :: RSS :: Email
Twitter :: Facebook :: Plusnet Assist
Logged
« Reply #2 on 27/06/2012, 12:12 »
Wow that looks complicated.
I found a page here on the BE Broadband site which has some info, although I don't know how to use it: http://beusergroup.co.uk/...?title=Technicolor_TG582n

Would you have any idea to use a CLI command? I.E. where do I type it in?
Logged
  • w23
  • Posts: 4344
  • I'm definitely NOT normal, and never have been.
  • View Profile
« Reply #3 on 27/06/2012, 12:17 »
For CLI you'd start with a Telnet command from a connected computer (for Windows this means typing telnet into a command prompt window, also with Vista and Windows 7 you likely need to enable telnet from 'programs & features > windows components as it is probably not enabled by default).

It does sound complicated but if you fancy a go there are plenty of people on here who will try to keep you right.
Call me 'w23' Wink
At any given moment in the universe many things happen. Coincidence is a matter of how close these events are in space, time and relationship.
Opinions expressed in forum posts are those of the poster, others may have different views.
Logged
« Reply #4 on 27/06/2012, 19:46 »
I've found an application note here http://download.modem-hel...fig-Guide-EN-r5.4.zip.php
which describes how to use the Speedtouch CLI to produce various none default configurations. It's actually pretty good at explaining the internal logical connections inside the router and how to use the CLI to produce different configurations.
@gnadv, From what I can see from that document you need the Bridged PPPoE configuration as described in Chapter 4.

So I believe you need to issue the following commands using the CLI.
I've modified the commands from those shown in the example to reflect a VPI/VCI of 0/38 and an Encapsulation of VCMUX as required for PlusNet.  
Quote
ppp relay flush
eth flush
atm flush
ppp flush
atm phonebook flush
atm phonebook add name=BrPPPoE_ph addr=0.38
atm ifadd intf=BrPPPoE_atm
atm ifconfig intf=BrPPPoE_atm dest=BrPPPoE_ph  encaps=vcmux ulp=mac
atm ifattach intf=BrPPPoE_atm
eth bridge ifadd intf=BrPPPoE_br
eth bridge ifconfig intf=BrPPPoE_br dest=BrPPPoE_atm
eth bridge ifattach intf=BrPPPoE_br
saveall
The first 5 commands clear any existing default configuration and then subsequent ones set up the new Bridged PPPoE connection.

I would assume that if it all goes horribly wrong then a factory reset ought to put it back to square one.
Hope that helps.
It will be interesting to hear if that works...
 
 Edit: just looked a little further at the template file for the TG585 here http://www.mattturner.plus.com/bridge.tpl and I'm not sure the Encapsulation needs changing. If that's the case then just leave out the encaps=vcmux from the atm ifconfig command

« Last Edit: 27/06/2012, 20:01 by MisterW »

Logged
« Reply #5 on 05/11/2012, 22:26 »
It will be interesting to hear if that works...

I know this is an old thread but thought it would be useful to update with my experience.
I managed to get this working however had to change the order of some commands to allow me to flush the phonebook.

Thanks to MisterW for getting me started Cool

Found this link  http://whrl.pl/Rcdxwy which gave me a clue as to why some commands were failing.

I reset the router and then issued the following commands:

ppp relay flush
ppp flush
eth flush
atm flush
atm phonebook flush
saveall

and then continued with "atm phonebook add name=BrPPPoE_ph addr=0.38" etc from MisterW's post.

This did the trick and now my firewall is connecting with PPPoE through the TG582n
Logged
« Reply #6 on 05/11/2012, 23:59 »


The included router is the Technicolor TG582n but nowhere can I find a setting to enable bridge mode, or turn off DCHP, wireless etc. Does anyone know how to achieve this? Is it even possible with this router?

 

Enable bridge mode I do not know but to use the router as a network switch disbale DHCP ( see below ) and disable the firewall and it works. If you want the wireless turned off as well that is also possible.


To turn off wireless login to the interface, click on home network, then interfaces, then wireless network plusnet etc, then top right hand corner configure, then untick the top box that says interface  enabled then click on apply.

DHCP off click on home network, click on interfaces, click on local network, top right hand corner click on configure, untick dhcp enabled, and then apply

Jobs a good un.
Logged
« Reply #7 on 12/12/2012, 10:24 »
Hi guys,

first post here so be gentle with me! One of the support guys just pointed me towards this post as a possible fix for something I'm trying to do but I'm struggling to get my head round how to apply this to my particular situation.

Just had Plusnet fibre installed. My main PC is over the other side of the room and for various boring reasons it wasn't possible to set the router up on that side of the room and so I was instead just going to link to it with a Wireless Access Point but I cannot get it working properly.

So, config is: Fibre modem with wired connection to Technicolour Wireless Router. Several wireless devices connecting quite happily to this and then on to the Internet beyond.

Other the other side of the room is a PC to which I had connected (over wired Ethernet) a TP-Link Wireless N Access Point (TL-WA901ND).

I have tried every option I can think of on the Access Point to get it to connect to the Technicolour but can't get it to connect to the Internet. It can be set up in Access Point mode, Client Mode or Repeater Mode (plus a couple of others that aren't really relevant). With some of these I can get the two devices talking together such that, for example, I can access the other device via the PC or a wirelessly connected laptop. So, for example, in Client mode I can get onto the Technicolour router setup page from my PC or onto the Access Point setup page from the laptop. So, they are talking. BUT I can't access the Internet from the PC.

I suspect one of two things is happening: either the Technicolour Router needs a bridging mode activating or I need to disable the DHCP server on the Technicolour router and enable it on the Access Point instead. I have tried every permutation I can think of in terms of turning off DHCP on the Access Point, giving the PC a fixed IP address and so on but none of those seem to work either. I am about to send the Access Point back and just get a Wireless card for the PC instead but this kind of defeats the object and so I thought I'd ask here to see if anyone had any better ideas.

How would I go about testing my two theories - i.e. either/or/and turning off DHCP on the Technicolour/'enabling' Bridge mode. I'm afraid although I've worked with PCs for 20 years I'm not technical enough to get my head round the PDF to sufficient degree to work it out for myself. Neither I nor the really helpful support guy at Plusnet can see a way to turn off DHCP on the Technicolour short of Telnet by the way - there doesn't appear to be an easy box to be unticked as suggested by one of the posters above.

Help!

cheers,

Simon
Logged
« Reply #8 on 12/12/2012, 10:54 »
Hi

I doubt you want to turn off DHCP in the Technicolour  router or use bridge mode - it would cease act as an Access point for all the other WiFi clients.

I am sure that you need to use the TP Link in client mode. You may have to set the TP link to a static IP address in the address range of the Technicolour router.

There is a manual for the TP link @ www.tp-link.it/resources/software/200912243240113.pdf

Richard


Logged
« Reply #9 on 12/12/2012, 11:33 »
As RichardB says, You definitely want the TP Link in Client mode.
Assuming you have the default settings on the Technicolor router...
Set the LAN IP of the TP link to 192.168.1.63 ( that will put it in the same subnet as the Technicolor but on a fixed IP outside the DHCP range )
Disable DHCP on the TP Link ( it ought to do that automatically in Client mode but check it )

That should work. Initially you may have a problem connecting from the PC to the TP Link ( and Technicolor ) if the TP Link hasn't connected as a Client to the Technicolor. If that happens then set a staic IP on the PC ( temporarily ) of 192.168.1.62 with a default gateway of 192.168.1.254. That should enable you to access the TP Link web UI on 192.168.1.63 and check the configuration and wireless connection.
Once it ( the TP link has connected ok wirlessly you should then be able to se the PC back to obtain an IP via DHCP.
Logged
« Reply #10 on 12/12/2012, 11:40 »
Cheers chaps. Will try that tonight when I get back home.
Logged
« Reply #11 on 12/12/2012, 16:23 »
Oh you superstars! That cracked it. Basically I was forgetting to reset my PC back to a non-fixed IP address after establishing the initial connection. As soon as I did that it all worked. Thanks so much guys - really appreciate the help.

cheers,

Simon
Logged
« Reply #12 on 09/01/2013, 23:32 »
Hi,

Just been set up with fibre and thought of recycling my now defunct Technicolor TG582N modem/router as an Ethernet switch so that I could connect multiple network devices to a my mains powerline adapter. Disabling DHCP in the interface option as explained by Hymermanbill in post 6 stopped the device from trying to allocate ip addresses and has consequently provided me with the solution. I am now using it as a switch connected to my powerline, two PC's and a NAS drive with no significant reduction in download speed when connected to the Internet and my other devices on my network.

Next stop is replacing my Powerlines as they are now the bottleneck.

Thanks for your help.



Logged
« Reply #13 on 20/04/2013, 10:08 »
Please excuse my ignorance

Got +net Fibre, tried the settings from above with no luck.

Annoying thing is I asked on 2 separate occasions before choosing if bridged mode was supported and was told yes no problem.

Called support after installation and they told me it not and pointed me here.

I run a separate firewall and host VPN and other service from my network, I previously had BE and I configured the router to act as a modem and pass the ip to my firewall - happy days

I do not know which port (1,2,3) will host this bridged connection.

Does the setting "Home Network\Devices\Assign the public IP address of a connection to a device"  not do something similar to bridged mode.

Is there no way to achieve the above result using the TG582n ?
To Err is Human
Logged
« Reply #14 on 20/04/2013, 10:35 »
I'm assuming your firewall acts as your gateway, running DHCP and routing traffic?

If so just remove the TG582 from your configuration altogether and plug the BT fibre modem directly into the WAN port of your firewall.

You will then need to set up PPPoE on the firewall to connect.
Logged
« Reply #15 on 20/04/2013, 16:19 »
My firewall is configured to route a ton of stuff from inside my network where I have a server that provides dhcp etc.

I tried plugging in the red cable to my firewall but firewall reported no connection.

The problem I have is double NAT, internally is use 10.0.0.0/24 , firewall on 10.0.0.255#
Router comes 192.168.1.4 and provides dhcp with wifi

I want it to be dumb, no dhp, no wifi, login to plusnet and pass resultant ip to my firewall.

Got Static option as well. on plusnet
To Err is Human
Logged
Pages: [1] 2 3 ... 5
Jump to:  

Related Sites

Community Apps

Here at Plusnet we're always trying to use clever open source things to make our lives easier. Sometimes we write our own and make other people's lives easier too!

View the Plusnet Open Source applications page

About Plusnet

We're a Yorkshire-based provider selling broadband and phone services to homes and businesses throughout the UK. Winner of the ISPA 2010 'Best Consumer Customer Service ISP' Award, we're proud to offer the UK's best value standalone broadband.

© Plusnet plc All Rights Reserved. E&OE

Powered by SMF | SMF © 2006-2008, Simple Machines LLC

Add to Technorati Favourites